lensfun/lensfun-0.3.0-INSTALL_HELPER_SCRIPTS.patch
Rex Dieter 700d1ec69d 0.3.0-2
- -DINSTALL_HELPER_SCRIPTS=OFF (with patch)
- -DCMAKE_BUILD_TYPE=Release (defaults to Debug otherwise)
- disable SSE2 on %ix86 (fedora base i686 platform doesn't support it)
- use %buildroot consistently
2014-11-17 11:13:37 -06:00

17 lines
645 B
Diff

diff -up lensfun-0.3.0/docs/CMakeLists.txt.orig lensfun-0.3.0/docs/CMakeLists.txt
--- lensfun-0.3.0/docs/CMakeLists.txt.orig 2014-11-17 11:06:01.842490051 -0600
+++ lensfun-0.3.0/docs/CMakeLists.txt 2014-11-17 11:03:25.823906935 -0600
@@ -22,6 +22,7 @@ ADD_CUSTOM_TARGET(doc
# install documentation
INSTALL(DIRECTORY ${CMAKE_DOC_OUT}/ DESTINATION ${DOCDIR})
+IF(INSTALL_HELPER_SCRIPTS)
# create and install man pages
ADD_CUSTOM_TARGET(man ALL)
ADD_CUSTOM_COMMAND(
@@ -38,3 +39,4 @@ INSTALL(FILES
${CMAKE_CURRENT_BINARY_DIR}/lensfun-add-adapter.1
DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1
)
+ENDIF(INSTALL_HELPER_SCRIPTS)