pkgconfig: fix cflags so lensfun.h is found

This commit is contained in:
Nils Philippsen 2012-07-25 10:46:39 +02:00
parent f8a6261578
commit c8b4e334de
2 changed files with 14 additions and 8 deletions

View File

@ -1,6 +1,7 @@
diff -up lensfun-0.2.6/libs/lensfun/CMakeLists.txt.cmake_pkgconfig lensfun-0.2.6/libs/lensfun/CMakeLists.txt
--- lensfun-0.2.6/libs/lensfun/CMakeLists.txt.cmake_pkgconfig 2012-02-12 05:19:39.000000000 -0600
+++ lensfun-0.2.6/libs/lensfun/CMakeLists.txt 2012-06-28 10:05:08.767440482 -0500
diff --git a/libs/lensfun/CMakeLists.txt b/libs/lensfun/CMakeLists.txt
index ef3dcf0..253a08c 100644
--- a/libs/lensfun/CMakeLists.txt
+++ b/libs/lensfun/CMakeLists.txt
@@ -26,3 +26,8 @@ INSTALL(TARGETS lensfun
RUNTIME DESTINATION ${BINDIR}
LIBRARY DESTINATION ${LIBDIR}
@ -10,9 +11,11 @@ diff -up lensfun-0.2.6/libs/lensfun/CMakeLists.txt.cmake_pkgconfig lensfun-0.2.6
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/lensfun.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc @ONLY)
+INSTALL( FILES ${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc DESTINATION ${LIBDIR}/pkgconfig )
+
diff -up lensfun-0.2.6/libs/lensfun/lensfun.pc.cmake.cmake_pkgconfig lensfun-0.2.6/libs/lensfun/lensfun.pc.cmake
--- lensfun-0.2.6/libs/lensfun/lensfun.pc.cmake.cmake_pkgconfig 2012-06-28 10:05:08.767440482 -0500
+++ lensfun-0.2.6/libs/lensfun/lensfun.pc.cmake 2012-06-28 10:37:50.337917472 -0500
diff --git a/libs/lensfun/lensfun.pc.cmake b/libs/lensfun/lensfun.pc.cmake
new file mode 100644
index 0000000..6d14b12
--- /dev/null
+++ b/libs/lensfun/lensfun.pc.cmake
@@ -0,0 +1,13 @@
+prefix=@CMAKE_INSTALL_PREFIX@
+bindir=@CMAKE_INSTALL_PREFIX@/@BINDIR@
@ -26,4 +29,4 @@ diff -up lensfun-0.2.6/libs/lensfun/lensfun.pc.cmake.cmake_pkgconfig lensfun-0.2
+Version: @VERSION_MAJOR@.@VERSION_MINOR@.@VERSION_MICRO@.@VERSION_BUGFIX@
+Requires.private: glib-2.0
+Libs: -L${libdir} -llensfun
+Cflags: -I${includedir}
+Cflags: -I${includedir} -I${includedir}/lensfun

View File

@ -2,7 +2,7 @@
Name: lensfun
Version: 0.2.6
Summary: Library to rectify defects introduced by photographic lenses
Release: 2%{?dist}
Release: 3%{?dist}
License: LGPLv3 and CC-BY-SA
Group: System Environment/Libraries
@ -92,6 +92,9 @@ rm -rf %{buildroot}
%changelog
* Wed Jul 25 2012 Nils Philippsen <nils@redhat.com> - 0.2.6-3
- pkgconfig: fix cflags so lensfun.h is found
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild