install man pages into their correct place

This commit is contained in:
Nils Philippsen 2014-11-19 19:13:03 +01:00
parent 14c1678b91
commit 8bf698f497
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,22 @@
diff -up lensfun-0.3.0/CMakeLists.txt.mandir lensfun-0.3.0/CMakeLists.txt
--- lensfun-0.3.0/CMakeLists.txt.mandir 2014-09-30 19:37:34.000000000 +0200
+++ lensfun-0.3.0/CMakeLists.txt 2014-11-19 17:48:07.874096303 +0100
@@ -87,6 +87,7 @@ SET(INCLUDEDIR include CACHE PATH "Direc
SET(DATADIR share/lensfun CACHE PATH "Directory for library data files")
SET(TESTSBINDIR share/lensfun/tests CACHE PATH "Directory for test and example programs")
SET(SCRIPTDIR ${BINDIR} CACHE PATH "Directory for helper scripts")
+SET(MANDIR share/man CACHE PATH "Root directory for man page files")
IF(INSTALL_HELPER_SCRIPTS)
FILE(GLOB HELPER_SCRIPTS apps/*)
diff -up lensfun-0.3.0/docs/CMakeLists.txt.mandir lensfun-0.3.0/docs/CMakeLists.txt
--- lensfun-0.3.0/docs/CMakeLists.txt.mandir 2014-11-19 17:48:07.874096303 +0100
+++ lensfun-0.3.0/docs/CMakeLists.txt 2014-11-19 17:51:27.562844291 +0100
@@ -37,6 +37,6 @@ INSTALL(FILES
${CMAKE_CURRENT_BINARY_DIR}/g-lensfun-update-data.1
${CMAKE_CURRENT_BINARY_DIR}/lensfun-update-data.1
${CMAKE_CURRENT_BINARY_DIR}/lensfun-add-adapter.1
- DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/${MANDIR}/man1
)
ENDIF(INSTALL_HELPER_SCRIPTS)

View File

@ -20,6 +20,8 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
## upstreamable patches ## upstreamable patches
# install manpages only when INSTALL_HELPER_SCRIPTS=ON # install manpages only when INSTALL_HELPER_SCRIPTS=ON
Patch1: lensfun-0.3.0-INSTALL_HELPER_SCRIPTS.patch Patch1: lensfun-0.3.0-INSTALL_HELPER_SCRIPTS.patch
# install manpages in the correct place
Patch2: lensfun-0.3.0-mandir.patch
BuildRequires: cmake >= 2.8 BuildRequires: cmake >= 2.8
BuildRequires: doxygen BuildRequires: doxygen
@ -58,6 +60,7 @@ adapters in lensfun.
%setup %setup
%patch1 -p1 -b .INSTALL_HELPER_SCRIPTS %patch1 -p1 -b .INSTALL_HELPER_SCRIPTS
%patch2 -p1 -b .mandir
%build %build
@ -110,6 +113,7 @@ rm -fv %{buildroot}%{_bindir}/g-lensfun-update-data \
%changelog %changelog
* Wed Nov 19 2014 Nils Philippsen <nils@redhat.com> * Wed Nov 19 2014 Nils Philippsen <nils@redhat.com>
- reenable helper scripts - reenable helper scripts
- install man pages into their correct place
* Mon Nov 17 2014 Rex Dieter <rdieter@fedoraproject.org> 0.3.0-3 * Mon Nov 17 2014 Rex Dieter <rdieter@fedoraproject.org> 0.3.0-3
- enable sse only in %%ix86 x86_64, sse2 on x86_64, disable elsewhere - enable sse only in %%ix86 x86_64, sse2 on x86_64, disable elsewhere