This commit is contained in:
Dan Horák 2024-02-01 13:27:04 +01:00
parent 79e8c7064f
commit 4823f8c155
2 changed files with 23 additions and 0 deletions

View File

@ -16,6 +16,8 @@ Source0: https://github.com/lensfun/lensfun/archive/v%{version}/%{name}-%{versio
## upstream patches (master branch)
Patch866: 0866-Pull-isnan-into-std-namespace-include-cmath-not-math.patch
# https://github.com/lensfun/lensfun/commit/ec9412d27d5fa8f377848a59c768b12c243cb80d
Patch1000: python.patch
## upstreamable patches
# install manpages only when INSTALL_HELPER_SCRIPTS=ON
@ -30,6 +32,7 @@ BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(zlib)
%if 0%{?python3:1}
BuildRequires: %{python3} %{python3}-devel
BuildRequires: python3-setuptools
%else
Obsoletes: lensfun-python3 < %{version}-%{release}
Obsoletes: lensfun-tools < %{version}-%{release}
@ -77,6 +80,7 @@ Obsoletes: python34-lensfun < %{version}-%{release}
%patch -P 866 -p1 -b .0866
%patch -P 1000 -p1 -b .1000
%patch -P 200 -p1 -b .INSTALL_HELPER_SCRIPTS

19
python.patch Normal file
View File

@ -0,0 +1,19 @@
commit ec9412d27d5fa8f377848a59c768b12c243cb80d
Author: Simon Raffeiner <info@simonraffeiner.de>
Date: Wed Dec 28 16:24:48 2022 +0100
Port apps/setup.py from Python distutils to setuptools
diff --git a/apps/setup.py.in b/apps/setup.py.in
index d2cba967..4b5ba5cf 100644
--- a/apps/setup.py.in
+++ b/apps/setup.py.in
@@ -3,7 +3,7 @@
"""This setup script installs the “lensfun” package."""
-from distutils.core import setup
+from setuptools import setup
setup(name="lensfun",