ledmon/SOURCES/0004-dont_build_with_werror...

30 lines
937 B
Diff

commit e4ee8feed7a2b460bbb202704072c1927015265f
Author: Adrian Bunk <bunk@debian.org>
Date: Thu Oct 31 12:28:48 2019 +0200
Don't build with -Werror
New compiler versions might output new warnings by default
(see #47 for an example), which makes -Werror problematic
for distributions.
The more specific -Werror= settings are usually not a problem.
The warnings are still shown, but they will no longer break
the build.
Signed-off-by: Adrian Bunk <bunk@debian.org>
diff --git a/configure.ac b/configure.ac
index 7bc20f8..7e01bd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,6 @@ AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
AX_AM_CFLAGS_ADD([-Werror=shift-negative-value])
AX_AM_CFLAGS_ADD([-Werror=alloca])
AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers])
-AX_AM_CFLAGS_ADD([-Werror])
AX_AM_CFLAGS_ADD([-Werror=format-signedness])
AC_SUBST([AM_CFLAGS])