use distribution LDFLAGS during build (#1548551)
This commit is contained in:
parent
234742cb1f
commit
d3e2a6feba
@ -1,7 +1,7 @@
|
||||
Summary: Enclosure LED Utilities
|
||||
Name: ledmon
|
||||
Version: 0.80
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://sourceforge.net/projects/ledmon/
|
||||
@ -26,7 +26,7 @@ use this application.
|
||||
|
||||
%build
|
||||
# can't use smp_flags because -j4 makes the build fail
|
||||
make CFLAGS="$RPM_OPT_FLAGS"
|
||||
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
|
||||
|
||||
%install
|
||||
make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT SBIN_DIR=$RPM_BUILD_ROOT/%{_sbindir} MANDIR=$RPM_BUILD_ROOT%{_mandir}
|
||||
@ -38,6 +38,9 @@ make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT SBIN_DIR=$RPM_BUI
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 26 2018 Jan Synáček <jsynacek@redhat.com> - 0.80-6
|
||||
- use distribution LDFLAGS during build (#1548551)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.80-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ledmon-0.80/src/Makefile 2016-11-25 13:59:48.000000000 +0100
|
||||
+++ ledmon-0.80-new/src/Makefile 2016-12-06 14:03:59.935258740 +0100
|
||||
@@ -57,10 +57,6 @@ LEDCTL_OBJECTS=\
|
||||
+++ ledmon-0.80-new/src/Makefile 2018-02-26 13:06:00.911085377 +0100
|
||||
@@ -57,15 +57,10 @@ LEDCTL_OBJECTS=\
|
||||
$(OUTDIR)/ledctl.o \
|
||||
$(OBJECTS)
|
||||
|
||||
@ -11,3 +11,8 @@
|
||||
DEFFLAGS=-D_DEBUG -D_GNU_SOURCE -D_BSD_SOURCE -DDMALLOC_DISABLE
|
||||
CPPFLAGS=$(DEFFLAGS)
|
||||
ALL_CPPFLAGS=$(CPPFLAGS) -I../config
|
||||
|
||||
-LDFLAGS=$(CXFLAGS)
|
||||
LDLIBS=-lsgutils2
|
||||
|
||||
SOURCES:=$(shell find -name "*.[cC]" -print)
|
||||
|
Loading…
Reference in New Issue
Block a user