update to 1.0.0
Resolves: RHEL-32532,RHEL-23113
This commit is contained in:
parent
8f46e885c4
commit
3bb1fca072
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/ledmon-0.95.tar.gz
|
||||
/ledmon-0.96.tar.gz
|
||||
/ledmon-0.97.tar.gz
|
||||
/ledmon-1.0.0.tar.gz
|
||||
|
56
ledmon.spec
56
ledmon.spec
@ -1,17 +1,20 @@
|
||||
Summary: Enclosure LED Utilities
|
||||
Name: ledmon
|
||||
Version: 0.97
|
||||
Version: 1.0.0
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://github.com/intel/ledmon
|
||||
Source0: https://github.com/intel/ledmon/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: ledmon_format-truncation-flag.patch
|
||||
|
||||
BuildRequires: sg3_utils-devel
|
||||
BuildRequires: pciutils-devel
|
||||
BuildRequires: autoconf automake
|
||||
BuildRequires: autoconf-archive
|
||||
BuildRequires: gcc make
|
||||
BuildRequires: libconfig-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: pciutils-devel
|
||||
BuildRequires: sg3_utils-devel
|
||||
# Needed for pkgconfig usage.
|
||||
BuildRequires: pkgconfig(systemd)
|
||||
# Needed for the udev dependency.
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: systemd-rpm-macros
|
||||
@ -27,20 +30,39 @@ types of system: 2-LED system (Activity LED, Status LED) and 3-LED system
|
||||
(Activity LED, Locate LED, Fail LED). User must have root privileges to
|
||||
use this application.
|
||||
|
||||
%package libs
|
||||
Summary: Runtime library files for %{name}
|
||||
Requires: pciutils-libs
|
||||
Requires: sg3_utils-libs
|
||||
|
||||
%description libs
|
||||
The %{name}-libs package contains runtime libraries for applications
|
||||
that use %{name}.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: pciutils-devel
|
||||
Requires: sg3_utils-devel
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# remove -Werror=format-truncation=1 in order to build package
|
||||
%patch0 -p1
|
||||
autoreconf -fiv
|
||||
|
||||
%build
|
||||
sh autogen.sh
|
||||
%configure --enable-systemd=yes
|
||||
make
|
||||
%configure --enable-systemd=yes --enable-library --disable-static
|
||||
%make_build
|
||||
|
||||
%install
|
||||
%make_install SBIN_DIR=$RPM_BUILD_ROOT/%{_sbindir} MANDIR=$RPM_BUILD_ROOT%{_mandir}
|
||||
|
||||
# These files are not useful for install
|
||||
find %{buildroot} -name '*.la' -delete
|
||||
|
||||
%post
|
||||
%systemd_post ledmon.service
|
||||
|
||||
@ -57,7 +79,19 @@ make
|
||||
%{_mandir}/*/*
|
||||
%{_unitdir}/ledmon.service
|
||||
|
||||
%files libs
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
%changelog
|
||||
* Fri Apr 12 2024 Jan Macku <jamacku@redhat.com> - 1.0.0-1
|
||||
- update to 1.0.0
|
||||
- package shared ledmon library by Tony Asleson
|
||||
|
||||
* Wed May 17 2023 Jan Macku <jamacku@redhat.com> - 0.97-1
|
||||
- update to 0.97 (#2159926)
|
||||
- drop ipmi-avoid-error-messages-on-non-dell-platforms.patch
|
||||
|
@ -1,26 +0,0 @@
|
||||
From a82b0e4080254e68eb70a338f8f6f7e6a6dbc581 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Macku <jamacku@redhat.com>
|
||||
Date: Tue, 2 Feb 2021 11:08:20 +0100
|
||||
Subject: [PATCH] ledmon_format-truncation-flag
|
||||
|
||||
suggested by kdudka
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 8fd5e6b..b80e2b0 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -22,7 +22,7 @@ AM_CPPFLAGS='-D_DEBUG -D_GNU_SOURCE -D_DEFAULT_SOURCE -DDMALLOC_DISABLE -DBUILD_
|
||||
AC_DEFUN([AX_AM_CFLAGS_ADD],[AX_CHECK_COMPILE_FLAG($1, AM_CFLAGS="$AM_CFLAGS $1")])
|
||||
AX_AM_CFLAGS_ADD([-Wformat -Werror=format-security])
|
||||
AX_AM_CFLAGS_ADD([-Werror=format-overflow=2])
|
||||
-AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
|
||||
+dnl AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
|
||||
AX_AM_CFLAGS_ADD([-Werror=shift-negative-value])
|
||||
AX_AM_CFLAGS_ADD([-Werror=alloca])
|
||||
AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers])
|
||||
--
|
||||
2.29.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ledmon-0.97.tar.gz) = 7a8f6c6f7cbaa10ae17ee60c2dfbce4100524b9b85fdc01a139f1fd2a33779348845df29b93f6c2cbabed4fa92a2a17a80636c2658e13507743bd2242fc08914
|
||||
SHA512 (ledmon-1.0.0.tar.gz) = af4dcfaf0284cfc5d88f09d2b4974514f40901c26c640a12ba4ae9bbe16e29e0ca975bc413cf155996162b324b5d365e7bc0306db0329aa755df690ac541a3a6
|
||||
|
Loading…
Reference in New Issue
Block a user