75c9028095
- Enable new upgrade path for RHEL 8.10 -> RHEL 9.4 (including RHEL with SAP HANA) - Introduce generic transition of systemd services states during the IPU - Introduce possibility to upgrade with local repositories - Improve possibilities of upgrade when a proxy is configured in DNF configutation file - Fix handling of symlinks under /etc/pki when managing certificates - Fix the upgrade with custom https repositories - Default to the NO_RHSM mode when subscription-manager is not installed - Detect customized configuration of dynamic linker - Drop the invalid `tuv` target channel for the --channel option - Fix the issue of going out of bounds in the isccfg parser - Fix traceback when saving the rhsm facts results and the /etc/rhsm/facts directory doesn’t exist yet - Load all rpm repository substitutions that dnf knows about, not just "releasever" only - Simplify handling of upgrades on systems using RHUI, reducing the maintenance burden for cloud providers - Detect possible unexpected RPM GPG keys has been installed during RPM transaction - Resolves: RHEL-16729
61 lines
2.8 KiB
Diff
61 lines
2.8 KiB
Diff
From c81731f04c479fd9212458054d9ba21daa8e4780 Mon Sep 17 00:00:00 2001
|
|
From: Jakub Jelen <jjelen@redhat.com>
|
|
Date: Mon, 26 Jun 2023 16:29:45 +0200
|
|
Subject: [PATCH 39/41] Fix several typos and Makefile help
|
|
|
|
- CheckSystemdServicesTasks: Fix typo in the phase name in comment
|
|
- utils: fix typo in comment
|
|
- Makefile: Fix example in help to actually work
|
|
|
|
Squashed by Petr Stodulka <pstodulk@redhat.com>
|
|
|
|
Signed-off-by: Jakub Jelen <jjelen@redhat.com>
|
|
---
|
|
Makefile | 2 +-
|
|
.../common/actors/systemd/checksystemdservicetasks/actor.py | 2 +-
|
|
repos/system_upgrade/common/libraries/utils.py | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index e3c40e01..b504a854 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -155,7 +155,7 @@ help:
|
|
@echo " PR=7 SUFFIX='my_additional_suffix' make <target>"
|
|
@echo " MR=6 COPR_CONFIG='path/to/the/config/copr/file' make <target>"
|
|
@echo " ACTOR=<actor> TEST_LIBS=y make test"
|
|
- @echo " BUILD_CONTAINER=el7 make build_container"
|
|
+ @echo " BUILD_CONTAINER=rhel7 make build_container"
|
|
@echo " TEST_CONTAINER=f34 make test_container"
|
|
@echo " CONTAINER_TOOL=docker TEST_CONTAINER=rhel7 make test_container_no_lint"
|
|
@echo ""
|
|
diff --git a/repos/system_upgrade/common/actors/systemd/checksystemdservicetasks/actor.py b/repos/system_upgrade/common/actors/systemd/checksystemdservicetasks/actor.py
|
|
index 547a13df..272ebc1f 100644
|
|
--- a/repos/system_upgrade/common/actors/systemd/checksystemdservicetasks/actor.py
|
|
+++ b/repos/system_upgrade/common/actors/systemd/checksystemdservicetasks/actor.py
|
|
@@ -14,7 +14,7 @@ class CheckSystemdServicesTasks(Actor):
|
|
- enabled and disabled. This actor inhibits upgrade in such cases.
|
|
|
|
Note: We expect that SystemdServicesTasks could be produced even after the
|
|
- TargetTransactionChecksPhase (e.g. during the ApplicationPhase). The
|
|
+ TargetTransactionChecksPhase (e.g. during the ApplicationsPhase). The
|
|
purpose of this actor is to report collisions in case we can already detect
|
|
them. In case of conflicts caused by messages produced later we just log
|
|
the collisions and the services will end up disabled.
|
|
diff --git a/repos/system_upgrade/common/libraries/utils.py b/repos/system_upgrade/common/libraries/utils.py
|
|
index cd3ad1a6..38b9bb1a 100644
|
|
--- a/repos/system_upgrade/common/libraries/utils.py
|
|
+++ b/repos/system_upgrade/common/libraries/utils.py
|
|
@@ -14,7 +14,7 @@ def parse_config(cfg=None, strict=True):
|
|
"""
|
|
Applies a workaround to parse a config file using py3 AND py2
|
|
|
|
- ConfigParser has a new def to read strings/iles in Py3, making
|
|
+ ConfigParser has a new def to read strings/files in Py3, making
|
|
the old ones (Py2) obsoletes, these function was created to use the
|
|
ConfigParser on Py2 and Py3
|
|
|
|
--
|
|
2.41.0
|
|
|