Update ELevate vendors patch:
- remove 0006-ReadOfKernelArgsError-fix-the-error.patch code as it is already on upstream - add '9.6' to supported versions - remove '9.6' target from upgrade path until it is not released - Add postgreSQL aarch64 packages '6c7cb6ef305d49d6' signature The package .spec: - put back patches: - 0006-ReadOfKernelArgsError-fix-the-error.patch - 0039-Enable-IPU-for-EL-9.6-and-drop-EL-8.8-9.2.patch - update changelog
This commit is contained in:
parent
606b51428e
commit
bdffdfd055
@ -3557,10 +3557,10 @@ index 00000000..0e2ba8ab
|
||||
+ end
|
||||
+end
|
||||
diff --git a/commands/command_utils.py b/commands/command_utils.py
|
||||
index 4f6f99eb..84117483 100644
|
||||
index 190f5f03..e264ced4 100644
|
||||
--- a/commands/command_utils.py
|
||||
+++ b/commands/command_utils.py
|
||||
@@ -13,7 +13,7 @@ LEAPP_UPGRADE_FLAVOUR_DEFAULT = 'default'
|
||||
@@ -16,7 +16,7 @@ LEAPP_UPGRADE_FLAVOUR_DEFAULT = 'default'
|
||||
LEAPP_UPGRADE_FLAVOUR_SAP_HANA = 'saphana'
|
||||
LEAPP_UPGRADE_PATHS = 'upgrade_paths.json'
|
||||
|
||||
@ -3579,10 +3579,10 @@ index 00000000..c6694a8e
|
||||
+### Useful for packages that have identical version strings but contain binary changes between major OS versions
|
||||
+### Packages that aren't installed will be skipped
|
||||
diff --git a/repos/system_upgrade/common/actors/addupgradebootentry/libraries/addupgradebootentry.py b/repos/system_upgrade/common/actors/addupgradebootentry/libraries/addupgradebootentry.py
|
||||
index 553ffc35..6af3ef8d 100644
|
||||
index b236e39b..af02f1a6 100644
|
||||
--- a/repos/system_upgrade/common/actors/addupgradebootentry/libraries/addupgradebootentry.py
|
||||
+++ b/repos/system_upgrade/common/actors/addupgradebootentry/libraries/addupgradebootentry.py
|
||||
@@ -84,7 +84,7 @@ def figure_out_commands_needed_to_add_entry(kernel_path, initramfs_path, args_to
|
||||
@@ -89,7 +89,7 @@ def figure_out_commands_needed_to_add_entry(kernel_path, initramfs_path, args_to
|
||||
'/usr/sbin/grubby',
|
||||
'--add-kernel', '{0}'.format(kernel_path),
|
||||
'--initrd', '{0}'.format(initramfs_path),
|
||||
@ -3592,10 +3592,10 @@ index 553ffc35..6af3ef8d 100644
|
||||
'--make-default',
|
||||
'--args', args_to_add_str
|
||||
diff --git a/repos/system_upgrade/common/actors/addupgradebootentry/tests/unit_test_addupgradebootentry.py b/repos/system_upgrade/common/actors/addupgradebootentry/tests/unit_test_addupgradebootentry.py
|
||||
index c4f5232b..b6d2e235 100644
|
||||
index 2f58ba9e..b15f96b5 100644
|
||||
--- a/repos/system_upgrade/common/actors/addupgradebootentry/tests/unit_test_addupgradebootentry.py
|
||||
+++ b/repos/system_upgrade/common/actors/addupgradebootentry/tests/unit_test_addupgradebootentry.py
|
||||
@@ -49,7 +49,7 @@ run_args_add = [
|
||||
@@ -50,7 +50,7 @@ run_args_add = [
|
||||
'/usr/sbin/grubby',
|
||||
'--add-kernel', '/abc',
|
||||
'--initrd', '/def',
|
||||
@ -3903,36 +3903,6 @@ index 9e213f64..52cfe14f 100644
|
||||
variant=data.get('VARIANT', '').strip('"') or None,
|
||||
variant_id=data.get('VARIANT_ID', '').strip('"') or None
|
||||
)
|
||||
diff --git a/repos/system_upgrade/common/actors/kernelcmdlineconfig/libraries/kernelcmdlineconfig.py b/repos/system_upgrade/common/actors/kernelcmdlineconfig/libraries/kernelcmdlineconfig.py
|
||||
index 238a8aa6..6b261c3b 100644
|
||||
--- a/repos/system_upgrade/common/actors/kernelcmdlineconfig/libraries/kernelcmdlineconfig.py
|
||||
+++ b/repos/system_upgrade/common/actors/kernelcmdlineconfig/libraries/kernelcmdlineconfig.py
|
||||
@@ -175,14 +175,14 @@ def entrypoint(configs=None):
|
||||
api.current_logger().error(str(e))
|
||||
|
||||
if use_cmdline_file():
|
||||
- report_hint = reporting.Hints(
|
||||
+ report_hint = (
|
||||
'After the system has been rebooted into the new version of RHEL, you'
|
||||
' should take the kernel cmdline arguments from /proc/cmdline (Everything'
|
||||
' except the BOOT_IMAGE entry and initrd entries) and copy them into'
|
||||
' /etc/kernel/cmdline before installing any new kernels.'
|
||||
)
|
||||
else:
|
||||
- report_hint = reporting.Hints(
|
||||
+ report_hint = (
|
||||
'After the system has been rebooted into the new version of RHEL, you'
|
||||
' should take the kernel cmdline arguments from /proc/cmdline (Everything'
|
||||
' except the BOOT_IMAGE entry and initrd entries) and then use the'
|
||||
@@ -204,7 +204,7 @@ def entrypoint(configs=None):
|
||||
' not able to set the arguments as the default for kernels installed in'
|
||||
' the future.'
|
||||
),
|
||||
- report_hint,
|
||||
+ reporting.Remediation(hint=report_hint),
|
||||
reporting.Severity(reporting.Severity.HIGH),
|
||||
reporting.Groups([
|
||||
reporting.Groups.BOOT,
|
||||
diff --git a/repos/system_upgrade/common/actors/missinggpgkeysinhibitor/libraries/missinggpgkey.py b/repos/system_upgrade/common/actors/missinggpgkeysinhibitor/libraries/missinggpgkey.py
|
||||
index 32e4527b..1e595e9a 100644
|
||||
--- a/repos/system_upgrade/common/actors/missinggpgkeysinhibitor/libraries/missinggpgkey.py
|
||||
@ -4745,7 +4715,7 @@ index 59b12c87..85d4a09e 100644
|
||||
def process(self):
|
||||
self.produce(systemfacts.get_sysctls_status())
|
||||
diff --git a/repos/system_upgrade/common/actors/targetuserspacecreator/libraries/userspacegen.py b/repos/system_upgrade/common/actors/targetuserspacecreator/libraries/userspacegen.py
|
||||
index cd2d7d6e..ae5bdca5 100644
|
||||
index 12736ab7..f90bf6e3 100644
|
||||
--- a/repos/system_upgrade/common/actors/targetuserspacecreator/libraries/userspacegen.py
|
||||
+++ b/repos/system_upgrade/common/actors/targetuserspacecreator/libraries/userspacegen.py
|
||||
@@ -152,9 +152,10 @@ def _import_gpg_keys(context, install_root_dir, target_major_version):
|
||||
@ -4762,7 +4732,7 @@ index cd2d7d6e..ae5bdca5 100644
|
||||
except CalledProcessError as exc:
|
||||
raise StopActorExecutionError(
|
||||
message=(
|
||||
@@ -629,6 +630,7 @@ def _prep_repository_access(context, target_userspace):
|
||||
@@ -639,6 +640,7 @@ def _prep_repository_access(context, target_userspace):
|
||||
run(["chroot", target_userspace, "/bin/bash", "-c", "su - -c update-ca-trust"])
|
||||
|
||||
if not rhsm.skip_rhsm():
|
||||
@ -5029,17 +4999,18 @@ index 00000000..51607273
|
||||
+
|
||||
+}
|
||||
diff --git a/repos/system_upgrade/common/files/distro/centos/gpg-signatures.json b/repos/system_upgrade/common/files/distro/centos/gpg-signatures.json
|
||||
index 547b13e7..61a00c03 100644
|
||||
index 547b13e7..73a9598f 100644
|
||||
--- a/repos/system_upgrade/common/files/distro/centos/gpg-signatures.json
|
||||
+++ b/repos/system_upgrade/common/files/distro/centos/gpg-signatures.json
|
||||
@@ -2,7 +2,23 @@
|
||||
@@ -2,7 +2,24 @@
|
||||
"keys": [
|
||||
"24c6a8a7f4a80eb5",
|
||||
"05b555b38483c65d",
|
||||
- "4eb84e71f2ee9d55"
|
||||
+ "4eb84e71f2ee9d55",
|
||||
+ "429785e181b961a5",
|
||||
+ "d07bf2a08d50eb66"
|
||||
+ "d07bf2a08d50eb66",
|
||||
+ "6c7cb6ef305d49d6"
|
||||
],
|
||||
- "obsoleted-keys": {}
|
||||
+ "obsoleted-keys": {
|
||||
@ -5255,27 +5226,26 @@ index 34f7b8f9..acba532c 100644
|
||||
|
||||
if self.opts.tid[0] == 'check':
|
||||
diff --git a/repos/system_upgrade/common/files/upgrade_paths.json b/repos/system_upgrade/common/files/upgrade_paths.json
|
||||
index 5399f148..d162762c 100644
|
||||
index cc9dcdb5..5ce5a666 100644
|
||||
--- a/repos/system_upgrade/common/files/upgrade_paths.json
|
||||
+++ b/repos/system_upgrade/common/files/upgrade_paths.json
|
||||
@@ -1,11 +1,10 @@
|
||||
@@ -1,10 +1,10 @@
|
||||
{
|
||||
"default": {
|
||||
- "7.9": ["8.8", "8.10"],
|
||||
- "8.8": ["9.2"],
|
||||
- "8.10": ["9.4", "9.5"],
|
||||
- "7.9": ["8.10"],
|
||||
- "8.10": ["9.4", "9.5", "9.6"],
|
||||
+ "7.9": ["8.7", "8.8", "8.9", "8.10"],
|
||||
+ "8.10": ["9.0", "9.1", "9.2", "9.3", "9.4", "9.5"],
|
||||
"9.6": ["10.0"],
|
||||
- "7": ["8.8", "8.10"],
|
||||
- "8": ["9.2", "9.4", "9.5"],
|
||||
- "7": ["8.10"],
|
||||
- "8": ["9.4", "9.5", "9.6"],
|
||||
+ "7": ["8.7", "8.8", "8.9", "8.10"],
|
||||
+ "8": ["9.0", "9.1", "9.2", "9.3", "9.4", "9.5"],
|
||||
"9": ["10.0"]
|
||||
},
|
||||
"saphana": {
|
||||
diff --git a/repos/system_upgrade/common/libraries/config/version.py b/repos/system_upgrade/common/libraries/config/version.py
|
||||
index 152d9112..c61a5581 100644
|
||||
index d710a647..1cdfa0e4 100644
|
||||
--- a/repos/system_upgrade/common/libraries/config/version.py
|
||||
+++ b/repos/system_upgrade/common/libraries/config/version.py
|
||||
@@ -17,9 +17,9 @@ OP_MAP = {
|
||||
@ -5283,11 +5253,11 @@ index 152d9112..c61a5581 100644
|
||||
_SUPPORTED_VERSIONS = {
|
||||
# Note: 'rhel-alt' is detected when on 'rhel' with kernel 4.x
|
||||
- '7': {'rhel': ['7.9'], 'rhel-alt': [], 'rhel-saphana': ['7.9']},
|
||||
- '8': {'rhel': ['8.8', '8.10'], 'rhel-saphana': ['8.8', '8.10']},
|
||||
- '8': {'rhel': ['8.10'], 'rhel-saphana': ['8.10']},
|
||||
- '9': {'rhel': ['9.4', '9.5', '9.6'], 'rhel-saphana': ['9.4', '9.6']},
|
||||
+ '7': {'rhel': ['7.9'], 'rhel-alt': [], 'rhel-saphana': ['7.9'], 'centos': ['7.9'], 'eurolinux': ['7.9'], 'ol': ['7.9'], 'scientific': ['7.9']},
|
||||
+ '8': {'rhel': ['8.8', '8.10'], 'rhel-saphana': ['8.8', '8.10'], 'centos': ['8.5', '8.999'], 'almalinux': ['8.6', '8.7', '8.8', '8.9', '8.10'], 'eurolinux': ['8.6', '8.7', '8.8', '8.9', '8.10'], 'ol': ['8.6', '8.7', '8.8', '8.9', '8.10'], 'rocky': ['8.6', '8.7', '8.8', '8.9', '8.10']},
|
||||
+ '9': {'rhel': ['9.4', '9.5', '9.6'], 'rhel-saphana': ['9.4', '9.6'], 'centos': ['9.999'], 'almalinux': ['9.4', '9.5'], 'eurolinux': ['9.4', '9.5'], 'ol': ['9.4', '9.5'], 'rocky': ['9.4', '9.5']},
|
||||
+ '9': {'rhel': ['9.4', '9.5', '9.6'], 'rhel-saphana': ['9.4', '9.6'], 'centos': ['9.999'], 'almalinux': ['9.4', '9.5', '9.6'], 'eurolinux': ['9.4', '9.5', '9.6'], 'ol': ['9.4', '9.5', '9.6'], 'rocky': ['9.4', '9.5', '9.6']},
|
||||
}
|
||||
|
||||
|
||||
|
@ -281,7 +281,7 @@ Requires: libdb-utils
|
||||
%patch -P 0003 -p1
|
||||
%patch -P 0004 -p1
|
||||
%patch -P 0005 -p1
|
||||
# %patch -P 0006 -p1 # the patch is a part of Vendors support
|
||||
%patch -P 0006 -p1
|
||||
%patch -P 0007 -p1
|
||||
%patch -P 0008 -p1
|
||||
%patch -P 0009 -p1
|
||||
@ -314,7 +314,7 @@ Requires: libdb-utils
|
||||
%patch -P 0036 -p1
|
||||
%patch -P 0037 -p1
|
||||
%patch -P 0038 -p1
|
||||
# %patch -P 0039 -p1 # ELevate provides own upgrade_paths.json and version.py
|
||||
%patch -P 0039 -p1
|
||||
%patch -P 0040 -p1
|
||||
%patch -P 0041 -p1
|
||||
%patch -P 0100 -p1
|
||||
@ -402,11 +402,14 @@ done;
|
||||
# no files here
|
||||
|
||||
%changelog
|
||||
* Mon Nov 25 2024 Yuriy Kohut <ykohut@almalinux.org> - 0.21.0-4.elevate.1
|
||||
- Skip patches:
|
||||
- 0006-ReadOfKernelArgsError-fix-the-error.patch
|
||||
- 0039-Enable-IPU-for-EL-9.6-and-drop-EL-8.8-9.2.patch
|
||||
- Exclude data files (from /etc/leapp/files) which are part of leapp-data-*: device_driver_deprecation_data.json, pes-events.json, repomap.json
|
||||
* Tue Nov 26 2024 Yuriy Kohut <ykohut@almalinux.org> - 0.21.0-4.elevate.1
|
||||
- Update ELevate patch:
|
||||
- remove 0006-ReadOfKernelArgsError-fix-the-error.patch code as it is already on upstream
|
||||
- add '9.6' to supported versions
|
||||
- remove '9.6' target from upgrade path until it is not released
|
||||
- Add postgreSQL aarch64 packages '6c7cb6ef305d49d6' signature
|
||||
- The package .spec:
|
||||
- exclude data files (from /etc/leapp/files) which are part of leapp-data-*: device_driver_deprecation_data.json, pes-events.json, repomap.json
|
||||
|
||||
* Tue Nov 19 2024 Matej Matuska <mmatuska@redhat.com> - 0.21.0-4
|
||||
- Use net.naming-scheme by default
|
||||
|
Loading…
Reference in New Issue
Block a user