- Call javadoc with sourcepath to work aroung gjdoc bug (#170611)
This commit is contained in:
parent
ea0bf49954
commit
b668af5dec
11
ldap-gjdoc.patch
Normal file
11
ldap-gjdoc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- mozilla/directory/java-sdk/ldap.mk 2005-11-04 23:44:56.000000000 -0500
|
||||
+++ mozilla/directory/java-sdk/ldap.mk.new 2005-11-04 23:45:29.000000000 -0500
|
||||
@@ -158,7 +158,7 @@
|
||||
endif
|
||||
|
||||
ifndef JAVADOC
|
||||
- JAVADOC=$(JDKBIN)javadoc -classpath "$(JAVACLASSPATH)$(SEP)$(BASEDIR)/ldapbeans"
|
||||
+ JAVADOC=$(JDKBIN)javadoc -classpath "$(JAVACLASSPATH)$(SEP)$(BASEDIR)/ldapbeans" -sourcepath ldapjdk:ldapbeans:ldapfilter
|
||||
endif
|
||||
|
||||
# Destination for class files and packages
|
@ -3,7 +3,7 @@
|
||||
%define version 4.17
|
||||
%define tar_name ldapsdk_java
|
||||
%define tar_version 20020819
|
||||
%define release 1jpp_2fc
|
||||
%define release 1jpp_3fc
|
||||
%define section free
|
||||
%define use_nonfree %{?_with_nonfree:1}%{!?_without_nonfree:0}
|
||||
|
||||
@ -23,6 +23,8 @@ Source0: %{tar_name}_%{tar_version}_clean.tar.gz
|
||||
# FIXME: A jpackage must be created for the
|
||||
# Mozilla Network Security Services for Java (JSS)
|
||||
Source2: jss34.jar
|
||||
Patch0: ldap-gjdoc.patch
|
||||
Patch1: ldapsp-gjdoc.patch
|
||||
|
||||
Requires: oro
|
||||
Requires: jndi
|
||||
@ -60,6 +62,8 @@ Javadoc for %{name}
|
||||
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
|
||||
# delete stuff that doesn't work with libgcj (#132524).
|
||||
if java -version 2>&1 | grep -q "gcj"; then
|
||||
@ -134,6 +138,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_javadocdir}/%{name}-%{version}/*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 5 2005 Archit Shah <ashah@redhat.com> 0:4.17-1jpp_3fc
|
||||
- Call javadoc with sourcepath to work aroung gjdoc bug (#170611)
|
||||
|
||||
* Thu Jan 27 2005 Gary Benson <gbenson@redhat.com> 0:4.17-1jpp_2fc
|
||||
- Remove non-distributable files from the source tarball.
|
||||
|
||||
|
11
ldapsp-gjdoc.patch
Normal file
11
ldapsp-gjdoc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- mozilla/directory/java-sdk/ldapsp.mk 2005-11-04 23:45:01.000000000 -0500
|
||||
+++ mozilla/directory/java-sdk/ldapsp.mk.new 2005-11-04 23:45:35.000000000 -0500
|
||||
@@ -92,7 +92,7 @@
|
||||
endif
|
||||
|
||||
ifndef JAVADOC
|
||||
- JAVADOC=$(JDKBIN)javadoc -classpath "$(JAVACLASSPATH)"
|
||||
+ JAVADOC=$(JDKBIN)javadoc -classpath "$(JAVACLASSPATH)" -sourcepath ldapsp
|
||||
endif
|
||||
|
||||
all: classes
|
Loading…
Reference in New Issue
Block a user