lcms2-2.9 (#1512518), .spec cosmetics/modernization
This commit is contained in:
parent
3e7917d9a9
commit
a72e12b3c4
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ lcms2-2.0a.tar.gz
|
||||
/lcms2-2.7rc3.tar.gz
|
||||
/lcms2-2.7.tar.gz
|
||||
/lcms2-2.8.tar.gz
|
||||
/lcms2-2.9.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 5ca71a7bc18b6897ab21d815d15e218e204581e2 Mon Sep 17 00:00:00 2001
|
||||
From: Marti <marti.maria@tktbrainpower.com>
|
||||
Date: Mon, 15 Aug 2016 23:31:39 +0200
|
||||
Subject: [PATCH] Added an extra check to MLU bounds
|
||||
|
||||
Thanks to Ibrahim el-sayed for spotting the bug
|
||||
---
|
||||
src/cmstypes.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/cmstypes.c b/src/cmstypes.c
|
||||
index cb61860..c7328b9 100644
|
||||
--- a/src/cmstypes.c
|
||||
+++ b/src/cmstypes.c
|
||||
@@ -1460,6 +1460,7 @@ void *Type_MLU_Read(struct _cms_typehandler_struct* self, cmsIOHANDLER* io, cmsU
|
||||
|
||||
// Check for overflow
|
||||
if (Offset < (SizeOfHeader + 8)) goto Error;
|
||||
+ if ((Offset + Len) > SizeOfTag + 8) goto Error;
|
||||
|
||||
// True begin of the string
|
||||
BeginOfThisString = Offset - SizeOfHeader - 8;
|
||||
--
|
||||
2.7.4
|
||||
|
20
lcms2.spec
20
lcms2.spec
@ -1,15 +1,12 @@
|
||||
Name: lcms2
|
||||
Version: 2.8
|
||||
Release: 5%{?dist}
|
||||
Version: 2.9
|
||||
Release: 1%{?dist}
|
||||
Summary: Color Management Engine
|
||||
Group: System Environment/Libraries
|
||||
License: MIT
|
||||
URL: http://www.littlecms.com/
|
||||
Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
## upstream patches
|
||||
Patch1: 0001-Added-an-extra-check-to-MLU-bounds.patch
|
||||
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libtiff-devel
|
||||
@ -22,7 +19,6 @@ parallel installed with the original (deprecated) lcms.
|
||||
|
||||
%package utils
|
||||
Summary: Utility applications for %{name}
|
||||
Group: Applications/Productivity
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description utils
|
||||
@ -30,7 +26,6 @@ The %{name}-utils package contains utility applications for %{name}.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for LittleCMS
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Provides: littlecms-devel = %{version}-%{release}
|
||||
|
||||
@ -40,7 +35,6 @@ Development files for LittleCMS.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .0001
|
||||
|
||||
%build
|
||||
%configure --disable-static --program-suffix=2
|
||||
@ -52,7 +46,6 @@ sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
make install DESTDIR=${RPM_BUILD_ROOT} INSTALL="install -p"
|
||||
|
||||
rm -fv ${RPM_BUILD_ROOT}%{_libdir}/lib*.la
|
||||
@ -66,33 +59,30 @@ cp -alf doc/LittleCMS2.?\ tutorial.pdf tutorial.pdf
|
||||
%check
|
||||
make check
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%{_libdir}/liblcms2.so.2*
|
||||
|
||||
%files utils
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/*
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc api.pdf plugin-api.pdf tutorial.pdf
|
||||
%{_includedir}/lcms2*.h
|
||||
%{_libdir}/liblcms2.so
|
||||
%{_libdir}/pkgconfig/lcms2.pc
|
||||
|
||||
%changelog
|
||||
* Fri Nov 17 2017 Rex Dieter <rdieter@fedoraproject.org> - 2.9-1
|
||||
- lcms2-2.9 (#1512518), .spec cosmetics/modernization
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user