Update to 2.15 and switch buildsystem to meson

This commit is contained in:
Richard Hughes 2023-03-02 10:55:27 +00:00
parent c5cc722750
commit 5e94208195
4 changed files with 37 additions and 240 deletions

1
.gitignore vendored
View File

@ -21,3 +21,4 @@ lcms2-2.0a.tar.gz
/lcms2-2.13.tar.gz /lcms2-2.13.tar.gz
/lcms2-2.13.1.tar.gz /lcms2-2.13.1.tar.gz
/lcms2-2.14.tar.gz /lcms2-2.14.tar.gz
/lcms2-2.15.tar.gz

25
360.patch Normal file
View File

@ -0,0 +1,25 @@
From 4e55c55802e4aee5f65be120291f5f4785483d98 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 2 Mar 2023 02:22:01 +0000
Subject: [PATCH] meson: fix big endian cargs
otherwise they are a string and appending with + [""]
later fails in
plugins/fast_float/testbed/meson.build:5:0: ERROR: The `+` operator of str does not accept objects of type list (['-DPROFILES_DIR="/home/buildozer/aports/main/lcms2/src/lcms2-2.15/plugins/test_profiles/"'])
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 694895e9f..2aa1dff65 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ if cc.has_function_attribute('visibility:hidden')
endif
if host_machine.endian() == 'big'
- cargs = '-DWORDS_BIGENDIAN=1'
+ cargs += '-DWORDS_BIGENDIAN=1'
endif

View File

@ -1,16 +1,18 @@
Name: lcms2 Name: lcms2
Version: 2.14 Version: 2.15
Release: 2%{?dist} Release: %autorelease
Summary: Color Management Engine Summary: Color Management Engine
License: MIT License: MIT
URL: http://www.littlecms.com/ URL: http://www.littlecms.com/
Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz
Patch1: 360.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: libtiff-devel BuildRequires: libtiff-devel
BuildRequires: zlib-devel BuildRequires: zlib-devel
BuildRequires: make BuildRequires: meson
%description %description
LittleCMS intends to be a small-footprint, speed optimized color management LittleCMS intends to be a small-footprint, speed optimized color management
@ -35,35 +37,15 @@ Development files for LittleCMS.
%prep %prep
%autosetup -p1 %autosetup -p1
%build %build
%configure \ %meson
--disable-static \ %meson_build
--program-suffix=2
# remove rpath from libtool
sed -i.rpath 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%make_build
%install %install
%make_install %meson_install
rm -fv %{buildroot}%{_libdir}/lib*.la
# rename docs (for use with %%doc below)
cp -alf doc/LittleCMS2.??\ API.pdf api.pdf
cp -alf doc/LittleCMS2.??\ Plugin\ API.pdf plugin-api.pdf
cp -alf doc/LittleCMS2.??\ tutorial.pdf tutorial.pdf
%check %check
%make_build check -k ||: %meson_test
%ldconfig_scriptlets
%files %files
%doc AUTHORS %doc AUTHORS
@ -77,220 +59,9 @@ cp -alf doc/LittleCMS2.??\ tutorial.pdf tutorial.pdf
%{_mandir}/man1/* %{_mandir}/man1/*
%files devel %files devel
%doc api.pdf plugin-api.pdf tutorial.pdf
%{_includedir}/lcms2*.h %{_includedir}/lcms2*.h
%{_libdir}/liblcms2.so %{_libdir}/liblcms2.so
%{_libdir}/pkgconfig/lcms2.pc %{_libdir}/pkgconfig/lcms2.pc
%changelog %changelog
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-2 %autochangelog
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Tue Nov 01 2022 Fedora Release Monitoring <release-monitoring@fedoraproject.org> - 2.14-1
- Update to 2.14 (#2139162)
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Wed Feb 16 2022 Rex Dieter <rdieter@fedoraproject.org> - 2.13.1-1
- 2.13.1 (#2050365)
* Wed Feb 16 2022 Rex Dieter <rdieter@fedoraproject.org> - 2.13-2
- %%doc ChangeLog (#2055122)
* Wed Feb 02 2022 Rex Dieter <rdieter@fedoraproject.org> - 2.13-1
- 2.13 (#2038570)
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Mon Feb 08 2021 Richard Hughes <richard@hughsie.com> - 2.12-1
- Update to new upstream version.
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jun 17 2020 Richard Hughes <richard@hughsie.com> - 2.11-1
- Update to new upstream version.
* Wed Jun 03 2020 Richard Hughes <richard@hughsie.com> - 2.10-1
- Update to new upstream version.
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 18 2018 Rex Dieter <rdieter@fedoraproject.org> - 2.9-4
- CVE-2018-16435 lcms2: heap-based buffer overflow in SetData function in cmsIT8LoadFromFile (#1628969)
- .spec cosmetics, use %%make_build %%make_install %%ldconfig_scriptlets
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Nov 17 2017 Rex Dieter <rdieter@fedoraproject.org> - 2.9-1
- lcms2-2.9 (#1512518), .spec cosmetics/modernization
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Aug 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 2.8-2
- lcms2: Out-of-bounds read in Type_MLU_Read() (#1367357)
* Mon Jul 25 2016 Richard Hughes <richard@hughsie.com> - 2.8-1
- Update to new upstream version.
* Wed Mar 09 2016 Rex Dieter <rdieter@fedoraproject.org> - 2.7-4
- %%files: less globs, use %%license
- tighten subpkg deps
- -devel: use %%doc
- use %%version in Source URL
- simplify %%setup
- %%check: make check
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sun Mar 22 2015 Richard Hughes <richard@hughsie.com> - 2.7-1
- Update to new upstream version.
* Tue Mar 17 2015 Richard Hughes <richard@hughsie.com> - 2.7-0.1rc3
- Update to new upstream RC version.
* Thu Feb 05 2015 Richard Hughes <richard@hughsie.com> - 2.7-0.1rc1
- Update to new upstream version.
- Added a flag to clip negative values in unbounded transforms
- Added a global optimization that merges consecutive matrices in pipelines.
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed May 21 2014 Brent Baude <baude@us.ibm.com> - 2.6-2
- Correct assumption about ppc64 endianess
* Mon Mar 17 2014 Richard Hughes <richard@hughsie.com> 2.6-1
- Update to new upstream version.
- Added a way to retrieve matrix shaper always, no matter LUT is present
- Added pthread dependency
- Big revamp on Contexts, from Artifex
- Fixed a bug in PCS/Colorspace order when reading V2 Lab devicelinks
- Fixed some indexing out of bounds in floating point interpolation
- Fix for delete tag memory corruption
- New locking plug-in, from Artifex
* Wed Feb 19 2014 Richard Hughes <richard@hughsie.com> 2.6-0.1.rc3
- Update to new prerelease upstream version.
* Fri Feb 14 2014 Richard Hughes <richard@hughsie.com> 2.6-0.1.rc1
- Update to new prerelease upstream version.
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Jul 01 2013 Richard Hughes <richard@hughsie.com> 2.5-1
- Update to new upstream version.
- Added a reference for Mac MLU tag
- Added a way to read the profile creator from header
- Added error descriptions on cmsSmoothToneCurve
- Added identity curves support for write V2 LUT
- Added new cmsPlugInTHR() and fixed some race conditions
- Added TIFF Lab16 handling on tifficc
- Fixed a bug on big endian platforms not supporting uint64 or long long.
- Fixed a multithead bug on optimization
- Fixed devicelink generation for 8 bits
- Fixed some 64 bit warnings on size_t to uint32 conversions
- Rendering intent used when creating the transform is now propagated to profile
- RGB profiles store only one copy of the curve to save space
- Transform2Devicelink now keeps white point when guessing deviceclass is enabled
- Update black point detection algorithm to reflect ICC changes
- User defined parametric curves can now be saved in ICC profiles
* Thu Jun 27 2013 Richard Hughes <richard@hughsie.com> 2.5-0.2
- Update to new release candidate version.
* Thu May 30 2013 Richard Hughes <richard@hughsie.com> 2.5-0.1
- Update to new release candidate version.
* Thu Apr 25 2013 Tim Waugh <twaugh@redhat.com> - 2.4-6
- Applied upstream fixes for threading (bug #951984).
* Thu Mar 7 2013 Tim Waugh <twaugh@redhat.com> - 2.4-5
- Added upstream fix for threading issue with plugin registration
(bug #912307).
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 2.4-3
- rebuild due to "jpeg8-ABI" feature drop
* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 2.4-2
- rebuild against new libjpeg
* Sat Sep 15 2012 Richard Hughes <richard@hughsie.com> 2.4-1
- Update to new upstream version.
- Black point detection from the algorithm disclosed by Adobe
- Added support for transforms on planar data with different stride
- Added a new plug-in type for optimizing full transforms
- Linear (gamma 1.0) profiles can now operate in unbounded mode
- Added "half" float support
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Fri Jun 10 2011 Richard Hughes <richard@hughsie.com> 2.3-1
- Update to new upstream version which incorporates many bugfixes.
* Fri Jun 10 2011 Richard Hughes <richard@hughsie.com> 2.2-2
- Actually update the sources...
* Fri Jun 10 2011 Richard Hughes <richard@hughsie.com> 2.2-1
- Update to new upstream version
- Stability and efficienty fixes
- Adds support for dictionary metatag
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Dec 01 2010 Richard Hughes <richard@hughsie.com> 2.1-1
- Update to new upstream version.
* Fri Jun 18 2010 Richard Hughes <richard@hughsie.com> 2.0a-3
- Address some more review comments.
- Resolves #590387
* Fri Jun 18 2010 Richard Hughes <richard@hughsie.com> 2.0a-2
- Address some review comments.
- Resolves #590387
* Fri Jun 18 2010 Richard Hughes <richard@hughsie.com> 2.0a-1
- Initial package for Fedora review

View File

@ -1 +1 @@
SHA512 (lcms2-2.14.tar.gz) = 92fba0a457ea81590eba0b8d98b7b621da6a83e3857948585e0b524235954954f9ac1670cf6a19b457c0fce22a87899ea4c5810db1ff2acf7c6b6e0dc4b61a1b SHA512 (lcms2-2.15.tar.gz) = ab038c369e66736e0dd3810fbac6cf5381bc3102c4dd693819367b1224f59d9e853ede081388464c0e7c213d92e6cddc48c23020953af10ad6c6802cfa17e213