Update to new upstream version
This commit is contained in:
parent
438361fb86
commit
4c186afb3d
2
.gitignore
vendored
2
.gitignore
vendored
@ -14,3 +14,5 @@ lcms2-2.0a.tar.gz
|
||||
/lcms2-2.7.tar.gz
|
||||
/lcms2-2.8.tar.gz
|
||||
/lcms2-2.9.tar.gz
|
||||
/lcms2-2.10rc1.tar.gz
|
||||
/lcms2-2.10.tar.gz
|
||||
|
@ -1,172 +0,0 @@
|
||||
From 768f70ca405cd3159d990e962d54456773bb8cf8 Mon Sep 17 00:00:00 2001
|
||||
From: Marti Maria <info@littlecms.com>
|
||||
Date: Wed, 15 Aug 2018 20:07:56 +0200
|
||||
Subject: [PATCH 17/18] Upgrade Visual studio 2017 15.8
|
||||
|
||||
- Upgrade to 15.8
|
||||
- Add check on CGATS memory allocation (thanks to Quang Nguyen for
|
||||
pointing out this)
|
||||
---
|
||||
Projects/VC2017/jpegicc/jpegicc.vcxproj | 1 +
|
||||
Projects/VC2017/lcms2_DLL/lcms2_DLL.vcxproj | 2 +-
|
||||
Projects/VC2017/lcms2_static/lcms2_static.vcxproj | 2 +-
|
||||
Projects/VC2017/linkicc/linkicc.vcxproj | 2 +-
|
||||
Projects/VC2017/psicc/psicc.vcxproj | 2 +-
|
||||
Projects/VC2017/testbed/testbed.vcxproj | 2 +-
|
||||
Projects/VC2017/tiffdiff/tiffdiff.vcxproj | 2 +-
|
||||
Projects/VC2017/tifficc/tifficc.vcxproj | 2 +-
|
||||
Projects/VC2017/transicc/transicc.vcxproj | 1 +
|
||||
src/cmscgats.c | 14 ++++++++++----
|
||||
10 files changed, 19 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/Projects/VC2017/jpegicc/jpegicc.vcxproj b/Projects/VC2017/jpegicc/jpegicc.vcxproj
|
||||
index ab26a53..39cfd00 100644
|
||||
--- a/Projects/VC2017/jpegicc/jpegicc.vcxproj
|
||||
+++ b/Projects/VC2017/jpegicc/jpegicc.vcxproj
|
||||
@@ -22,6 +22,7 @@
|
||||
<ProjectGuid>{62812507-F926-4968-96A9-17678460AD90}</ProjectGuid>
|
||||
<RootNamespace>jpegicc</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/lcms2_DLL/lcms2_DLL.vcxproj b/Projects/VC2017/lcms2_DLL/lcms2_DLL.vcxproj
|
||||
index 4c8aa3f..d1bf3eb 100644
|
||||
--- a/Projects/VC2017/lcms2_DLL/lcms2_DLL.vcxproj
|
||||
+++ b/Projects/VC2017/lcms2_DLL/lcms2_DLL.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{8C51BE48-ADB8-4089-A9EC-F6BF993A0548}</ProjectGuid>
|
||||
<RootNamespace>lcms2_DLL</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/lcms2_static/lcms2_static.vcxproj b/Projects/VC2017/lcms2_static/lcms2_static.vcxproj
|
||||
index 2a9988a..9fc05ce 100644
|
||||
--- a/Projects/VC2017/lcms2_static/lcms2_static.vcxproj
|
||||
+++ b/Projects/VC2017/lcms2_static/lcms2_static.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{71DEDE59-3F1E-486B-A899-4283000F76B5}</ProjectGuid>
|
||||
<RootNamespace>lcms2_static</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/linkicc/linkicc.vcxproj b/Projects/VC2017/linkicc/linkicc.vcxproj
|
||||
index 30c2b4e..51586dd 100644
|
||||
--- a/Projects/VC2017/linkicc/linkicc.vcxproj
|
||||
+++ b/Projects/VC2017/linkicc/linkicc.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{FBFBE1DC-DB84-4BA1-9552-B4780F457849}</ProjectGuid>
|
||||
<RootNamespace>linkicc</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/psicc/psicc.vcxproj b/Projects/VC2017/psicc/psicc.vcxproj
|
||||
index 9dcf89a..8f26e12 100644
|
||||
--- a/Projects/VC2017/psicc/psicc.vcxproj
|
||||
+++ b/Projects/VC2017/psicc/psicc.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{EF6A8851-65FE-46F5-B9EF-14F0B671F693}</ProjectGuid>
|
||||
<RootNamespace>psicc</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/testbed/testbed.vcxproj b/Projects/VC2017/testbed/testbed.vcxproj
|
||||
index 0af3762..3f6aea3 100644
|
||||
--- a/Projects/VC2017/testbed/testbed.vcxproj
|
||||
+++ b/Projects/VC2017/testbed/testbed.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{928A3A2B-46EF-4279-959C-513B3652FF0E}</ProjectGuid>
|
||||
<RootNamespace>testbed</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/tiffdiff/tiffdiff.vcxproj b/Projects/VC2017/tiffdiff/tiffdiff.vcxproj
|
||||
index 7edfe28..3a6d837 100644
|
||||
--- a/Projects/VC2017/tiffdiff/tiffdiff.vcxproj
|
||||
+++ b/Projects/VC2017/tiffdiff/tiffdiff.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{75B91835-CCD7-48BE-A606-A9C997D5DBEE}</ProjectGuid>
|
||||
<RootNamespace>tiffdiff</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/tifficc/tifficc.vcxproj b/Projects/VC2017/tifficc/tifficc.vcxproj
|
||||
index cd9f04c..5ef954f 100644
|
||||
--- a/Projects/VC2017/tifficc/tifficc.vcxproj
|
||||
+++ b/Projects/VC2017/tifficc/tifficc.vcxproj
|
||||
@@ -22,7 +22,7 @@
|
||||
<ProjectGuid>{2256DE16-ED92-4A6F-9C54-F65BB61E64A2}</ProjectGuid>
|
||||
<RootNamespace>tifficc</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
- <WindowsTargetPlatformVersion>8.1</WindowsTargetPlatformVersion>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/Projects/VC2017/transicc/transicc.vcxproj b/Projects/VC2017/transicc/transicc.vcxproj
|
||||
index d9b77c6..b3173d8 100644
|
||||
--- a/Projects/VC2017/transicc/transicc.vcxproj
|
||||
+++ b/Projects/VC2017/transicc/transicc.vcxproj
|
||||
@@ -22,6 +22,7 @@
|
||||
<ProjectGuid>{9EE22D66-C849-474C-9ED5-C3E141DAB160}</ProjectGuid>
|
||||
<RootNamespace>transicc</RootNamespace>
|
||||
<Keyword>Win32Proj</Keyword>
|
||||
+ <WindowsTargetPlatformVersion>10.0.17134.0</WindowsTargetPlatformVersion>
|
||||
</PropertyGroup>
|
||||
<Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />
|
||||
<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|Win32'" Label="Configuration">
|
||||
diff --git a/src/cmscgats.c b/src/cmscgats.c
|
||||
index 1a87613..8c3e96d 100644
|
||||
--- a/src/cmscgats.c
|
||||
+++ b/src/cmscgats.c
|
||||
@@ -1,7 +1,7 @@
|
||||
//---------------------------------------------------------------------------------
|
||||
//
|
||||
// Little Color Management System
|
||||
-// Copyright (c) 1998-2017 Marti Maria Saguer
|
||||
+// Copyright (c) 1998-2018 Marti Maria Saguer
|
||||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining
|
||||
// a copy of this software and associated documentation files (the "Software"),
|
||||
@@ -1506,10 +1506,16 @@ void AllocateDataSet(cmsIT8* it8)
|
||||
t-> nSamples = atoi(cmsIT8GetProperty(it8, "NUMBER_OF_FIELDS"));
|
||||
t-> nPatches = atoi(cmsIT8GetProperty(it8, "NUMBER_OF_SETS"));
|
||||
|
||||
- t-> Data = (char**)AllocChunk (it8, ((cmsUInt32Number) t->nSamples + 1) * ((cmsUInt32Number) t->nPatches + 1) *sizeof (char*));
|
||||
- if (t->Data == NULL) {
|
||||
+ if (t -> nSamples < 0 || t->nSamples > 0x7ffe || t->nPatches < 0 || t->nPatches > 0x7ffe)
|
||||
+ {
|
||||
+ SynError(it8, "AllocateDataSet: too much data");
|
||||
+ }
|
||||
+ else {
|
||||
+ t->Data = (char**)AllocChunk(it8, ((cmsUInt32Number)t->nSamples + 1) * ((cmsUInt32Number)t->nPatches + 1) * sizeof(char*));
|
||||
+ if (t->Data == NULL) {
|
||||
|
||||
- SynError(it8, "AllocateDataSet: Unable to allocate data array");
|
||||
+ SynError(it8, "AllocateDataSet: Unable to allocate data array");
|
||||
+ }
|
||||
}
|
||||
|
||||
}
|
||||
--
|
||||
2.17.1
|
||||
|
16
lcms2.spec
16
lcms2.spec
@ -1,14 +1,11 @@
|
||||
Name: lcms2
|
||||
Version: 2.9
|
||||
Release: 7%{?dist}
|
||||
Version: 2.10
|
||||
Release: 1%{?dist}
|
||||
Summary: Color Management Engine
|
||||
License: MIT
|
||||
URL: http://www.littlecms.com/
|
||||
Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz
|
||||
|
||||
## upstream patches
|
||||
Patch17: 0017-Upgrade-Visual-studio-2017-15.8.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libtiff-devel
|
||||
@ -56,9 +53,9 @@ sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
rm -fv %{buildroot}%{_libdir}/lib*.la
|
||||
|
||||
# rename docs (for use with %%doc below)
|
||||
cp -alf doc/LittleCMS2.?\ API.pdf api.pdf
|
||||
cp -alf doc/LittleCMS2.?\ Plugin\ API.pdf plugin-api.pdf
|
||||
cp -alf doc/LittleCMS2.?\ tutorial.pdf tutorial.pdf
|
||||
cp -alf doc/LittleCMS2.??\ API.pdf api.pdf
|
||||
cp -alf doc/LittleCMS2.??\ Plugin\ API.pdf plugin-api.pdf
|
||||
cp -alf doc/LittleCMS2.??\ tutorial.pdf tutorial.pdf
|
||||
|
||||
|
||||
%check
|
||||
@ -84,6 +81,9 @@ cp -alf doc/LittleCMS2.?\ tutorial.pdf tutorial.pdf
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 03 2020 Richard Hughes <richard@hughsie.com> - 2.10-1
|
||||
- Update to new upstream version.
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.9-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (lcms2-2.9.tar.gz) = e30ad5a9a1ab9e7aaace9431434caa19a5ff6143db46644aba971a5ee37a265b26bf738e886d766405a7eb45a9d620d67c7ab3684ace86a107cf5a76642c04a5
|
||||
SHA512 (lcms2-2.10.tar.gz) = 81ea385fc441fd2e0ff98d250fc6c6e57eb7548b55ce4e0b25c824105330f35c4ba0b65e86e35252acd7065cdfe531f5f4dffcc5602d40f4902c9774293db5f8
|
||||
|
Loading…
Reference in New Issue
Block a user