New upstream version

This should also fix the Fedora 40 mass-rebuild failure.
This commit is contained in:
Richard Hughes 2024-01-22 12:42:27 +00:00
parent fae9a20b41
commit 308bfb5889
2 changed files with 3 additions and 30 deletions

View File

@ -1,25 +0,0 @@
From 4e55c55802e4aee5f65be120291f5f4785483d98 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 2 Mar 2023 02:22:01 +0000
Subject: [PATCH] meson: fix big endian cargs
otherwise they are a string and appending with + [""]
later fails in
plugins/fast_float/testbed/meson.build:5:0: ERROR: The `+` operator of str does not accept objects of type list (['-DPROFILES_DIR="/home/buildozer/aports/main/lcms2/src/lcms2-2.15/plugins/test_profiles/"'])
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 694895e9f..2aa1dff65 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ if cc.has_function_attribute('visibility:hidden')
endif
if host_machine.endian() == 'big'
- cargs = '-DWORDS_BIGENDIAN=1'
+ cargs += '-DWORDS_BIGENDIAN=1'
endif

View File

@ -1,5 +1,5 @@
Name: lcms2 Name: lcms2
Version: 2.15 Version: 2.16
Release: %autorelease Release: %autorelease
Summary: Color Management Engine Summary: Color Management Engine
# part of src/cmssm.c is softsurf (no SPDX yet) see https://gitlab.com/fedora/legal/fedora-license-data/-/issues/469 # part of src/cmssm.c is softsurf (no SPDX yet) see https://gitlab.com/fedora/legal/fedora-license-data/-/issues/469
@ -9,8 +9,6 @@ License: MIT AND GPL-3.0-or-later
URL: http://www.littlecms.com/ URL: http://www.littlecms.com/
Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz Source0: http://www.littlecms.com/lcms2-%{version}.tar.gz
Patch1: 360.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: libtiff-devel BuildRequires: libtiff-devel
@ -41,7 +39,7 @@ Development files for LittleCMS.
%autosetup -p1 %autosetup -p1
%build %build
%meson %meson -Dutils=true
%meson_build %meson_build
%install %install
@ -54,7 +52,7 @@ Development files for LittleCMS.
%doc AUTHORS %doc AUTHORS
%doc ChangeLog %doc ChangeLog
%doc README* %doc README*
%license COPYING %license LICENSE
%{_libdir}/liblcms2.so.2* %{_libdir}/liblcms2.so.2*
%files utils %files utils