diff --git a/latex2html.spec b/latex2html.spec
index cee47fb..23b06ea 100644
--- a/latex2html.spec
+++ b/latex2html.spec
@@ -3,7 +3,7 @@
Summary: Converts LaTeX documents to HTML
Name: latex2html
Version: 2017.2
-Release: 1%{?dist}
+Release: 2%{?dist}
License: GPLv2+
Group: Applications/Publishing
URL: http://www.latex2html.org/
@@ -116,8 +116,8 @@ perl -pi -e"s,/usr/bin/latex,/usr/bin/platex," cfgcache.pm
perl -pi -e"s,/usr/(share/)?lib,%{_datadir},;
s,%{_datadir}/latex2html,%{_datadir}/jlatex2html," cfgcache.pm
make
-perl -pi -e"s,\\\${dd}pstoimg,\\\${dd}jpstoimg, ;
- s,\\\${dd}texexpand,\\\${dd}jtexexpand," l2hconf.pm
+perl -pi -e"s,\\\$\{dd}pstoimg,\\\$\{dd}jpstoimg, ;
+ s,\\\$\{dd}texexpand,\\\$\{dd}jtexexpand," l2hconf.pm
for i in latex2html pstoimg texexpand ; do
mv ${i} j${i}
@@ -128,11 +128,11 @@ popd
%install
pushd %{name}-%{version}
perl -pi -e"s,%{_prefix},%{buildroot}%{_prefix}," cfgcache.pm
-perl -pi -e"s,/.*\\\${dd}texexpand,%{_bindir}/texexpand,;
- s,/.*\\\${dd}pstoimg,%{_bindir}/pstoimg,;
- s,/.*\\\${dd}*icons,\\\${LATEX2HTMLDIR}/icons,;
- s,/.*\\\${dd}rgb.txt,\\\${LATEX2HTMLDIR}/styles/rgb.txt,;
- s,/.*\\\${dd}styles\\\${dd}crayola.txt,\\\${LATEX2HTMLDIR}/styles/crayola.txt," latex2html
+perl -pi -e"s,/.*\\\$\{dd}texexpand,%{_bindir}/texexpand,;
+ s,/.*\\\$\{dd}pstoimg,%{_bindir}/pstoimg,;
+ s,/.*\\\$\{dd}*icons,\\\$\{LATEX2HTMLDIR}/icons,;
+ s,/.*\\\$\{dd}rgb.txt,\\\$\{LATEX2HTMLDIR}/styles/rgb.txt,;
+ s,/.*\\\$\{dd}styles\\\$\{dd}crayola.txt,\\\$\{LATEX2HTMLDIR}/styles/crayola.txt," latex2html
perl -pi -e"s,%{buildroot},," l2hconf.pm
make install
@@ -156,11 +156,11 @@ popd
pushd %{name}-%{version}JA
perl -pi -e"s,%{_prefix},%{buildroot}%{_prefix}," cfgcache.pm
perl -pi -e"s,latex2html pstoimg texexpand,jlatex2html jpstoimg jtexexpand," config/install.pl
-perl -pi -e"s,/.*\\\${dd}texexpand,%{_bindir}/jtexexpand,;
- s,/.*\\\${dd}pstoimg,%{_bindir}/jpstoimg,;
- s,/.*\\\${dd}icons,\\\${LATEX2HTMLDIR}/icons,;
- s,/.*\\\${dd}styles\\\${dd}rgb.txt,\\\${LATEX2HTMLDIR}/styles/rgb.txt,;
- s,/.*\\\${dd}styles\\\${dd}crayola.txt,\\\${LATEX2HTMLDIR}/styles/crayola.txt," jlatex2html
+perl -pi -e"s,/.*\\\$\{dd}texexpand,%{_bindir}/jtexexpand,;
+ s,/.*\\\$\{dd}pstoimg,%{_bindir}/jpstoimg,;
+ s,/.*\\\$\{dd}icons,\\\$\{LATEX2HTMLDIR}/icons,;
+ s,/.*\\\$\{dd}styles\\\$\{dd}rgb.txt,\\\$\{LATEX2HTMLDIR}/styles/rgb.txt,;
+ s,/.*\\\$\{dd}styles\\\$\{dd}crayola.txt,\\\$\{LATEX2HTMLDIR}/styles/crayola.txt," jlatex2html
perl -pi -e"s,%{buildroot},," l2hconf.pm
make install
@@ -216,6 +216,9 @@ rm -f %{buildroot}%{_datadir}/texmf/tex/latex/html/url.sty
%{_mandir}/man1/pstoimg.*
%changelog
+* Wed Jul 12 2017 Ben Cotton 2017.2-2
+- Update Perl commands in spec file to use valid syntax
+
* Mon Jun 26 2017 Tom Callaway 2017.2-1
- update to 2017.2