Update to 1.15

This commit is contained in:
Wim Taymans 2020-04-16 12:28:02 +02:00 committed by Sérgio M. Basto
parent dcb08bdec8
commit facade41e3
5 changed files with 28 additions and 34 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
ladspa_sdk_1.13.tgz
/ladspa_sdk_1.15.tgz

View File

@ -1,25 +0,0 @@
--- src/search.c 2001-07-21 09:04:23.000000000 -0700
+++ src/search.c.plugindir 2007-10-09 04:43:30.000000000 -0700
@@ -99,10 +99,7 @@
pcLADSPAPath = getenv("LADSPA_PATH");
if (!pcLADSPAPath) {
- fprintf(stderr,
- "Warning: You do not have a LADSPA_PATH "
- "environment variable set.\n");
- return;
+ pcLADSPAPath = PLUGINDIR;
}
pcStart = pcLADSPAPath;
--- src/load.c 2001-07-21 09:04:23.000000000 -0700
+++ src/load.c.plugindir 2007-10-09 04:42:47.000000000 -0700
@@ -54,6 +54,8 @@
to search. */
pcLADSPAPath = getenv("LADSPA_PATH");
+ if (! pcLADSPAPath)
+ pcLADSPAPath = PLUGINDIR;
if (pcLADSPAPath) {

13
ladspa-1.15.patch Normal file
View File

@ -0,0 +1,13 @@
diff -ru ladspa_sdk_1.15/src/Makefile ladspa_sdk_1.15.new/src/Makefile
--- ladspa_sdk_1.15/src/Makefile 2019-01-06 13:27:52.000000000 +0100
+++ ladspa_sdk_1.15.new/src/Makefile 2020-04-16 11:53:02.059458285 +0200
@@ -15,8 +15,7 @@
INCLUDES = -I.
LIBRARIES = -ldl -lm
-CFLAGS = $(INCLUDES) -Wall -Werror -O2 -fPIC \
- -DDEFAULT_LADSPA_PATH=$(INSTALL_PLUGINS_DIR)
+CFLAGS = $(INCLUDES) -Wall -Werror -O2 -fPIC
BINFLAGS = -fPIE -pie
CXXFLAGS = $(CFLAGS)
PLUGINS = ../plugins/amp.so \

View File

@ -1,13 +1,14 @@
Name: ladspa
Version: 1.13
Release: 31%{?dist}
Version: 1.15
Release: 1%{?dist}
Summary: Linux Audio Developer's Simple Plug-in API, examples and tools
License: LGPLv2+
URL: http://www.ladspa.org/
Source: http://www.ladspa.org/download/%{name}_sdk_%{version}.tgz
Patch1: ladspa-1.13-plugindir.patch
Patch1: ladspa-1.15.patch
BuildRequires: perl-interpreter
BuildRequires: gcc-c++
@ -35,12 +36,13 @@ header file.
%prep
%setup -q -n ladspa_sdk
%patch1 -p0 -b .plugindir
%setup -q -n ladspa_sdk_%{version}
%patch1 -p1 -b .0001
# respect RPM_OPT_FLAGS
perl -pi -e 's/^(CFLAGS.*)-O3(.*)/$1\$\(RPM_OPT_FLAGS\)$2 -DPLUGINDIR=\$\(PLUGINDIR\)/' src/makefile
perl -pi -e 's/^(CFLAGS.*)-O2(.*)/$1\$\(RPM_OPT_FLAGS\)$2 -DDEFAULT_LADSPA_PATH=\$\(PLUGINDIR\)/' src/Makefile
# avoid X.org dependency
perl -pi -e 's/-mkdirhier/-mkdir -p/' src/makefile
perl -pi -e 's/-mkdirhier/-mkdir -p/' src/Makefile
# Respect our CC and CPP choices
perl -pi -e 's/CC(.*)=(.*)cc//' src/makefile
@ -54,7 +56,7 @@ perl -pi -e "s!HREF=\"ladspa.h.txt\"!href=\"file:///usr/include/ladspa.h\"!" *.h
%build
%set_build_flags
cd src
PLUGINDIR=\\\"%{_libdir}/ladspa\\\" %{__make} targets %{?_smp_mflags} LD="ld --build-id"
PLUGINDIR=%{_libdir}/ladspa make targets %{?_smp_mflags} LD="ld --build-id"
#make test
#make check
@ -89,6 +91,9 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/ladspa/rdf
%changelog
* Sun Jan 14 2024 Wim Taymans <wtaymans@fedoraproject.org> - 1.15-1
- Update to 1.15
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.13-31
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

View File

@ -1 +1 @@
671be3e1021d0722cadc7fb27054628e ladspa_sdk_1.13.tgz
SHA512 (ladspa_sdk_1.15.tgz) = a521622e23d988284244003e4ccfc3b42f6ddc7944cb00e7949b87e09d7f39a0cbb64b6d8b5a5af0a5ccf7179f88815416a88f02d3912957167e54b74accfc65