- Really added the plugindir patch now (thanks to Karsten Hopp)
- Avoid the make errors because of mkdirhier better than until now
This commit is contained in:
parent
b79751623a
commit
d7a6f06428
25
ladspa-1.13-plugindir.patch
Normal file
25
ladspa-1.13-plugindir.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- src/search.c 2001-07-21 09:04:23.000000000 -0700
|
||||
+++ src/search.c.plugindir 2007-10-09 04:43:30.000000000 -0700
|
||||
@@ -99,10 +99,7 @@
|
||||
|
||||
pcLADSPAPath = getenv("LADSPA_PATH");
|
||||
if (!pcLADSPAPath) {
|
||||
- fprintf(stderr,
|
||||
- "Warning: You do not have a LADSPA_PATH "
|
||||
- "environment variable set.\n");
|
||||
- return;
|
||||
+ pcLADSPAPath = PLUGINDIR;
|
||||
}
|
||||
|
||||
pcStart = pcLADSPAPath;
|
||||
--- src/load.c 2001-07-21 09:04:23.000000000 -0700
|
||||
+++ src/load.c.plugindir 2007-10-09 04:42:47.000000000 -0700
|
||||
@@ -54,6 +54,8 @@
|
||||
to search. */
|
||||
|
||||
pcLADSPAPath = getenv("LADSPA_PATH");
|
||||
+ if (! pcLADSPAPath)
|
||||
+ pcLADSPAPath = PLUGINDIR;
|
||||
|
||||
if (pcLADSPAPath) {
|
||||
|
15
ladspa.spec
15
ladspa.spec
@ -1,6 +1,6 @@
|
||||
Name: ladspa
|
||||
Version: 1.13
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
|
||||
Summary: Linux Audio Developer's Simple Plug-in API, examples and tools
|
||||
|
||||
@ -41,6 +41,8 @@ header file.
|
||||
%patch1 -p0 -b .plugindir
|
||||
# respect RPM_OPT_FLAGS
|
||||
perl -pi -e 's/^(CFLAGS.*)-O3(.*)/$1\$\(RPM_OPT_FLAGS\)$2 -DPLUGINDIR=\$\(PLUGINDIR\)/' src/makefile
|
||||
# avoid X.org dependency
|
||||
perl -pi -e 's/-mkdirhier/-mkdir -p/' src/makefile
|
||||
|
||||
# fix links to the header file in the docs
|
||||
cd doc
|
||||
@ -58,13 +60,6 @@ PLUGINDIR=\\\"%{_libdir}/ladspa\\\" make targets %{?_smp_mflags} LD="ld --build-
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
## ladspa_sdk uses mkdirhier for install which is provided by XFree86
|
||||
## we don't want to depend on XFree86 for building
|
||||
## so let's make these dirs ourselves
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/ladspa
|
||||
mkdir -p $RPM_BUILD_ROOT%{_includedir}/ladspa
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}/ladspa
|
||||
|
||||
cd src
|
||||
make install \
|
||||
INSTALL_PLUGINS_DIR=$RPM_BUILD_ROOT%{_libdir}/ladspa \
|
||||
@ -96,6 +91,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Mar 22 2009 Robert Scheck <robert@fedoraproject.org> - 1.13-5
|
||||
- Really added the plugindir patch now (thanks to Karsten Hopp)
|
||||
- Avoid the make errors because of mkdirhier better than until now
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user