- link with build-id to fix rawhide build
- upgrade to 1.13 (GCC4 build-fix and string fixes) (#449542) - add -plugindir patch so listplugin and friends will work by default (Anthony Green #324741)
This commit is contained in:
parent
824a1ad94f
commit
aa971165db
@ -1 +1 @@
|
|||||||
ladspa_sdk_1.12.tgz
|
ladspa_sdk_1.13.tgz
|
||||||
|
@ -1,95 +0,0 @@
|
|||||||
--- ladspa_sdk/src/plugins/sine.cpp.bak 2002-07-06 19:23:17.000000000 +0200
|
|
||||||
+++ ladspa_sdk/src/plugins/sine.cpp 2006-06-07 12:24:33.677978128 +0200
|
|
||||||
@@ -92,11 +92,36 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
friend LADSPA_Handle instantiateSineOscillator(const LADSPA_Descriptor *,
|
|
||||||
+ unsigned long SampleRate);
|
|
||||||
+
|
|
||||||
+ friend void connectPortToSineOscillator(LADSPA_Handle Instance,
|
|
||||||
+ unsigned long Port,
|
|
||||||
+ LADSPA_Data * DataLocation);
|
|
||||||
+
|
|
||||||
+ friend void activateSineOscillator(void * pvHandle);
|
|
||||||
+
|
|
||||||
+ friend void runSineOscillator_FreqAudio_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
+ unsigned long SampleCount);
|
|
||||||
+
|
|
||||||
+ friend void runSineOscillator_FreqAudio_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
+ unsigned long SampleCount);
|
|
||||||
+
|
|
||||||
+ friend void runSineOscillator_FreqCtrl_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
+ unsigned long SampleCount);
|
|
||||||
+
|
|
||||||
+ friend void runSineOscillator_FreqCtrl_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
+ unsigned long SampleCount);
|
|
||||||
+
|
|
||||||
+ friend void cleanupSineOscillator(void *pvHandle);
|
|
||||||
+
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+ LADSPA_Handle instantiateSineOscillator(const LADSPA_Descriptor *,
|
|
||||||
unsigned long SampleRate) {
|
|
||||||
return new SineOscillator(SampleRate);
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void connectPortToSineOscillator(LADSPA_Handle Instance,
|
|
||||||
+ void connectPortToSineOscillator(LADSPA_Handle Instance,
|
|
||||||
unsigned long Port,
|
|
||||||
LADSPA_Data * DataLocation) {
|
|
||||||
switch (Port) {
|
|
||||||
@@ -112,11 +137,11 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void activateSineOscillator(void * pvHandle) {
|
|
||||||
+ void activateSineOscillator(void * pvHandle) {
|
|
||||||
((SineOscillator *)pvHandle)->m_lPhase = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void runSineOscillator_FreqAudio_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
+ void runSineOscillator_FreqAudio_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
unsigned long SampleCount) {
|
|
||||||
SineOscillator * poSineOscillator = (SineOscillator *)Instance;
|
|
||||||
for (unsigned long lIndex = 0; lIndex < SampleCount; lIndex++) {
|
|
||||||
@@ -133,7 +158,7 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void runSineOscillator_FreqAudio_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
+ void runSineOscillator_FreqAudio_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
unsigned long SampleCount) {
|
|
||||||
SineOscillator * poSineOscillator = (SineOscillator *)Instance;
|
|
||||||
LADSPA_Data fAmplitude = *(poSineOscillator->m_pfAmplitude);
|
|
||||||
@@ -151,7 +176,7 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void runSineOscillator_FreqCtrl_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
+ void runSineOscillator_FreqCtrl_AmpAudio(LADSPA_Handle Instance,
|
|
||||||
unsigned long SampleCount) {
|
|
||||||
SineOscillator * poSineOscillator = (SineOscillator *)Instance;
|
|
||||||
poSineOscillator->setPhaseStepFromFrequency
|
|
||||||
@@ -165,7 +190,7 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void runSineOscillator_FreqCtrl_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
+ void runSineOscillator_FreqCtrl_AmpCtrl(LADSPA_Handle Instance,
|
|
||||||
unsigned long SampleCount) {
|
|
||||||
SineOscillator * poSineOscillator = (SineOscillator *)Instance;
|
|
||||||
LADSPA_Data fAmplitude = *(poSineOscillator->m_pfAmplitude);
|
|
||||||
@@ -180,12 +205,10 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- friend void cleanupSineOscillator(void *pvHandle) {
|
|
||||||
+ void cleanupSineOscillator(void *pvHandle) {
|
|
||||||
delete (SineOscillator *)pvHandle;
|
|
||||||
}
|
|
||||||
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
/*****************************************************************************/
|
|
||||||
|
|
||||||
typedef char * char_ptr;
|
|
18
ladspa.spec
18
ladspa.spec
@ -1,6 +1,6 @@
|
|||||||
Name: ladspa
|
Name: ladspa
|
||||||
Version: 1.12
|
Version: 1.13
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Summary: LADSPA SDK, example plug-ins and tools
|
Summary: LADSPA SDK, example plug-ins and tools
|
||||||
|
|
||||||
@ -8,7 +8,7 @@ Group: System Environment/Libraries
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.ladspa.org/
|
URL: http://www.ladspa.org/
|
||||||
Source: http://www.ladspa.org/download/%{name}_sdk_%{version}.tgz
|
Source: http://www.ladspa.org/download/%{name}_sdk_%{version}.tgz
|
||||||
Patch: ladspa-1.12-gcc41.patch
|
Patch1: ladspa-1.13-plugindir.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
@ -38,9 +38,9 @@ header file.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ladspa_sdk
|
%setup -q -n ladspa_sdk
|
||||||
%patch -p1
|
%patch1 -p0 -b .plugindir
|
||||||
# respect RPM_OPT_FLAGS
|
# respect RPM_OPT_FLAGS
|
||||||
perl -pi -e 's/^(CFLAGS.*)-O3(.*)/$1\$\(RPM_OPT_FLAGS\)$2/' src/makefile
|
perl -pi -e 's/^(CFLAGS.*)-O3(.*)/$1\$\(RPM_OPT_FLAGS\)$2 -DPLUGINDIR=\$\(PLUGINDIR\)/' src/makefile
|
||||||
|
|
||||||
# fix links to the header file in the docs
|
# fix links to the header file in the docs
|
||||||
cd doc
|
cd doc
|
||||||
@ -49,7 +49,7 @@ perl -pi -e "s!HREF=\"ladspa.h.txt\"!href=\"file:///usr/include/ladspa.h\"!" *.h
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
cd src
|
cd src
|
||||||
make targets %{?_smp_mflags}
|
PLUGINDIR=\\\"%{_libdir}/ladspa\\\" make targets %{?_smp_mflags} LD="ld --build-id"
|
||||||
|
|
||||||
#make test
|
#make test
|
||||||
#make check
|
#make check
|
||||||
@ -96,6 +96,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 1.13-1
|
||||||
|
- link with build-id to fix rawhide build
|
||||||
|
- upgrade to 1.13 (GCC4 build-fix and string fixes) (#449542)
|
||||||
|
- add -plugindir patch so listplugin and friends will work by default
|
||||||
|
(Anthony Green #324741)
|
||||||
|
|
||||||
* Tue Aug 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.12-10
|
* Tue Aug 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.12-10
|
||||||
- fix license tag
|
- fix license tag
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user