- Splitted main package into an additional library subpackage
- Added patch and workaround for building under RHEL 5 (#915123) - Corrected duplicate doc packaging, renamed package to apidocs
This commit is contained in:
parent
c66bd69a01
commit
19a642dc29
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,2 +1 @@
|
||||
*.rpm
|
||||
/kyotocabinet-1.2.??.tar.gz
|
||||
kyotocabinet-1.2.??.tar.gz
|
||||
|
73
kyotocabinet-1.2.76-8-byte-atomics.patch
Normal file
73
kyotocabinet-1.2.76-8-byte-atomics.patch
Normal file
@ -0,0 +1,73 @@
|
||||
Patch by Shawn Landden <shawnlandden@gmail.com> for kyotocabinet >= 1.2.76, which fixes
|
||||
the configure test to handle lack of 8 byte atomics correctly as is the case with all ARM
|
||||
targets (and especially RHEL 5 on ix86) currently.
|
||||
|
||||
--- kyotocabinet-1.2.76/configure.in 2012-05-24 13:31:42.000000000 +0200
|
||||
+++ kyotocabinet-1.2.76/configure.in.8-byte-atomics 2013-03-01 00:21:21.000000000 +0100
|
||||
@@ -238,9 +238,22 @@
|
||||
# Atomic operations
|
||||
if test "$enable_atomic" != "no"
|
||||
then
|
||||
- printf 'checking for atomic operations... '
|
||||
- AC_TRY_COMPILE([], [__sync_fetch_and_add], [MYGCCATOMIC=yes], [MYGCCATOMIC=no])
|
||||
- if test "$MYGCCATOMIC" = "yes"
|
||||
+ printf 'checking for 8 byte atomic operations... '
|
||||
+ if printf '
|
||||
+/* Some targets support 4 byte atomics, but not 8 byte atomics,
|
||||
+ * and will fail at link time if they are used.
|
||||
+ *
|
||||
+ * http://gcc.gnu.org/onlinedocs/gcc-4.6.3/gcc/Atomic-Builtins.html
|
||||
+ * http://gcc.gnu.org/wiki/Atomic
|
||||
+ */
|
||||
+#include <stdint.h>
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+uint64_t n = 0xdeadbeaf;
|
||||
+__sync_bool_compare_and_swap(&n, 0xdeadbeaf, 0);
|
||||
+return n;
|
||||
+}' | $CC -xc -o config.tmp - >/dev/null 2>&1
|
||||
then
|
||||
MYCPPFLAGS="$MYCPPFLAGS -D_MYGCCATOMIC"
|
||||
printf 'yes\n'
|
||||
--- kyotocabinet-1.2.76/configure 2012-05-24 13:31:45.000000000 +0200
|
||||
+++ kyotocabinet-1.2.76/configure.8-byte-atomics 2013-03-01 00:22:37.000000000 +0100
|
||||
@@ -4012,25 +4012,22 @@
|
||||
# Atomic operations
|
||||
if test "$enable_atomic" != "no"
|
||||
then
|
||||
- printf 'checking for atomic operations... '
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
+ printf 'checking for 8 byte atomic operations... '
|
||||
+ if printf '
|
||||
+/* Some targets support 4 byte atomics, but not 8 byte atomics,
|
||||
+ * and will fail at link time if they are used.
|
||||
+ *
|
||||
+ * http://gcc.gnu.org/onlinedocs/gcc-4.6.3/gcc/Atomic-Builtins.html
|
||||
+ * http://gcc.gnu.org/wiki/Atomic
|
||||
+ */
|
||||
+#include <stdint.h>
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-__sync_fetch_and_add
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_cxx_try_compile "$LINENO"; then :
|
||||
- MYGCCATOMIC=yes
|
||||
-else
|
||||
- MYGCCATOMIC=no
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
- if test "$MYGCCATOMIC" = "yes"
|
||||
+uint64_t n = 0xdeadbeaf;
|
||||
+__sync_bool_compare_and_swap(&n, 0xdeadbeaf, 0);
|
||||
+return n;
|
||||
+}' | $CC -xc -o config.tmp - >/dev/null 2>&1
|
||||
then
|
||||
MYCPPFLAGS="$MYCPPFLAGS -D_MYGCCATOMIC"
|
||||
printf 'yes\n'
|
1304
kyotocabinet-1.2.76-tr1_hashtable.patch
Normal file
1304
kyotocabinet-1.2.76-tr1_hashtable.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,42 +0,0 @@
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 40595f9..7587577 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -12,6 +12,7 @@ SHELL = @SHELL@
|
||||
|
||||
# Package information
|
||||
PACKAGE = @PACKAGE_NAME@
|
||||
+PACKAGE_TARNAME = @PACKAGE_TARNAME@
|
||||
VERSION = @PACKAGE_VERSION@
|
||||
PACKAGEDIR = $(PACKAGE)-$(VERSION)
|
||||
PACKAGETGZ = $(PACKAGE)-$(VERSION).tar.gz
|
||||
@@ -36,8 +37,8 @@ INCLUDEDIR = @includedir@
|
||||
LIBDIR = @libdir@
|
||||
BINDIR = @bindir@
|
||||
LIBEXECDIR = @libexecdir@
|
||||
-DATADIR = @datadir@/$(PACKAGE)
|
||||
MAN1DIR = @mandir@/man1
|
||||
+DOCDIR = @docdir@
|
||||
PCDIR = @libdir@/pkgconfig
|
||||
DESTDIR =
|
||||
|
||||
@@ -117,8 +118,8 @@ install :
|
||||
cp -Rf $(LIBRARYFILES) $(DESTDIR)$(LIBDIR)
|
||||
mkdir -p $(DESTDIR)$(BINDIR)
|
||||
cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
|
||||
- mkdir -p $(DESTDIR)$(DATADIR)
|
||||
- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
|
||||
+ mkdir -p $(DESTDIR)$(DOCDIR)
|
||||
+ cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DOCDIR)
|
||||
mkdir -p $(DESTDIR)$(MAN1DIR)
|
||||
cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
|
||||
mkdir -p $(DESTDIR)$(PCDIR)
|
||||
@@ -140,7 +141,7 @@ uninstall :
|
||||
-cd $(DESTDIR)$(LIBDIR) && rm -f $(LIBRARYFILES)
|
||||
-cd $(DESTDIR)$(BINDIR) && rm -f $(COMMANDFILES)
|
||||
-cd $(DESTDIR)$(MAN1DIR) && rm -f $(MAN1FILES)
|
||||
- -rm -rf $(DESTDIR)$(DATADIR)
|
||||
+ -rm -rf $(DESTDIR)$(DOCDIR)
|
||||
-cd $(DESTDIR)$(PCDIR) && rm -f $(PCFILES)
|
||||
-[ "$$UID" = 0 ] && PATH=/sbin:/usr/sbin:$(PATH) ldconfig 2>/dev/null || true
|
||||
|
@ -1,67 +1,91 @@
|
||||
%define doctarget %{_defaultdocdir}/%{name}-%{version}
|
||||
|
||||
Summary: A straightforward implementation of DBM
|
||||
Name: kyotocabinet
|
||||
Version: 1.2.76
|
||||
Release: 2%{?dist}
|
||||
Summary: A lightweight database library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3
|
||||
URL: http://fallabs.com/kyotocabinet/
|
||||
Source0: http://fallabs.com/%{name}/pkg/%{name}-%{version}.tar.gz
|
||||
Group: Applications/Databases
|
||||
URL: http://fallabs.com/%{name}/
|
||||
Source: http://fallabs.com/%{name}/pkg/%{name}-%{version}.tar.gz
|
||||
Patch0: kyotocabinet-1.2.76-8-byte-atomics.patch
|
||||
Patch1: kyotocabinet-1.2.76-tr1_hashtable.patch
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
BuildRequires: zlib-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: zlib-devel
|
||||
|
||||
%description
|
||||
Kyoto Cabinet is a library of routines for managing a database. The database is
|
||||
a simple data file containing records, and each record is a pair of a key and a
|
||||
value. Every key and value is an array of bytes with variable length. Both
|
||||
binary data and character strings can be used as a key or a value. There is
|
||||
neither a concept of tables nor of data types.
|
||||
Kyoto Cabinet is a library of routines for managing a database. The
|
||||
database is a simple data file containing records, each is a pair of
|
||||
a key and a value. Every key and value is serial bytes with variable
|
||||
length. Both binary data and character string can be used as a key
|
||||
and a value. Each key must be unique within a database. And there is
|
||||
neither concept of data tables nor data types. Records are organized
|
||||
in hash table or B+ tree.
|
||||
|
||||
%package libs
|
||||
Summary: Libraries for applications using Kyoto Cabinet
|
||||
Group: System Environment/Libraries
|
||||
Provides: %{name}-lib = %{version}-%{release}
|
||||
Provides: %{name}-lib%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: %{name}-lib < 1.2.76-3
|
||||
|
||||
%description libs
|
||||
The kyotocabinet-libs package provides the essential shared libraries
|
||||
for any Kyoto Cabinet client program or interface.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Summary: Development files for Kyoto Cabinet
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}, pkgconfig
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
%description devel
|
||||
The kyotocabinet-devel package contains libraries and header files for
|
||||
developing applications that use Kyoto Cabinet.
|
||||
|
||||
%package api-doc
|
||||
Summary: Development documentation for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%package apidocs
|
||||
Summary: API documentation for Kyoto Cabinet library
|
||||
Group: Documentation
|
||||
%if 0%{?fedora}%{?rhel} >= 6
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
Provides: %{name}-api-doc = %{version}-%{release}
|
||||
Obsoletes: %{name}-api-doc < 1.2.76-3
|
||||
|
||||
%description api-doc
|
||||
The %{name}-api-doc package contains API documentation for developing
|
||||
applications that use %{name}.
|
||||
%description apidocs
|
||||
The kyotocabinet-apidocs package contains API documentation for developing
|
||||
applications that use Kyoto Cabinet.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
sed -i -e 's/ -g0 -O2//' -e 's/ -O0//' configure
|
||||
%if 0%{?rhel} == 5
|
||||
%patch0 -p1 -b .8-byte-atomics
|
||||
%patch1 -p1 -b .tr1_hashtable
|
||||
%endif
|
||||
sed -e 's/ -g0 -O2//' -e 's/ -O0//' -i configure
|
||||
|
||||
%build
|
||||
%configure --disable-rpath --disable-opt --docdir=%{doctarget}
|
||||
make LDENV= %{?_smp_mflags}
|
||||
|
||||
%configure --disable-opt
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm -rf $RPM_BUILD_ROOT%{_libdir}/libkyotocabinet.a
|
||||
cp README $RPM_BUILD_ROOT%{doctarget}
|
||||
make DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' install
|
||||
|
||||
# Don't install any static .a file
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libkyotocabinet.a
|
||||
|
||||
# Clean up for later usage in documentation
|
||||
rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc doc/{command.html,common.css,icon16.png}
|
||||
%{_bindir}/kccachetest
|
||||
%{_bindir}/kcdirmgr
|
||||
%{_bindir}/kcdirtest
|
||||
@ -79,28 +103,28 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_bindir}/kctreetest
|
||||
%{_bindir}/kcutilmgr
|
||||
%{_bindir}/kcutiltest
|
||||
%{_mandir}/man1/kccachetest.1.gz
|
||||
%{_mandir}/man1/kcdirmgr.1.gz
|
||||
%{_mandir}/man1/kcdirtest.1.gz
|
||||
%{_mandir}/man1/kcforestmgr.1.gz
|
||||
%{_mandir}/man1/kcforesttest.1.gz
|
||||
%{_mandir}/man1/kcgrasstest.1.gz
|
||||
%{_mandir}/man1/kchashmgr.1.gz
|
||||
%{_mandir}/man1/kchashtest.1.gz
|
||||
%{_mandir}/man1/kclangctest.1.gz
|
||||
%{_mandir}/man1/kcpolymgr.1.gz
|
||||
%{_mandir}/man1/kcpolytest.1.gz
|
||||
%{_mandir}/man1/kcprototest.1.gz
|
||||
%{_mandir}/man1/kcstashtest.1.gz
|
||||
%{_mandir}/man1/kctreemgr.1.gz
|
||||
%{_mandir}/man1/kctreetest.1.gz
|
||||
%{_mandir}/man1/kcutilmgr.1.gz
|
||||
%{_mandir}/man1/kcutiltest.1.gz
|
||||
%{_libdir}/libkyotocabinet.so.16
|
||||
%{_libdir}/libkyotocabinet.so.16.13.0
|
||||
%{doctarget}/
|
||||
%{doctarget}/doc/command.html
|
||||
%{doctarget}/doc/common.css
|
||||
%{_mandir}/man1/kccachetest.1*
|
||||
%{_mandir}/man1/kcdirmgr.1*
|
||||
%{_mandir}/man1/kcdirtest.1*
|
||||
%{_mandir}/man1/kcforestmgr.1*
|
||||
%{_mandir}/man1/kcforesttest.1*
|
||||
%{_mandir}/man1/kcgrasstest.1*
|
||||
%{_mandir}/man1/kchashmgr.1*
|
||||
%{_mandir}/man1/kchashtest.1*
|
||||
%{_mandir}/man1/kclangctest.1*
|
||||
%{_mandir}/man1/kcpolymgr.1*
|
||||
%{_mandir}/man1/kcpolytest.1*
|
||||
%{_mandir}/man1/kcprototest.1*
|
||||
%{_mandir}/man1/kcstashtest.1*
|
||||
%{_mandir}/man1/kctreemgr.1*
|
||||
%{_mandir}/man1/kctreetest.1*
|
||||
%{_mandir}/man1/kcutilmgr.1*
|
||||
%{_mandir}/man1/kcutiltest.1*
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog COPYING FOSSEXCEPTION LINKEXCEPTION
|
||||
%{_libdir}/libkyotocabinet.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -125,231 +149,17 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/kcutil.h
|
||||
%{_libdir}/libkyotocabinet.so
|
||||
%{_libdir}/pkgconfig/kyotocabinet.pc
|
||||
%{doctarget}/kyotocabinet.idl
|
||||
|
||||
%files api-doc
|
||||
%files apidocs
|
||||
%defattr(-,root,root,-)
|
||||
%{doctarget}/doc/api/annotated.html
|
||||
%{doctarget}/doc/api/classes.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ArcfourCompressor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ArcfourCompressor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1AtomicInt64-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1AtomicInt64.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Error-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Error.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1FileProcessor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1FileProcessor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Logger-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1Logger.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1MetaTrigger-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1MetaTrigger.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1ProgressChecker-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1BasicDB_1_1ProgressChecker.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CacheDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CacheDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CacheDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CacheDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Comparator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Comparator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Compressor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Compressor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CondVar-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1CondVar.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB_1_1Visitor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DB_1_1Visitor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DecimalComparator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DecimalComparator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirStream-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1DirStream.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1File-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1File.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1HashDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1HashDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1HashDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1HashDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZMA-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZMA.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZMACompressor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZMACompressor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZO-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZO.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZOCompressor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LZOCompressor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LexicalComparator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LexicalComparator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LinkedHashMap-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LinkedHashMap.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LinkedHashMap_1_1Iterator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1LinkedHashMap_1_1Iterator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1MapReduce-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1MapReduce.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1MapReduce_1_1ValueIterator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1MapReduce_1_1ValueIterator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Mutex-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Mutex.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PlantDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PlantDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PlantDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PlantDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PolyDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PolyDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PolyDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1PolyDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ProtoDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ProtoDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ProtoDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ProtoDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1RWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1RWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Regex-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Regex.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedMutex-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedMutex.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedRWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedRWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedSpinLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedSpinLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedSpinRWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ScopedSpinRWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedMutex-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedMutex.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedRWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedRWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedSpinLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedSpinLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedSpinRWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SlottedSpinRWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SpinLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SpinLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SpinRWLock-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1SpinRWLock.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1StashDB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1StashDB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1StashDB_1_1Cursor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1StashDB_1_1Cursor.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TSD-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TSD.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TSDKey-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TSDKey.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TaskQueue-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TaskQueue.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TaskQueue_1_1Task-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TaskQueue_1_1Task.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Thread-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1Thread.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Iterator-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Iterator.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Sorter-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Sorter.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ZLIB-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ZLIB.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ZLIBCompressor-members.html
|
||||
%{doctarget}/doc/api/classkyotocabinet_1_1ZLIBCompressor.html
|
||||
%{doctarget}/doc/api/doxygen.css
|
||||
%{doctarget}/doc/api/doxygen.png
|
||||
%{doctarget}/doc/api/files.html
|
||||
%{doctarget}/doc/api/functions.html
|
||||
%{doctarget}/doc/api/functions_0x62.html
|
||||
%{doctarget}/doc/api/functions_0x63.html
|
||||
%{doctarget}/doc/api/functions_0x64.html
|
||||
%{doctarget}/doc/api/functions_0x65.html
|
||||
%{doctarget}/doc/api/functions_0x66.html
|
||||
%{doctarget}/doc/api/functions_0x67.html
|
||||
%{doctarget}/doc/api/functions_0x68.html
|
||||
%{doctarget}/doc/api/functions_0x69.html
|
||||
%{doctarget}/doc/api/functions_0x6a.html
|
||||
%{doctarget}/doc/api/functions_0x6b.html
|
||||
%{doctarget}/doc/api/functions_0x6c.html
|
||||
%{doctarget}/doc/api/functions_0x6d.html
|
||||
%{doctarget}/doc/api/functions_0x6e.html
|
||||
%{doctarget}/doc/api/functions_0x6f.html
|
||||
%{doctarget}/doc/api/functions_0x70.html
|
||||
%{doctarget}/doc/api/functions_0x72.html
|
||||
%{doctarget}/doc/api/functions_0x73.html
|
||||
%{doctarget}/doc/api/functions_0x74.html
|
||||
%{doctarget}/doc/api/functions_0x75.html
|
||||
%{doctarget}/doc/api/functions_0x76.html
|
||||
%{doctarget}/doc/api/functions_0x77.html
|
||||
%{doctarget}/doc/api/functions_0x78.html
|
||||
%{doctarget}/doc/api/functions_0x79.html
|
||||
%{doctarget}/doc/api/functions_0x7e.html
|
||||
%{doctarget}/doc/api/functions_enum.html
|
||||
%{doctarget}/doc/api/functions_eval.html
|
||||
%{doctarget}/doc/api/functions_func.html
|
||||
%{doctarget}/doc/api/functions_func_0x62.html
|
||||
%{doctarget}/doc/api/functions_func_0x63.html
|
||||
%{doctarget}/doc/api/functions_func_0x64.html
|
||||
%{doctarget}/doc/api/functions_func_0x65.html
|
||||
%{doctarget}/doc/api/functions_func_0x66.html
|
||||
%{doctarget}/doc/api/functions_func_0x67.html
|
||||
%{doctarget}/doc/api/functions_func_0x68.html
|
||||
%{doctarget}/doc/api/functions_func_0x69.html
|
||||
%{doctarget}/doc/api/functions_func_0x6a.html
|
||||
%{doctarget}/doc/api/functions_func_0x6b.html
|
||||
%{doctarget}/doc/api/functions_func_0x6c.html
|
||||
%{doctarget}/doc/api/functions_func_0x6d.html
|
||||
%{doctarget}/doc/api/functions_func_0x6e.html
|
||||
%{doctarget}/doc/api/functions_func_0x6f.html
|
||||
%{doctarget}/doc/api/functions_func_0x70.html
|
||||
%{doctarget}/doc/api/functions_func_0x72.html
|
||||
%{doctarget}/doc/api/functions_func_0x73.html
|
||||
%{doctarget}/doc/api/functions_func_0x74.html
|
||||
%{doctarget}/doc/api/functions_func_0x75.html
|
||||
%{doctarget}/doc/api/functions_func_0x76.html
|
||||
%{doctarget}/doc/api/functions_func_0x77.html
|
||||
%{doctarget}/doc/api/functions_func_0x79.html
|
||||
%{doctarget}/doc/api/functions_func_0x7e.html
|
||||
%{doctarget}/doc/api/functions_vars.html
|
||||
%{doctarget}/doc/api/globals.html
|
||||
%{doctarget}/doc/api/globals_defs.html
|
||||
%{doctarget}/doc/api/globals_eval.html
|
||||
%{doctarget}/doc/api/globals_func.html
|
||||
%{doctarget}/doc/api/globals_type.html
|
||||
%{doctarget}/doc/api/globals_vars.html
|
||||
%{doctarget}/doc/api/hierarchy.html
|
||||
%{doctarget}/doc/api/index.html
|
||||
%{doctarget}/doc/api/kccachedb_8h.html
|
||||
%{doctarget}/doc/api/kccommon_8h.html
|
||||
%{doctarget}/doc/api/kccompare_8h.html
|
||||
%{doctarget}/doc/api/kccompress_8h.html
|
||||
%{doctarget}/doc/api/kcdb_8h.html
|
||||
%{doctarget}/doc/api/kcdbext_8h.html
|
||||
%{doctarget}/doc/api/kcdirdb_8h.html
|
||||
%{doctarget}/doc/api/kcfile_8h.html
|
||||
%{doctarget}/doc/api/kchashdb_8h.html
|
||||
%{doctarget}/doc/api/kclangc_8h.html
|
||||
%{doctarget}/doc/api/kcmap_8h.html
|
||||
%{doctarget}/doc/api/kcplantdb_8h.html
|
||||
%{doctarget}/doc/api/kcpolydb_8h.html
|
||||
%{doctarget}/doc/api/kcprotodb_8h.html
|
||||
%{doctarget}/doc/api/kcregex_8h.html
|
||||
%{doctarget}/doc/api/kcthread_8h.html
|
||||
%{doctarget}/doc/api/kcutil_8h.html
|
||||
%{doctarget}/doc/api/namespacekyotocabinet.html
|
||||
%{doctarget}/doc/api/namespacemembers.html
|
||||
%{doctarget}/doc/api/namespacemembers_func.html
|
||||
%{doctarget}/doc/api/namespacemembers_type.html
|
||||
%{doctarget}/doc/api/namespacemembers_vars.html
|
||||
%{doctarget}/doc/api/namespaces.html
|
||||
%{doctarget}/doc/api/structkyotocabinet_1_1File_1_1Status-members.html
|
||||
%{doctarget}/doc/api/structkyotocabinet_1_1File_1_1Status.html
|
||||
%{doctarget}/doc/api/tabs.css
|
||||
%doc COPYING doc/api/* kyotocabinet.idl
|
||||
|
||||
%changelog
|
||||
* Sat Mar 02 2013 Robert Scheck <robert@fedoraproject.org> 1.2.76-3
|
||||
- Splitted main package into an additional library subpackage
|
||||
- Added patch and workaround for building under RHEL 5 (#915123)
|
||||
- Corrected duplicate doc packaging, renamed package to apidocs
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.76-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user