Import rpm: 34aedd622a1e4526303aaed0fcc71702965d44c4
This commit is contained in:
commit
48f6743226
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/kxml-2.3.0-clean.tar.gz
|
34
0001-Unbundle-xpp3-classes.patch
Normal file
34
0001-Unbundle-xpp3-classes.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From 4163fd75bd60cf559cfb677194a8bfbef2b60f98 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Tue, 19 Jan 2016 10:35:19 +0100
|
||||
Subject: [PATCH] Unbundle xpp3 classes
|
||||
|
||||
---
|
||||
build.xml | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 780e516..bbc4536 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -41,8 +41,6 @@
|
||||
<delete dir="tmpclasses"/>
|
||||
<mkdir dir="tmpclasses"/>
|
||||
|
||||
- <unzip src="lib/xmlpull_1_1_3_1.jar" dest="tmpclasses" overwrite="true"/>
|
||||
-
|
||||
<!-- debug="off" -->
|
||||
|
||||
<javac srcdir="src" verbose="true"
|
||||
@@ -68,8 +66,6 @@
|
||||
<jar jarfile="dist/kxml2-min-${version}.jar">
|
||||
<fileset dir="tmpclasses">
|
||||
<!-- <include name="META-INF/**"/> -->
|
||||
- <include name="org/xmlpull/v1/XmlPullParser.class"/>
|
||||
- <include name="org/xmlpull/v1/XmlPullParserException.class"/>
|
||||
<include name="org/kxml2/io/KXmlParser.class"/>
|
||||
</fileset>
|
||||
</jar>
|
||||
--
|
||||
2.5.0
|
||||
|
12
kxml-2.3.0-OSGI-MANIFEST.MF
Normal file
12
kxml-2.3.0-OSGI-MANIFEST.MF
Normal file
@ -0,0 +1,12 @@
|
||||
Bundle-SymbolicName: org.kxml2
|
||||
Export-Package: org.kxml2.io;version="2.3.0",
|
||||
org.kxml2.kdom;version="2.3.0",
|
||||
org.kxml2.wap;version="2.3.0",
|
||||
org.kxml2.syncml;version="2.3.0",
|
||||
org.kxml2.wml;version="2.3.0",
|
||||
org.kxml2.wv;version="2.3.0"
|
||||
Import-Package: org.xmlpull.v1
|
||||
Bundle-Version: 2.3.0
|
||||
Bundle-Vendor: fedoraproject.org
|
||||
Bundle-Name: kxml2-2.3.0
|
||||
Bundle-ManifestVersion: 2
|
197
kxml.spec
Normal file
197
kxml.spec
Normal file
@ -0,0 +1,197 @@
|
||||
# Copyright (c) 2000-2008, JPackage Project
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
#
|
||||
# 1. Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 2. Redistributions in binary form must reproduce the above copyright
|
||||
# notice, this list of conditions and the following disclaimer in the
|
||||
# documentation and/or other materials provided with the
|
||||
# distribution.
|
||||
# 3. Neither the name of the JPackage Project nor the names of its
|
||||
# contributors may be used to endorse or promote products derived
|
||||
# from this software without specific prior written permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
Name: kxml
|
||||
Version: 2.3.0
|
||||
Release: 18%{?dist}
|
||||
Summary: Small XML pull parser
|
||||
License: MIT
|
||||
URL: http://kxml.sourceforge.net/
|
||||
# ./create-tarball %%{version}
|
||||
Source0: %{name}-%{version}-clean.tar.gz
|
||||
Source1: http://repo1.maven.org/maven2/net/sf/kxml/kxml2/%{version}/kxml2-%{version}.pom
|
||||
Source2: http://repo1.maven.org/maven2/net/sf/kxml/kxml2-min/%{version}/kxml2-min-%{version}.pom
|
||||
Source3: %{name}-%{version}-OSGI-MANIFEST.MF
|
||||
|
||||
Patch0: 0001-Unbundle-xpp3-classes.patch
|
||||
|
||||
BuildRequires: javapackages-local
|
||||
BuildRequires: ant
|
||||
BuildRequires: xpp3 >= 0:1.1.3.1
|
||||
Requires: xpp3 >= 0:1.1.3.1
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
kXML is a small XML pull parser, specially designed for constrained
|
||||
environments such as Applets, Personal Java or MIDP devices.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export OPT_JAR_LIST=xpp3
|
||||
ant
|
||||
|
||||
jar ufm dist/%{name}2-%{version}.jar %{SOURCE3}
|
||||
|
||||
%mvn_artifact %{SOURCE1} dist/%{name}2-%{version}.jar
|
||||
%mvn_artifact %{SOURCE2} dist/%{name}2-min-%{version}.jar
|
||||
|
||||
# Compat symlinks
|
||||
%mvn_file :kxml2 kxml/kxml2 kxml
|
||||
%mvn_file :kxml2-min kxml/kxml2-min kxml-min
|
||||
|
||||
%install
|
||||
%mvn_install -J www/kxml2/javadoc
|
||||
|
||||
%files -f .mfiles
|
||||
%license license.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license license.txt
|
||||
|
||||
%changelog
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Sep 25 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.3.0-15
|
||||
- Elimitate race condition when injecting JAR manifest
|
||||
- Resolves: rhbz#1495232
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jun 28 2017 Mat Booth <mat.booth@redhat.com> - 2.3.0-13
|
||||
- Install with xmvn
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Mar 23 2016 Severin Gehwolf <sgehwolf@redhat.com> - 2.3.0-11
|
||||
- Fix OSGi metadata after RHBZ#1299774.
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jan 19 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.3.0-9
|
||||
- Unbundle xpp3 classes
|
||||
- Resolves: rhbz#1299774
|
||||
|
||||
* Tue Jun 16 2015 Jie Kang <jkang@redhat.com> - 2.3.0-8
|
||||
- Add OSGi metadata.
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu May 29 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.3.0-6
|
||||
- Use .mfiles generated during build
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.3.0-5
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Wed Feb 19 2014 Michal Srb <msrb@redhat.com> - 2.3.0-4
|
||||
- Install POM+depmap for net.sf.kxml:kxml2-min
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2013 Michal Srb <msrb@redhat.com> - 2.3.0-2
|
||||
- Clean up tarball
|
||||
- Drop group tag
|
||||
- Fix R
|
||||
|
||||
* Thu Jan 24 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.3.0-1
|
||||
- Update to upstream version 2.3.0
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Apr 30 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.2.2-11
|
||||
- Fix license tag
|
||||
- Add missing Requires
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Nov 29 2011 Alexander Kurtakov <akurtako@redhat.com> 2.2.2-9
|
||||
- Adapt to current guidelines.
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Dec 9 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> 2.2.2-7
|
||||
- Fix pom dependency from xmlpull to xpp3
|
||||
|
||||
* Wed Dec 8 2010 Alexander Kurtakov <akurtako@redhat.com> 2.2.2-6
|
||||
- Remove versioned jar and javadoc.
|
||||
- Fix pom name.
|
||||
|
||||
* Thu Sep 3 2009 Alexander Kurtakov <akurtako@redhat.com> 2.2.2-5
|
||||
- Fix Summary and description.
|
||||
- Fix line length.
|
||||
- Use pom from the URL.
|
||||
|
||||
* Thu Sep 3 2009 Alexander Kurtakov <akurtako@redhat.com> 2.2.2-4
|
||||
- Adapt for Fedora.
|
||||
|
||||
* Mon Dec 08 2008 Will Tatam <will.tatam@red61.com> 2.2.2-3
|
||||
- Auto rebuild for JPackage 5 in mock
|
||||
|
||||
* Wed May 07 2008 Ralph Apel <r.apel@r-apel.de> 0:2.2.2-2jpp
|
||||
- Add xpp3 (B)R
|
||||
|
||||
* Wed May 07 2008 Ralph Apel <r.apel@r-apel.de> 0:2.2.2-1jpp
|
||||
- 2.2.2
|
||||
|
||||
* Thu Aug 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.1.8-4jpp
|
||||
- Pro-forma rebuild with Ant 1.6.2
|
||||
|
||||
* Mon Jan 26 2004 David Walluck <david@anti-microsoft.org> 0:2.1.8-3jpp
|
||||
- remove fractal reference
|
||||
|
||||
* Sun Jan 25 2004 David Walluck <david@anti-microsoft.org> 0:2.1.8-2jpp
|
||||
- fix license
|
||||
|
||||
* Sun Jan 25 2004 David Walluck <david@anti-microsoft.org> 0:2.1.8-1jpp
|
||||
- release
|
32
kxml2-2.3.0.pom
Normal file
32
kxml2-2.3.0.pom
Normal file
@ -0,0 +1,32 @@
|
||||
<project>
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>net.sf.kxml</groupId>
|
||||
<artifactId>kxml2</artifactId>
|
||||
<version>2.3.0</version>
|
||||
<packaging>jar</packaging>
|
||||
<name>kXML 2 is a small XML pull parser based on the common XML pull API</name>
|
||||
<url>http://kxml.sourceforge.net/</url>
|
||||
<description>kXML is a small XML pull parser, specially designed for constrained environments such as Applets, Personal Java or MIDP devices. In contrast to kXML 1, kXML 2 is based on the common XML pull API.</description>
|
||||
<licenses>
|
||||
<license>
|
||||
<name>BSD style</name>
|
||||
<url>http://kxml.cvs.sourceforge.net/viewvc/kxml/kxml2/license.txt?view=markup</url>
|
||||
<distribution>repo</distribution>
|
||||
<comments>The license applies to the kXML2 classes (all classes below the org.kxml2 package).</comments>
|
||||
</license>
|
||||
<license>
|
||||
<name>Public Domain</name>
|
||||
<url>http://creativecommons.org/licenses/publicdomain</url>
|
||||
<distribution>repo</distribution>
|
||||
<comments>The license applies to the XmlPull API (all classes directly in the org.xmlpull.v1 package)</comments>
|
||||
</license>
|
||||
</licenses>
|
||||
<scm>
|
||||
<url>http://kxml.cvs.sourceforge.net/viewvc/kxml/kxml2/</url>
|
||||
</scm>
|
||||
<organization>
|
||||
<name>Stefan Haustein, Oberhausen, Rhld., Germany</name>
|
||||
<url>http://kxml.sourceforge.net/</url>
|
||||
</organization>
|
||||
<dependencies/>
|
||||
</project>
|
32
kxml2-min-2.3.0.pom
Normal file
32
kxml2-min-2.3.0.pom
Normal file
@ -0,0 +1,32 @@
|
||||
<project>
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>net.sf.kxml</groupId>
|
||||
<artifactId>kxml2-min</artifactId>
|
||||
<version>2.3.0</version>
|
||||
<packaging>jar</packaging>
|
||||
<name>kXML 2 is a small XML pull parser based on the common XML pull API</name>
|
||||
<url>http://kxml.sourceforge.net/</url>
|
||||
<description>kXML is a small XML pull parser, specially designed for constrained environments such as Applets, Personal Java or MIDP devices. In contrast to kXML 1, kXML 2 is based on the common XML pull API. This archive contains only the kXML 2 parser.</description>
|
||||
<licenses>
|
||||
<license>
|
||||
<name>BSD style</name>
|
||||
<url>http://kxml.cvs.sourceforge.net/viewvc/kxml/kxml2/license.txt?view=markup</url>
|
||||
<distribution>repo</distribution>
|
||||
<comments>The license applies to the kXML2 classes (all classes below the org.kxml2 package).</comments>
|
||||
</license>
|
||||
<license>
|
||||
<name>Public Domain</name>
|
||||
<url>http://creativecommons.org/licenses/publicdomain</url>
|
||||
<distribution>repo</distribution>
|
||||
<comments>The license applies to the XmlPull API (all classes directly in the org.xmlpull.v1 package)</comments>
|
||||
</license>
|
||||
</licenses>
|
||||
<scm>
|
||||
<url>http://kxml.cvs.sourceforge.net/viewvc/kxml/kxml2/</url>
|
||||
</scm>
|
||||
<organization>
|
||||
<name>Stefan Haustein, Oberhausen, Rhld., Germany</name>
|
||||
<url>http://kxml.sourceforge.net/</url>
|
||||
</organization>
|
||||
<dependencies/>
|
||||
</project>
|
Loading…
Reference in New Issue
Block a user