new upstream release
This commit is contained in:
parent
d30d0499de
commit
d692b90b3c
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@ INIT.2010-07-01.tgz
|
||||
/ksh-1.0.1.tar.gz
|
||||
/ksh-1.0.2.tar.gz
|
||||
/ksh-1.0.3.tar.gz
|
||||
/ksh-1.0.4.tar.gz
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/src/cmd/ksh93/tests/functions.sh b/src/cmd/ksh93/tests/functions.sh
|
||||
index 8fcb483..fcabc90 100755
|
||||
--- a/src/cmd/ksh93/tests/functions.sh
|
||||
+++ b/src/cmd/ksh93/tests/functions.sh
|
||||
@@ -146,10 +146,12 @@ fi
|
||||
if [[ $PWD != "$dir" ]]
|
||||
then err_exit 'cd inside nested subshell changes $PWD'
|
||||
fi
|
||||
+: <<'disabled' # TODO: failing only on i686 arch
|
||||
fun() "$bin_echo" hello
|
||||
if [[ $(fun) != hello ]]
|
||||
then err_exit one line functions not working
|
||||
fi
|
||||
+disabled
|
||||
cat > $tmp/script <<-\!
|
||||
print -r -- "$1"
|
||||
!
|
11
ksh.spec
11
ksh.spec
@ -3,18 +3,13 @@ Summary: The Original ATT Korn Shell
|
||||
URL: http://www.kornshell.com/
|
||||
License: EPL-2.0
|
||||
Epoch: 3
|
||||
Version: 1.0.3
|
||||
Version: 1.0.4
|
||||
Release: 1%{?dist}
|
||||
Source0: https://github.com/ksh93/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: kshcomp.conf
|
||||
Source2: kshrc.rhs
|
||||
Source3: dotkshrc
|
||||
|
||||
# skip a test failing on 32-bit systems
|
||||
# https://github.com/ksh93/ksh/issues/203
|
||||
Patch1: %{name}-%{version}-regre-tests.patch
|
||||
|
||||
|
||||
Conflicts: pdksh
|
||||
Requires: coreutils, diffutils
|
||||
BuildRequires: gcc
|
||||
@ -142,6 +137,10 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/binfmt.d/kshcomp.conf
|
||||
|
||||
%changelog
|
||||
* Tue Oct 25 2022 Vincent Mihalkovic <vmihalko@redhat.com> - 3:1.0.4-1
|
||||
- new upstream release
|
||||
Resolves: rhbz#2137061
|
||||
|
||||
* Tue Sep 13 2022 Lukáš Zaoral <lzaoral@redhat.com> - 3:1.0.3-1
|
||||
- new upstream release
|
||||
Resolves: rhbz#2110530
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ksh-1.0.3.tar.gz) = 9d6e664bc6c8d102ba09e692d057b9546b07ba3ecb060449df6648e7c99f8dfd670401e6fcf34f6f3de13338a3c31c09596344931ccfdf4cd4e49eabdf005c23
|
||||
SHA512 (ksh-1.0.4.tar.gz) = ca6ff4625a48a991d07a34c8d28656c131124e6cccbb495d8fbc2922db9f94a83c1df2be17a7fa7aa39ce5b9243573b0b806eef87d11c5a2936e7af564d2f5e6
|
||||
|
Loading…
Reference in New Issue
Block a user