fix: in a login shell "( cmd & )" does nothing (#1217238)
This commit is contained in:
parent
a4ff81226e
commit
ccfec981bc
11
ksh-20120801-nohupfork.patch
Normal file
11
ksh-20120801-nohupfork.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up ksh-20120801/src/cmd/ksh93/sh/xec.c.nohupfork ksh-20120801/src/cmd/ksh93/sh/xec.c
|
||||
--- ksh-20120801/src/cmd/ksh93/sh/xec.c.nohupfork 2015-08-27 14:25:38.925378019 +0200
|
||||
+++ ksh-20120801/src/cmd/ksh93/sh/xec.c 2015-08-27 14:30:42.267058087 +0200
|
||||
@@ -2067,6 +2067,7 @@ int sh_exec(register const Shnode_t *t,
|
||||
{
|
||||
sh_exec(t->par.partre,flags);
|
||||
shp->st.trapcom[0]=0;
|
||||
+ sh_offoption(SH_INTERACTIVE);
|
||||
sh_done(shp,0);
|
||||
}
|
||||
}
|
7
ksh.spec
7
ksh.spec
@ -9,7 +9,7 @@ Group: System Environment/Shells
|
||||
#CPL everywhere else (for KSH itself)
|
||||
License: CPL
|
||||
Version: %{releasedate}
|
||||
Release: 27%{?dist}
|
||||
Release: 28%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{release_date}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{release_date}.tgz
|
||||
Source2: kshcomp.conf
|
||||
@ -151,6 +151,7 @@ Patch60: ksh-20120801-trapcom.patch
|
||||
Patch61: ksh-20120801-lexfix.patch
|
||||
Patch62: ksh-20140801-arraylen.patch
|
||||
Patch63: ksh-20120801-diskfull.patch
|
||||
Patch64: ksh-20120801-nohupfork.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
@ -219,6 +220,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch61 -p1 -b .lexfix
|
||||
%patch62 -p1 -b .arraylen
|
||||
%patch63 -p1 -b .diskfull
|
||||
%patch64 -p1 -b .nohupfork
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -322,6 +324,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Thu Aug 27 2015 Michal Hlavinka <mhlavink@redhat.com> - 20120801-28
|
||||
- fix: in a login shell "( cmd & )" does nothing (#1217238)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20120801-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user