ksh updated to 2011-04-15
This commit is contained in:
parent
45d8d3ce89
commit
b97b525faf
2
.gitignore
vendored
2
.gitignore
vendored
@ -28,3 +28,5 @@ INIT.2010-07-01.tgz
|
|||||||
/INIT.2011-02-02.tgz
|
/INIT.2011-02-02.tgz
|
||||||
/ast-ksh.2011-02-08.tgz
|
/ast-ksh.2011-02-08.tgz
|
||||||
/INIT.2011-02-08.tgz
|
/INIT.2011-02-08.tgz
|
||||||
|
/ast-ksh.2011-04-15.tgz
|
||||||
|
/INIT.2011-04-15.tgz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up ksh-20110208/src/cmd/ksh93/bltins/typeset.c.oddarrays ksh-20110208/src/cmd/ksh93/bltins/typeset.c
|
|
||||||
--- ksh-20110208/src/cmd/ksh93/bltins/typeset.c.oddarrays 2010-12-31 01:15:57.000000000 +0100
|
|
||||||
+++ ksh-20110208/src/cmd/ksh93/bltins/typeset.c 2011-03-29 07:21:03.484519769 +0200
|
|
||||||
@@ -587,7 +587,7 @@ static int b_common(char **argv,regi
|
|
||||||
path_alias(np,path_absolute(shp,nv_name(np),NIL(Pathcomp_t*)));
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
- np = nv_open(name,troot,nvflags|((nvflags&NV_ASSIGN)?0:NV_ARRAY)|NV_FARRAY);
|
|
||||||
+ np = nv_open(name,troot,nvflags|((nvflags&NV_ASSIGN)?0:NV_ARRAY)|(iarray?NV_FARRAY:0));
|
|
||||||
if(nv_isnull(np) && !nv_isarray(np) && nv_isattr(np,NV_NOFREE))
|
|
||||||
nv_offattr(np,NV_NOFREE);
|
|
||||||
if(tp->pflag)
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up ksh-20110208/src/cmd/ksh93/sh/subshell.c.clist ksh-20110208/src/cmd/ksh93/sh/subshell.c
|
|
||||||
--- ksh-20110208/src/cmd/ksh93/sh/subshell.c.clist 2010-11-03 21:01:11.000000000 +0100
|
|
||||||
+++ ksh-20110208/src/cmd/ksh93/sh/subshell.c 2011-03-02 15:52:14.339083830 +0100
|
|
||||||
@@ -242,7 +242,7 @@ Namval_t *sh_assignok(register Namval_t
|
|
||||||
if(!sp->shpwd || np==SH_LEVELNOD || np==L_ARGNOD || np==SH_SUBSCRNOD || np==SH_NAMENOD)
|
|
||||||
return(np);
|
|
||||||
/* don't bother to save if in newer scope */
|
|
||||||
- if(sp->var!=shp->var_tree && shp->last_root==shp->var_tree)
|
|
||||||
+ if(sp->var!=shp->var_tree && sp->var!=shp->var_base && shp->last_root==shp->var_tree)
|
|
||||||
return(np);
|
|
||||||
if((ap=nv_arrayptr(np)) && (mp=nv_opensub(np)))
|
|
||||||
{
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -up ksh-20110208/src/cmd/ksh93/sh/jobs.c.suspend ksh-20110208/src/cmd/ksh93/sh/jobs.c
|
|
||||||
--- ksh-20110208/src/cmd/ksh93/sh/jobs.c.suspend 2010-12-01 17:57:47.000000000 +0100
|
|
||||||
+++ ksh-20110208/src/cmd/ksh93/sh/jobs.c 2011-03-29 17:01:32.880515568 +0200
|
|
||||||
@@ -945,6 +945,7 @@ int job_walk(Sfio_t *file,int (*fun)(str
|
|
||||||
if(!(pw = job_bypid(pid)))
|
|
||||||
{
|
|
||||||
pw = &dummy;
|
|
||||||
+ pw->p_shp = sh_getinterp();
|
|
||||||
pw->p_pid = pid;
|
|
||||||
pw->p_pgrp = pid;
|
|
||||||
}
|
|
21
ksh.spec
21
ksh.spec
@ -1,12 +1,12 @@
|
|||||||
%global releasedate 2011-02-08
|
%global releasedate 2011-04-15
|
||||||
|
|
||||||
Name: ksh
|
Name: ksh
|
||||||
Summary: The Original ATT Korn Shell
|
Summary: The Original ATT Korn Shell
|
||||||
URL: http://www.kornshell.com/
|
URL: http://www.kornshell.com/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: CPL
|
License: CPL
|
||||||
Version: 20110208
|
Version: 20110415
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||||
Source3: kshrc.rhs
|
Source3: kshrc.rhs
|
||||||
@ -20,15 +20,6 @@ Patch1: ksh-20070328-builtins.patch
|
|||||||
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
||||||
Patch2: ksh-20100826-fixregr.patch
|
Patch2: ksh-20100826-fixregr.patch
|
||||||
|
|
||||||
Patch3: ksh-20110208-clist.patch
|
|
||||||
|
|
||||||
#for ksh<=20110329
|
|
||||||
Patch4: ksh-20110208-arrays.patch
|
|
||||||
|
|
||||||
#for ksh<=20110329
|
|
||||||
Patch5: ksh-20110208-suspend.patch
|
|
||||||
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Conflicts: pdksh
|
Conflicts: pdksh
|
||||||
Requires: coreutils, glibc-common, diffutils
|
Requires: coreutils, glibc-common, diffutils
|
||||||
@ -49,9 +40,6 @@ with "sh" (the Bourne Shell).
|
|||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
%patch1 -p1 -b .builtins
|
%patch1 -p1 -b .builtins
|
||||||
%patch2 -p1 -b .fixregr
|
%patch2 -p1 -b .fixregr
|
||||||
%patch3 -p1 -b .clist
|
|
||||||
%patch4 -p1 -b .oddarrays
|
|
||||||
%patch5 -p1 -b .suspend
|
|
||||||
|
|
||||||
#/dev/fd test does not work because of mock
|
#/dev/fd test does not work because of mock
|
||||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||||
@ -130,6 +118,9 @@ fi
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 18 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110415-1
|
||||||
|
- ksh updated to 2011-04-15
|
||||||
|
|
||||||
* Tue Mar 29 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110208-3
|
* Tue Mar 29 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110208-3
|
||||||
- fix array definition being treated as fixed array
|
- fix array definition being treated as fixed array
|
||||||
- fix suspend crashing ksh
|
- fix suspend crashing ksh
|
||||||
|
Loading…
Reference in New Issue
Block a user