- ksh updated to 2011-01-04
This commit is contained in:
parent
28f1d68859
commit
ac13542f84
2
.gitignore
vendored
2
.gitignore
vendored
@ -16,3 +16,5 @@ INIT.2010-07-01.tgz
|
|||||||
/INIT.2010-12-01.tgz
|
/INIT.2010-12-01.tgz
|
||||||
/ast-ksh.2010-12-12.tgz
|
/ast-ksh.2010-12-12.tgz
|
||||||
/INIT.2010-12-12.tgz
|
/INIT.2010-12-12.tgz
|
||||||
|
/ast-ksh.2011-01-04.tgz
|
||||||
|
/INIT.2011-01-04.tgz
|
||||||
|
43
ksh-20110104-wctype.patch
Normal file
43
ksh-20110104-wctype.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff -up ksh-20110104/src/cmd/ksh93/sh/init.c.wcpatch ksh-20110104/src/cmd/ksh93/sh/init.c
|
||||||
|
--- ksh-20110104/src/cmd/ksh93/sh/init.c.wcpatch 2010-12-30 16:08:25.000000000 +0100
|
||||||
|
+++ ksh-20110104/src/cmd/ksh93/sh/init.c 2011-01-17 14:45:06.199705445 +0100
|
||||||
|
@@ -47,39 +47,8 @@
|
||||||
|
#include "lexstates.h"
|
||||||
|
#include "version.h"
|
||||||
|
|
||||||
|
-#if _hdr_wctype
|
||||||
|
#include <ast_wchar.h>
|
||||||
|
#include <wctype.h>
|
||||||
|
-#endif
|
||||||
|
-#if !_typ_wctrans_t
|
||||||
|
-#undef wctrans_t
|
||||||
|
-#define wctrans_t sh_wctrans_t
|
||||||
|
-typedef int wctrans_t;
|
||||||
|
-#endif
|
||||||
|
-#if !_lib_wctrans
|
||||||
|
-#undef wctrans
|
||||||
|
-#define wctrans sh_wctrans
|
||||||
|
-static wctrans_t wctrans(const char *name)
|
||||||
|
-{
|
||||||
|
- if(strcmp(name,e_tolower)==0)
|
||||||
|
- return(1);
|
||||||
|
- else if(strcmp(name,e_toupper)==0)
|
||||||
|
- return(2);
|
||||||
|
- return(0);
|
||||||
|
-}
|
||||||
|
-#endif
|
||||||
|
-#if !_lib_towctrans
|
||||||
|
-#undef towctrans
|
||||||
|
-#define towctrans sh_towctrans
|
||||||
|
-static int towctrans(int c, wctrans_t t)
|
||||||
|
-{
|
||||||
|
- if(t==1 && isupper(c))
|
||||||
|
- c = tolower(c);
|
||||||
|
- else if(t==2 && isupper(c))
|
||||||
|
- c = toupper(c);
|
||||||
|
- return(c);
|
||||||
|
-}
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
char e_version[] = "\n@(#)$Id: Version "
|
||||||
|
#if SHOPT_AUDIT
|
15
ksh.spec
15
ksh.spec
@ -1,12 +1,12 @@
|
|||||||
%global releasedate 2010-11-22
|
%global releasedate 2011-01-04
|
||||||
|
|
||||||
Name: ksh
|
Name: ksh
|
||||||
Summary: The Original ATT Korn Shell
|
Summary: The Original ATT Korn Shell
|
||||||
URL: http://www.kornshell.com/
|
URL: http://www.kornshell.com/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: CPL
|
License: CPL
|
||||||
Version: 20101212
|
Version: 20110104
|
||||||
Release: 2.20101122%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||||
Source3: kshrc.rhs
|
Source3: kshrc.rhs
|
||||||
@ -20,6 +20,9 @@ Patch1: ksh-20070328-builtins.patch
|
|||||||
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
||||||
Patch2: ksh-20100826-fixregr.patch
|
Patch2: ksh-20100826-fixregr.patch
|
||||||
|
|
||||||
|
#ksh's wctype.h detection script is broken, workaround it
|
||||||
|
Patch3: ksh-20110104-wctype.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Conflicts: pdksh
|
Conflicts: pdksh
|
||||||
Requires: coreutils, glibc-common, diffutils
|
Requires: coreutils, glibc-common, diffutils
|
||||||
@ -40,6 +43,7 @@ with "sh" (the Bourne Shell).
|
|||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
%patch1 -p1 -b .builtins
|
%patch1 -p1 -b .builtins
|
||||||
%patch2 -p1 -b .fixregr
|
%patch2 -p1 -b .fixregr
|
||||||
|
%patch3 -p1 -b .wcpatch
|
||||||
|
|
||||||
#/dev/fd test does not work because of mock
|
#/dev/fd test does not work because of mock
|
||||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||||
@ -48,7 +52,7 @@ sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
|||||||
./bin/package
|
./bin/package
|
||||||
./bin/package make mamake ||:
|
./bin/package make mamake ||:
|
||||||
./bin/package make mamake ||:
|
./bin/package make mamake ||:
|
||||||
export CCFLAGS="$RPM_OPT_FLAGS"
|
export CCFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||||
export CC=gcc
|
export CC=gcc
|
||||||
./bin/package "make"
|
./bin/package "make"
|
||||||
|
|
||||||
@ -118,6 +122,9 @@ fi
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 17 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110104-1
|
||||||
|
- ksh updated to 2011-01-04
|
||||||
|
|
||||||
* Thu Dec 23 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101212-2.20101122
|
* Thu Dec 23 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101212-2.20101122
|
||||||
- found ugly regression, reverting to 2010-11-22 (with io race patch) for now
|
- found ugly regression, reverting to 2010-11-22 (with io race patch) for now
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user