- new upstream version
This commit is contained in:
parent
0f1170cccf
commit
a664599070
@ -1,3 +1,3 @@
|
||||
INIT.2008-02-02.tgz
|
||||
ast-ksh.2008-02-02.tgz
|
||||
ast-ksh-locale.2008-02-02.tgz
|
||||
INIT.2008-07-25.tgz
|
||||
ast-ksh.2008-07-25.tgz
|
||||
ast-ksh-locale.2008-07-25.tgz
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- ksh-20070328/src/cmd/ksh93/sh/jobs.c.ttou 2007-05-22 12:47:38.000000000 +0200
|
||||
+++ ksh-20070328/src/cmd/ksh93/sh/jobs.c 2007-05-22 12:50:24.000000000 +0200
|
||||
@@ -609,9 +609,16 @@
|
||||
{
|
||||
/* save the terminal state for current job */
|
||||
#ifdef SIGTSTP
|
||||
+ Sig_handler_t saved_handler;
|
||||
+
|
||||
+ saved_handler = signal(SIGTTOU, SIG_IGN);
|
||||
job_fgrp(pw,tcgetpgrp(job.fd));
|
||||
if(tcsetpgrp(job.fd,sh.pid) !=0)
|
||||
+ {
|
||||
+ signal(SIGTTOU, saved_handler);
|
||||
return;
|
||||
+ }
|
||||
+ signal(SIGTTOU, saved_handler);
|
||||
#endif /* SIGTSTP */
|
||||
/* force the following tty_get() to do a tcgetattr() */
|
||||
tty_set(-1, 0, NIL(struct termios*));
|
20
ksh-20080725-ttou.patch
Normal file
20
ksh-20080725-ttou.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -up ksh-20080725/src/cmd/ksh93/sh/jobs.c.ttou ksh-20080725/src/cmd/ksh93/sh/jobs.c
|
||||
--- ksh-20080725/src/cmd/ksh93/sh/jobs.c.ttou 2008-07-28 08:25:02.000000000 +0200
|
||||
+++ ksh-20080725/src/cmd/ksh93/sh/jobs.c 2008-07-28 08:27:30.000000000 +0200
|
||||
@@ -663,9 +663,16 @@ static void job_reset(register struct pr
|
||||
{
|
||||
/* save the terminal state for current job */
|
||||
#ifdef SIGTSTP
|
||||
+ Sig_handler_t saved_handler;
|
||||
+
|
||||
+ saved_handler = signal(SIGTTOU, SIG_IGN);
|
||||
job_fgrp(pw,tcgetpgrp(job.fd));
|
||||
if(tcsetpgrp(job.fd,job.mypid) !=0)
|
||||
+ {
|
||||
+ signal(SIGTTOU, saved_handler);
|
||||
return;
|
||||
+ }
|
||||
+ signal(SIGTTOU, saved_handler);
|
||||
#endif /* SIGTSTP */
|
||||
/* force the following tty_get() to do a tcgetattr() unless fg */
|
||||
if(!(pw->p_flag&P_FG))
|
14
ksh.spec
14
ksh.spec
@ -1,5 +1,5 @@
|
||||
#ExclusiveArch: x86_64
|
||||
%define releasedate 2008-02-02
|
||||
%define releasedate 2008-07-25
|
||||
#ExcludeArch: ia64
|
||||
|
||||
Name: ksh
|
||||
@ -7,7 +7,7 @@ Summary: The Original ATT Korn Shell
|
||||
URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: Common Public License Version 1.0
|
||||
Version: 20080202
|
||||
Version: 20080725
|
||||
Release: 1%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
@ -16,7 +16,7 @@ Source2: http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.%{rel
|
||||
Patch1: ksh-20070328-uname.patch
|
||||
Patch2: ksh-20070328-useex.patch
|
||||
Patch3: ksh-20070328-builtins.patch
|
||||
Patch4: ksh-20070328-ttou.patch
|
||||
Patch4: ksh-20080725-ttou.patch
|
||||
Patch5: ksh-20070628-unaligned.patch
|
||||
# for debugging only:
|
||||
#Patch100: ksh-20060124-iffedebug.patch
|
||||
@ -44,7 +44,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch1 -p1 -b .uname
|
||||
%patch2 -p1 -b .use_ex
|
||||
%patch3 -p1 -b .builtins
|
||||
%patch4 -p1 -b .ttou
|
||||
#%patch4 -p1 -b .ttou
|
||||
%patch5 -p1 -b .unaligned
|
||||
#patch100 -p1 -b .iffedebug
|
||||
|
||||
@ -104,6 +104,12 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Mon Jul 28 2008 Tomas Smetana <tsmetana@redhat.com> 20080725-1
|
||||
- new upstream version
|
||||
|
||||
* Thu Jun 26 2008 Tomas Smetana <tsmetana@redhat.com> 20080624-1
|
||||
- new upstream version
|
||||
|
||||
* Mon Feb 11 2008 Tomas Smetana <tsmetana@redhat.com> 20080202-1
|
||||
- new upstream version
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
740c6fc775bf2f7b6bff463bdbad1c31 INIT.2008-02-02.tgz
|
||||
d2a71e320fbaa7a0fd950a27c7e4b099 ast-ksh.2008-02-02.tgz
|
||||
f003813d83fa2606017b3b60196ad38e ast-ksh-locale.2008-02-02.tgz
|
||||
59bd2850ce70bd93db3760578e237449 INIT.2008-07-25.tgz
|
||||
aa6031753184ce6a5d08a8abc8c0ab92 ast-ksh.2008-07-25.tgz
|
||||
cd5b1720c1c0584e13cc689e75b4baf2 ast-ksh-locale.2008-07-25.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user