fix: resume of suspended process using pipes does not work (#708909)
This commit is contained in:
parent
63f9177113
commit
99a963dc26
11
ksh-20110505-resume.patch
Normal file
11
ksh-20110505-resume.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- old/src/cmd/ksh93/sh/xec.c Wed Jun 1 18:03:07 2011
|
||||
+++ old/src/cmd/ksh93/sh/xec.c.orig Tue Jun 7 16:20:47 2011
|
||||
@@ -2963,7 +2963,7 @@
|
||||
#else
|
||||
myjob = job_post(shp,parent,postid);
|
||||
#endif /* SHOPT_BGX */
|
||||
- if(job.waitall && (flags&FPOU))
|
||||
+ if(job.waitall && (flags&FPOU) && !sh_isoption(SH_MONITOR))
|
||||
{
|
||||
job.curjobid = myjob+1;
|
||||
if(job.exitval)
|
8
ksh.spec
8
ksh.spec
@ -6,7 +6,7 @@ URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: CPL
|
||||
Version: 20110505
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source3: kshrc.rhs
|
||||
@ -20,6 +20,8 @@ Patch1: ksh-20070328-builtins.patch
|
||||
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
||||
Patch2: ksh-20100826-fixregr.patch
|
||||
|
||||
Patch3: ksh-20110505-resume.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
Requires: coreutils, glibc-common, diffutils
|
||||
@ -40,6 +42,7 @@ with "sh" (the Bourne Shell).
|
||||
%setup -q -T -D -a 1
|
||||
%patch1 -p1 -b .builtins
|
||||
%patch2 -p1 -b .fixregr
|
||||
%patch3 -p1 -b .resume
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -118,6 +121,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Wed Jun 08 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110505-2
|
||||
- fix: resume of suspended process using pipes does not work (#708909)
|
||||
|
||||
* Mon May 09 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110505-1
|
||||
- ksh updated to 2011-05-05
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user