- fix #405381 - ksh will not handle $(xxx) when typeset -r IFS
- fix #386501 - bad group in spec file
This commit is contained in:
parent
49ffebb6f6
commit
64f1bf7f99
12
ksh-20071105-ifs.patch
Normal file
12
ksh-20071105-ifs.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ksh-20071105/src/cmd/ksh93/sh/macro.c.ifs ksh-20071105/src/cmd/ksh93/sh/macro.c
|
||||
--- ksh-20071105/src/cmd/ksh93/sh/macro.c.ifs 2008-01-07 08:33:51.000000000 +0100
|
||||
+++ ksh-20071105/src/cmd/ksh93/sh/macro.c 2008-01-07 08:35:45.000000000 +0100
|
||||
@@ -1777,7 +1777,7 @@ static void comsubst(Mac_t *mp,int type)
|
||||
#endif
|
||||
*mp = savemac;
|
||||
np = nv_scoped(IFSNOD);
|
||||
- nv_putval(np,mp->ifsp,0);
|
||||
+ nv_putval(np,mp->ifsp, NV_RDONLY);
|
||||
mp->ifsp = nv_getval(np);
|
||||
stakset(savptr,savtop);
|
||||
newlines = 0;
|
10
ksh.spec
10
ksh.spec
@ -5,10 +5,10 @@
|
||||
Name: ksh
|
||||
Summary: The Original ATT Korn Shell
|
||||
URL: http://www.kornshell.com/
|
||||
Group: Applications/Shells
|
||||
Group: System Environment/Shells
|
||||
License: Common Public License Version 1.0
|
||||
Version: 20071105
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source2: http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.%{releasedate}.tgz
|
||||
@ -18,6 +18,7 @@ Patch2: ksh-20070328-useex.patch
|
||||
Patch3: ksh-20070328-builtins.patch
|
||||
Patch4: ksh-20070328-ttou.patch
|
||||
Patch5: ksh-20070628-unaligned.patch
|
||||
Patch6: ksh-20071105-ifs.patch
|
||||
# for debugging only:
|
||||
#Patch100: ksh-20060124-iffedebug.patch
|
||||
|
||||
@ -46,6 +47,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch3 -p1 -b .builtins
|
||||
%patch4 -p1 -b .ttou
|
||||
%patch5 -p1 -b .unaligned
|
||||
%patch6 -p1 -b .ifs
|
||||
#patch100 -p1 -b .iffedebug
|
||||
|
||||
%build
|
||||
@ -104,6 +106,10 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Mon Jan 07 2008 Tomas Smetana <tsmetana@redhat.com> 20071105-2
|
||||
- fix #405381 - ksh will not handle $(xxx) when typeset -r IFS
|
||||
- fix #386501 - bad group in spec file
|
||||
|
||||
* Wed Nov 07 2007 Tomas Smetana <tsmetana@redhat.com> 20071105-1
|
||||
- new upstream version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user