- fix rare cd builtin crash (#578582)
This commit is contained in:
parent
4e113465da
commit
62b429bf63
11
ksh-20100309-pathcrash.patch
Normal file
11
ksh-20100309-pathcrash.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up ksh-20100309/src/cmd/ksh93/sh/path.c.pathcrash ksh-20100309/src/cmd/ksh93/sh/path.c
|
||||
--- ksh-20100309/src/cmd/ksh93/sh/path.c.pathcrash 2010-05-05 14:05:41.670681132 +0200
|
||||
+++ ksh-20100309/src/cmd/ksh93/sh/path.c 2010-05-05 14:05:41.707584330 +0200
|
||||
@@ -1437,6 +1437,7 @@ static Pathcomp_t *path_addcomp(Pathcomp
|
||||
}
|
||||
for(pp=first, oldpp=0; pp; oldpp=pp, pp=pp->next);
|
||||
pp = newof((Pathcomp_t*)0,Pathcomp_t,1,len+1);
|
||||
+ pp->shp = sh_getinterp();
|
||||
pp->refcount = 1;
|
||||
memcpy((char*)(pp+1),name,len+1);
|
||||
pp->name = (char*)(pp+1);
|
8
ksh.spec
8
ksh.spec
@ -6,7 +6,7 @@ URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: CPL
|
||||
Version: 20100309
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source3: kshrc.rhs
|
||||
@ -27,6 +27,8 @@ Patch4: ksh-20100309-compsubst.patch
|
||||
#sent upstream, rhbz#587127, for ksh <2010-03-19
|
||||
Patch5: ksh-20100309-fixwhence.patch
|
||||
|
||||
#from upstream, rhbz#578582, for ksh <? 2010-04-13
|
||||
Patch6: ksh-20100309-pathcrash.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
@ -49,6 +51,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch3 -p1 -b .restoretty
|
||||
%patch4 -p1 -b .compsubst
|
||||
%patch5 -p1 -b .fixwhence
|
||||
%patch6 -p1 -b .pathcrash
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -104,6 +107,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Wed May 05 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-5
|
||||
- fix rare cd builtin crash (#578582)
|
||||
|
||||
* Wed May 05 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-4
|
||||
- fix infinite loop when whence builtin is used with -q option (#587127)
|
||||
- fix stdin for double command substitution (#584007)
|
||||
|
Loading…
Reference in New Issue
Block a user