Auto sync2gitlab import of ksh-20120801-256.el8.src.rpm
This commit is contained in:
parent
cd9fd2352b
commit
2f1643be58
12
ksh-20120801-signal-bubbling.patch
Normal file
12
ksh-20120801-signal-bubbling.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/src/cmd/ksh93/sh/xec.c b/src/cmd/ksh93/sh/xec.c
|
||||||
|
--- a/src/cmd/ksh93/sh/xec.c
|
||||||
|
+++ b/src/cmd/ksh93/sh/xec.c
|
||||||
|
@@ -3529,7 +3529,7 @@ int sh_funscope(int argn, char *argv[],int(*fun)(void*),void *arg,int execflg)
|
||||||
|
}
|
||||||
|
if(jmpval)
|
||||||
|
r=shp->exitval;
|
||||||
|
- if(r>SH_EXITSIG && ((r&SH_EXITMASK)==SIGINT || ((r&SH_EXITMASK)==SIGQUIT)))
|
||||||
|
+ if(r>SH_EXITSIG && ((r&SH_EXITMASK)==SIGINT || ((r&SH_EXITMASK)==SIGQUIT) || (getenv("_AST_KSH_SIGNAL_BUBBLE"))))
|
||||||
|
kill(getpid(),r&SH_EXITMASK);
|
||||||
|
if(jmpval > SH_JMPFUN)
|
||||||
|
{
|
9
ksh.spec
9
ksh.spec
@ -6,7 +6,7 @@ Summary: The Original ATT Korn Shell
|
|||||||
URL: http://www.kornshell.com/
|
URL: http://www.kornshell.com/
|
||||||
License: EPL
|
License: EPL
|
||||||
Version: %{releasedate}
|
Version: %{releasedate}
|
||||||
Release: 255%{?dist}
|
Release: 256%{?dist}
|
||||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{release_date}.tgz
|
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{release_date}.tgz
|
||||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{release_date}.tgz
|
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{release_date}.tgz
|
||||||
Source2: kshcomp.conf
|
Source2: kshcomp.conf
|
||||||
@ -220,6 +220,9 @@ Patch89: ksh-20120801-cve-2019-14868.patch
|
|||||||
# rhbz#1857847
|
# rhbz#1857847
|
||||||
Patch90: ksh-20120801-jobcontrol.patch
|
Patch90: ksh-20120801-jobcontrol.patch
|
||||||
|
|
||||||
|
# rhbz#2060600
|
||||||
|
Patch91: ksh-20120801-signal-bubbling.patch
|
||||||
|
|
||||||
Conflicts: pdksh
|
Conflicts: pdksh
|
||||||
Requires: coreutils, diffutils, chkconfig
|
Requires: coreutils, diffutils, chkconfig
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
@ -372,6 +375,10 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/binfmt.d/kshcomp.conf
|
%config(noreplace) %{_sysconfdir}/binfmt.d/kshcomp.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 21 2022 Vincent Mihalkovic <vmihalko@redhat.com> - 20120801-256
|
||||||
|
- Do not evaluate arithmetic expressions from environment variables at startup
|
||||||
|
Resolves: #2060600
|
||||||
|
|
||||||
* Mon Jan 03 2022 Vincent Mihalkovic <vmihalko@redhat.com> - 20120801-255
|
* Mon Jan 03 2022 Vincent Mihalkovic <vmihalko@redhat.com> - 20120801-255
|
||||||
- Fix race conditions running external commands with job control on
|
- Fix race conditions running external commands with job control on
|
||||||
Resolves: #1857847
|
Resolves: #1857847
|
||||||
|
Loading…
Reference in New Issue
Block a user