fix tilda expansion in scripts
This commit is contained in:
parent
b0b7eaa73c
commit
1f85ad675d
16
ksh-20120214-tildafix.patch
Normal file
16
ksh-20120214-tildafix.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up ksh-20120214/src/cmd/ksh93/sh/macro.c.tildafix ksh-20120214/src/cmd/ksh93/sh/macro.c
|
||||||
|
--- ksh-20120214/src/cmd/ksh93/sh/macro.c.tildafix 2012-03-13 10:09:36.895655554 +0100
|
||||||
|
+++ ksh-20120214/src/cmd/ksh93/sh/macro.c 2012-03-13 10:11:54.751591156 +0100
|
||||||
|
@@ -2719,7 +2719,12 @@ skip:
|
||||||
|
if(!logins_tree)
|
||||||
|
logins_tree = dtopen(&_Nvdisc,Dtbag);
|
||||||
|
if(np=nv_search(string,logins_tree,NV_ADD))
|
||||||
|
+ {
|
||||||
|
+ c = shp->subshell;
|
||||||
|
+ shp->subshell = 0;
|
||||||
|
nv_putval(np, pw->pw_dir,0);
|
||||||
|
+ shp->subshell = c;
|
||||||
|
+ }
|
||||||
|
return(pw->pw_dir);
|
||||||
|
}
|
||||||
|
|
9
ksh.spec
9
ksh.spec
@ -6,7 +6,7 @@ URL: http://www.kornshell.com/
|
|||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: EPL
|
License: EPL
|
||||||
Version: 20120214
|
Version: 20120214
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||||
Source3: kshrc.rhs
|
Source3: kshrc.rhs
|
||||||
@ -20,6 +20,9 @@ Patch1: ksh-20070328-builtins.patch
|
|||||||
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
||||||
Patch2: ksh-20100826-fixregr.patch
|
Patch2: ksh-20100826-fixregr.patch
|
||||||
|
|
||||||
|
# for ksh <= 2012-03-09, fix tilda expansion, rhbz#802565
|
||||||
|
Patch3: ksh-20120214-tildafix.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Conflicts: pdksh
|
Conflicts: pdksh
|
||||||
Requires: coreutils, glibc-common, diffutils
|
Requires: coreutils, glibc-common, diffutils
|
||||||
@ -40,6 +43,7 @@ with "sh" (the Bourne Shell).
|
|||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
%patch1 -p1 -b .builtins
|
%patch1 -p1 -b .builtins
|
||||||
%patch2 -p1 -b .fixregr
|
%patch2 -p1 -b .fixregr
|
||||||
|
%patch3 -p1 -b .tildafix
|
||||||
|
|
||||||
#/dev/fd test does not work because of mock
|
#/dev/fd test does not work because of mock
|
||||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||||
@ -125,6 +129,9 @@ fi
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 13 2012 Michal Hlavinka <mhlavink@redhat.com> - 20120214-2
|
||||||
|
- fix tilda expansion in scripts
|
||||||
|
|
||||||
* Mon Feb 20 2012 Michal Hlavinka <mhlavink@redhat.com> - 20120214-1
|
* Mon Feb 20 2012 Michal Hlavinka <mhlavink@redhat.com> - 20120214-1
|
||||||
- ksh updated to 20120214
|
- ksh updated to 20120214
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user