- new upstream version
This commit is contained in:
parent
98fd270b05
commit
0f1170cccf
@ -1,3 +1,3 @@
|
|||||||
ast-ksh.2007-11-05.tgz
|
INIT.2008-02-02.tgz
|
||||||
ast-ksh-locale.2007-11-05.tgz
|
ast-ksh.2008-02-02.tgz
|
||||||
INIT.2007-11-05.tgz
|
ast-ksh-locale.2008-02-02.tgz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up ksh-20071105/src/cmd/ksh93/sh/macro.c.ifs ksh-20071105/src/cmd/ksh93/sh/macro.c
|
|
||||||
--- ksh-20071105/src/cmd/ksh93/sh/macro.c.ifs 2008-01-07 08:33:51.000000000 +0100
|
|
||||||
+++ ksh-20071105/src/cmd/ksh93/sh/macro.c 2008-01-07 08:35:45.000000000 +0100
|
|
||||||
@@ -1777,7 +1777,7 @@ static void comsubst(Mac_t *mp,int type)
|
|
||||||
#endif
|
|
||||||
*mp = savemac;
|
|
||||||
np = nv_scoped(IFSNOD);
|
|
||||||
- nv_putval(np,mp->ifsp,0);
|
|
||||||
+ nv_putval(np,mp->ifsp, NV_RDONLY);
|
|
||||||
mp->ifsp = nv_getval(np);
|
|
||||||
stakset(savptr,savtop);
|
|
||||||
newlines = 0;
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up ksh-20071105/src/cmd/ksh93/sh/init.c.optind ksh-20071105/src/cmd/ksh93/sh/init.c
|
|
||||||
--- ksh-20071105/src/cmd/ksh93/sh/init.c.optind 2008-01-30 07:56:28.000000000 +0100
|
|
||||||
+++ ksh-20071105/src/cmd/ksh93/sh/init.c 2008-01-30 07:57:19.000000000 +0100
|
|
||||||
@@ -198,6 +198,8 @@ static void put_optindex(Namval_t* np,co
|
|
||||||
Shell_t *shp = ((struct shell*)fp)->sh;
|
|
||||||
shp->st.opterror = shp->st.optchar = 0;
|
|
||||||
nv_putv(np, val, flags, fp);
|
|
||||||
+ if(!val)
|
|
||||||
+ nv_disc(np,fp,NV_POP);
|
|
||||||
}
|
|
||||||
|
|
||||||
static Sfdouble_t nget_optindex(register Namval_t* np, Namfun_t *fp)
|
|
13
ksh.spec
13
ksh.spec
@ -1,5 +1,5 @@
|
|||||||
#ExclusiveArch: x86_64
|
#ExclusiveArch: x86_64
|
||||||
%define releasedate 2007-11-05
|
%define releasedate 2008-02-02
|
||||||
#ExcludeArch: ia64
|
#ExcludeArch: ia64
|
||||||
|
|
||||||
Name: ksh
|
Name: ksh
|
||||||
@ -7,8 +7,8 @@ Summary: The Original ATT Korn Shell
|
|||||||
URL: http://www.kornshell.com/
|
URL: http://www.kornshell.com/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: Common Public License Version 1.0
|
License: Common Public License Version 1.0
|
||||||
Version: 20071105
|
Version: 20080202
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||||
Source2: http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.%{releasedate}.tgz
|
Source2: http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.%{releasedate}.tgz
|
||||||
@ -18,8 +18,6 @@ Patch2: ksh-20070328-useex.patch
|
|||||||
Patch3: ksh-20070328-builtins.patch
|
Patch3: ksh-20070328-builtins.patch
|
||||||
Patch4: ksh-20070328-ttou.patch
|
Patch4: ksh-20070328-ttou.patch
|
||||||
Patch5: ksh-20070628-unaligned.patch
|
Patch5: ksh-20070628-unaligned.patch
|
||||||
Patch6: ksh-20071105-ifs.patch
|
|
||||||
Patch7: ksh-20071105-optind.patch
|
|
||||||
# for debugging only:
|
# for debugging only:
|
||||||
#Patch100: ksh-20060124-iffedebug.patch
|
#Patch100: ksh-20060124-iffedebug.patch
|
||||||
|
|
||||||
@ -48,8 +46,6 @@ with "sh" (the Bourne Shell).
|
|||||||
%patch3 -p1 -b .builtins
|
%patch3 -p1 -b .builtins
|
||||||
%patch4 -p1 -b .ttou
|
%patch4 -p1 -b .ttou
|
||||||
%patch5 -p1 -b .unaligned
|
%patch5 -p1 -b .unaligned
|
||||||
%patch6 -p1 -b .ifs
|
|
||||||
%patch7 -p1 -b .optind
|
|
||||||
#patch100 -p1 -b .iffedebug
|
#patch100 -p1 -b .iffedebug
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -108,6 +104,9 @@ fi
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 11 2008 Tomas Smetana <tsmetana@redhat.com> 20080202-1
|
||||||
|
- new upstream version
|
||||||
|
|
||||||
* Wed Jan 30 2008 Tomas Smetana <tsmetana@redhat.com> 20071105-3
|
* Wed Jan 30 2008 Tomas Smetana <tsmetana@redhat.com> 20071105-3
|
||||||
- fix #430602 - ksh segfaults after unsetting OPTIND
|
- fix #430602 - ksh segfaults after unsetting OPTIND
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
19c22f3711188c49564589f525ebd5d7 ast-ksh.2007-11-05.tgz
|
740c6fc775bf2f7b6bff463bdbad1c31 INIT.2008-02-02.tgz
|
||||||
8024e4ab068f933bc8fc0f45a9c4fb71 ast-ksh-locale.2007-11-05.tgz
|
d2a71e320fbaa7a0fd950a27c7e4b099 ast-ksh.2008-02-02.tgz
|
||||||
312f61269398c0fc854b753a51938230 INIT.2007-11-05.tgz
|
f003813d83fa2606017b3b60196ad38e ast-ksh-locale.2008-02-02.tgz
|
||||||
|
Loading…
Reference in New Issue
Block a user