ksh updated to 2012-05-31
This commit is contained in:
parent
c7f72d5f3b
commit
0ca0131317
2
.gitignore
vendored
2
.gitignore
vendored
@ -44,3 +44,5 @@ INIT.2010-07-01.tgz
|
||||
/INIT.2012-02-14.tgz
|
||||
/ast-ksh.2012-02-29.tgz
|
||||
/INIT.2012-02-29.tgz
|
||||
/ast-ksh.2012-05-31.tgz
|
||||
/INIT.2012-05-31.tgz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up ksh-20120229/src/cmd/ksh93/sh/xec.c.rc12hang ksh-20120229/src/cmd/ksh93/sh/xec.c
|
||||
--- ksh-20120229/src/cmd/ksh93/sh/xec.c.rc12hang 2012-03-02 17:37:09.000000000 +0100
|
||||
+++ ksh-20120229/src/cmd/ksh93/sh/xec.c 2012-03-19 11:29:41.002964239 +0100
|
||||
@@ -1623,7 +1623,7 @@ int sh_exec(register const Shnode_t *t,
|
||||
else
|
||||
job_wait(parent);
|
||||
if(shp->topfd > topfd)
|
||||
- sh_iorestore(shp,topfd,sh.exitval);
|
||||
+ sh_iorestore(shp,topfd,0);
|
||||
if(usepipe && tsetio && subdup)
|
||||
iounpipe(shp);
|
||||
if(!sh_isoption(SH_MONITOR))
|
||||
@@ -3079,7 +3079,7 @@ pid_t _sh_fork(Shell_t *shp,register pid
|
||||
if(!tsetio || !subdup)
|
||||
{
|
||||
if(shp->topfd > restorefd)
|
||||
- sh_iorestore(shp,restorefd,sh.exitval);
|
||||
+ sh_iorestore(shp,restorefd,0);
|
||||
iounpipe(shp);
|
||||
}
|
||||
}
|
14
ksh.spec
14
ksh.spec
@ -1,12 +1,12 @@
|
||||
%global releasedate 2012-02-29
|
||||
%global releasedate 2012-05-31
|
||||
|
||||
Name: ksh
|
||||
Summary: The Original ATT Korn Shell
|
||||
URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: EPL
|
||||
Version: 20120229
|
||||
Release: 2%{?dist}
|
||||
Version: 20120531
|
||||
Release: 1%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source3: kshrc.rhs
|
||||
@ -20,8 +20,6 @@ Patch1: ksh-20070328-builtins.patch
|
||||
#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
|
||||
Patch2: ksh-20100826-fixregr.patch
|
||||
|
||||
Patch3: ksh-20120229-rc12hang.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
Requires: coreutils, glibc-common, diffutils
|
||||
@ -42,7 +40,6 @@ with "sh" (the Bourne Shell).
|
||||
%setup -q -T -D -a 1
|
||||
%patch1 -p1 -b .builtins
|
||||
%patch2 -p1 -b .fixregr
|
||||
%patch3 -p1 -b .rc12hang
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -51,7 +48,7 @@ sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
./bin/package
|
||||
./bin/package make mamake ||:
|
||||
./bin/package make mamake ||:
|
||||
export CCFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
export CCFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-unknown-pragmas -Wno-parentheses -Wno-unused -Wno-unused-but-set-variable -Wno-cpp"
|
||||
export CC=gcc
|
||||
./bin/package "make"
|
||||
|
||||
@ -128,6 +125,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Mon Jun 04 2012 Michal Hlavinka <mhlavink@redhat.com> - 20120531-1
|
||||
- ksh updated to 2012-05-31
|
||||
|
||||
* Mon Mar 19 2012 Michal Hlavinka <mhlavink@redhat.com> - 20120229-2
|
||||
- do not hang after return code 12
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user