ksh stops on read when monitor mode is enabled
This commit is contained in:
parent
7c07bb2ede
commit
09a4238612
12
ksh-20120801-mtty.patch
Normal file
12
ksh-20120801-mtty.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up ksh-20120801/src/cmd/ksh93/sh/xec.c.mtty ksh-20120801/src/cmd/ksh93/sh/xec.c
|
||||
--- ksh-20120801/src/cmd/ksh93/sh/xec.c.mtty 2013-10-30 13:23:31.342298357 +0100
|
||||
+++ ksh-20120801/src/cmd/ksh93/sh/xec.c 2013-10-30 13:24:20.453885803 +0100
|
||||
@@ -3144,7 +3144,7 @@ pid_t _sh_fork(Shell_t *shp,register pid
|
||||
* completed. Make parent the job group id.
|
||||
*/
|
||||
if(postid==0)
|
||||
- job.curpgid = parent;
|
||||
+ job.curpgid = getpid();
|
||||
if(job.jobcontrol || (flags&FAMP))
|
||||
{
|
||||
if(setpgid(parent,job.curpgid)<0 && errno==EPERM)
|
7
ksh.spec
7
ksh.spec
@ -6,7 +6,7 @@ URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: EPL
|
||||
Version: 20120801
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source2: kshcomp.conf
|
||||
@ -27,6 +27,7 @@ Patch6: ksh-20120801-cdfix2.patch
|
||||
Patch7: ksh-20130214-fixkill.patch
|
||||
Patch8: ksh-20120801-kshmfix.patch
|
||||
Patch9: ksh-20120801-memlik.patch
|
||||
Patch10: ksh-20120801-mtty.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
@ -55,6 +56,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch7 -p1 -b .fixkill
|
||||
%patch8 -p1 -b .kshmfix
|
||||
%patch9 -p1 -b .memlik
|
||||
%patch10 -p1 -b .mtty
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -149,6 +151,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Wed Oct 30 2013 Michal Hlavinka <mhlavink@redhat.com> - 20120801-12
|
||||
- ksh stops on read when monitor mode is enabled
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20120801-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user