Set terminal foreground process group while resuming process
Resolves: #1459000
This commit is contained in:
parent
000859d97b
commit
01b2471170
11
ksh-20120801-jobwait-sigstop.patch
Normal file
11
ksh-20120801-jobwait-sigstop.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff --git a/src/cmd/ksh93/sh/jobs.c b/src/cmd/ksh93/sh/jobs.c
|
||||
--- a/src/cmd/ksh93/sh/jobs.c
|
||||
+++ b/src/cmd/ksh93/sh/jobs.c
|
||||
@@ -1579,6 +1579,7 @@ int job_wait(register pid_t pid)
|
||||
if( pw->p_exit!=SIGTTIN && pw->p_exit!=SIGTTOU)
|
||||
break;
|
||||
|
||||
+ tcsetpgrp(JOBTTY,pw->p_pgrp);
|
||||
killpg(pw->p_pgrp,SIGCONT);
|
||||
}
|
||||
else /* ignore stop when non-interactive */
|
9
ksh.spec
9
ksh.spec
@ -8,7 +8,7 @@ URL: http://www.kornshell.com/
|
||||
#CPL everywhere else (for KSH itself)
|
||||
License: CPL
|
||||
Version: %{releasedate}
|
||||
Release: 38%{?dist}
|
||||
Release: 39%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{release_date}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{release_date}.tgz
|
||||
Source2: kshcomp.conf
|
||||
@ -190,6 +190,9 @@ Patch78: ksh-20120801-syntax-error.patch
|
||||
# rhbz#1477082
|
||||
Patch79: ksh-20120801-glibc-build-fix.patch
|
||||
|
||||
# rhbz#1459000
|
||||
Patch80: ksh-20120801-jobwait-sigstop.patch
|
||||
|
||||
Conflicts: pdksh
|
||||
Requires: coreutils, diffutils, chkconfig
|
||||
BuildRequires: bison
|
||||
@ -313,6 +316,10 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/binfmt.d/kshcomp.conf
|
||||
|
||||
%changelog
|
||||
* Mon Aug 14 2017 Siteshwar Vashisht <svashisht@redhat.com> - 20120801-39
|
||||
- Set terminal foreground process group while resuming process
|
||||
Resolves: #1459000
|
||||
|
||||
* Thu Aug 03 2017 Siteshwar Vashisht <svashisht@redhat.com> - 20120801-38
|
||||
- Fix build failures caused by update in glibc
|
||||
Resolves: #1477082
|
||||
|
Loading…
Reference in New Issue
Block a user