cd file did not produce any error
This commit is contained in:
parent
10497cb684
commit
01a16b1ff3
@ -1,6 +1,6 @@
|
||||
diff -up ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c.cdfix ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c
|
||||
--- ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c.cdfix 2013-01-04 18:54:11.890462334 +0100
|
||||
+++ ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c 2013-01-04 18:54:11.914462535 +0100
|
||||
--- ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c.cdfix 2013-02-01 16:04:55.507150242 +0100
|
||||
+++ ksh-20120801/src/cmd/ksh93/bltins/cd_pwd.c 2013-02-01 16:06:39.361007641 +0100
|
||||
@@ -214,7 +214,10 @@ int b_cd(int argc, char *argv[],Shbltin_
|
||||
if(*++dp=='.' && (*++dp=='/' || *dp==0))
|
||||
n++;
|
||||
|
7
ksh.spec
7
ksh.spec
@ -6,7 +6,7 @@ URL: http://www.kornshell.com/
|
||||
Group: System Environment/Shells
|
||||
License: EPL
|
||||
Version: 20120801
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Source0: http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
|
||||
Source1: http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
|
||||
Source2: kshcomp.conf
|
||||
@ -23,6 +23,7 @@ Patch2: ksh-20100826-fixregr.patch
|
||||
Patch3: rmdirfix.patch
|
||||
Patch4: ksh-20120801-cdfix.patch
|
||||
Patch5: ksh-20120801-tabfix.patch
|
||||
Patch6: ksh-20120801-cdfix2.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Conflicts: pdksh
|
||||
@ -47,6 +48,7 @@ with "sh" (the Bourne Shell).
|
||||
%patch3 -p1 -b .rmdirfix
|
||||
%patch4 -p1 -b .cdfix
|
||||
%patch5 -p1 -b .tabfix
|
||||
%patch6 -p1 -b .cdfix2
|
||||
|
||||
#/dev/fd test does not work because of mock
|
||||
sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
|
||||
@ -140,6 +142,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Fri Feb 01 2013 Michal Hlavinka <mhlavink@redhat.com> - 20120801-6
|
||||
- cd file did not produce any error
|
||||
|
||||
* Fri Jan 25 2013 Michal Hlavinka <mhlavink@redhat.com> - 20120801-5
|
||||
- ksh could not enter directories with path containing /.something (#889748)
|
||||
- file name autocomplete prevented following numeric input (#889745)
|
||||
|
Loading…
Reference in New Issue
Block a user