import kronosnet-1.22-3.el9
This commit is contained in:
parent
85087d8aff
commit
43d0fac8c0
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/kronosnet-1.21.tar.xz
|
SOURCES/kronosnet-1.22.tar.xz
|
||||||
|
@ -1 +1 @@
|
|||||||
c377962a50c474ceb3d644d05c81e568bef29bfa SOURCES/kronosnet-1.21.tar.xz
|
9e89dc037ead2591de47e871903ea6c9c4258679 SOURCES/kronosnet-1.22.tar.xz
|
||||||
|
@ -1,58 +0,0 @@
|
|||||||
commit e13b7c74634c511d44603a203a328f4d67920321
|
|
||||||
Author: Christine Caulfield <ccaulfie@redhat.com>
|
|
||||||
Date: Mon May 10 13:00:58 2021 +0100
|
|
||||||
|
|
||||||
[build] Add -fstack-clash-protection to release builds
|
|
||||||
|
|
||||||
CentOS Stream CI insists on this but it's generally a 'good thing'
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index e429dcc..020cbe1 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -173,6 +173,23 @@ AC_ARG_ENABLE([libnozzle],
|
|
||||||
|
|
||||||
AM_CONDITIONAL([BUILD_LIBNOZZLE], [test x$enable_libnozzle = xyes])
|
|
||||||
|
|
||||||
+## local helper functions
|
|
||||||
+# this function checks if CC support options passed as
|
|
||||||
+# args. Global CPPFLAGS are ignored during this test.
|
|
||||||
+cc_supports_flag() {
|
|
||||||
+ saveCPPFLAGS="$CPPFLAGS"
|
|
||||||
+ CPPFLAGS="$@"
|
|
||||||
+ if echo $CC | grep -q clang; then
|
|
||||||
+ CPPFLAGS="-Werror $CPPFLAGS"
|
|
||||||
+ fi
|
|
||||||
+ AC_MSG_CHECKING([whether $CC supports "$@"])
|
|
||||||
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
|
|
||||||
+ [RC=0; AC_MSG_RESULT([yes])],
|
|
||||||
+ [RC=1; AC_MSG_RESULT([no])])
|
|
||||||
+ CPPFLAGS="$saveCPPFLAGS"
|
|
||||||
+ return $RC
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
# Checks for libraries.
|
|
||||||
AX_PTHREAD(,[AC_MSG_ERROR([POSIX threads support is required])])
|
|
||||||
saved_LIBS="$LIBS"
|
|
||||||
@@ -297,12 +314,20 @@ AC_ARG_WITH([testdir],
|
|
||||||
|
|
||||||
AC_SUBST([TESTDIR])
|
|
||||||
|
|
||||||
+# Check for availablility of hardening options
|
|
||||||
+HARDENING_FLAGS="-fstack-clash-protection"
|
|
||||||
+for j in $HARDENING_FLAGS; do
|
|
||||||
+ if cc_supports_flag $j; then
|
|
||||||
+ EXTRA_HARDENING_FLAGS="$EXTRA_HARDENING_FLAGS $j";
|
|
||||||
+ fi
|
|
||||||
+done
|
|
||||||
+
|
|
||||||
# debug build stuff
|
|
||||||
if test "x${enable_debug}" = xyes; then
|
|
||||||
AC_DEFINE_UNQUOTED([DEBUG], [1], [Compiling Debugging code])
|
|
||||||
OPT_CFLAGS="-O0"
|
|
||||||
else
|
|
||||||
- OPT_CFLAGS="-O3"
|
|
||||||
+ OPT_CFLAGS="-O3 $EXTRA_HARDENING_FLAGS"
|
|
||||||
fi
|
|
||||||
|
|
||||||
# gdb flags
|
|
@ -25,7 +25,7 @@
|
|||||||
%bcond_with rpmdebuginfo
|
%bcond_with rpmdebuginfo
|
||||||
%bcond_with overriderpmdebuginfo
|
%bcond_with overriderpmdebuginfo
|
||||||
%bcond_without buildman
|
%bcond_without buildman
|
||||||
%bcond_with installtests
|
%bcond_without installtests
|
||||||
|
|
||||||
%if %{with overriderpmdebuginfo}
|
%if %{with overriderpmdebuginfo}
|
||||||
%undefine _enable_debug_packages
|
%undefine _enable_debug_packages
|
||||||
@ -36,13 +36,13 @@
|
|||||||
|
|
||||||
Name: kronosnet
|
Name: kronosnet
|
||||||
Summary: Multipoint-to-Multipoint VPN daemon
|
Summary: Multipoint-to-Multipoint VPN daemon
|
||||||
Version: 1.21
|
Version: 1.22
|
||||||
Release: 4%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: https://kronosnet.org
|
URL: https://kronosnet.org
|
||||||
Source0: https://kronosnet.org/releases/%{name}-%{version}.tar.xz
|
Source0: https://kronosnet.org/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: bz1954551-enable-stack-clash-protection.patch
|
#Patch0: bz1954551-enable-stack-clash-protection.patch
|
||||||
|
|
||||||
# Build dependencies
|
# Build dependencies
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -87,7 +87,7 @@ BuildRequires: autoconf automake libtool
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch0 -p1 -b .bz1954551-enable-stack-clash-protection
|
#%patch0 -p1 -b .bz1954551-enable-stack-clash-protection
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with runautogen}
|
%if %{with runautogen}
|
||||||
@ -439,6 +439,14 @@ Requires: libknet1%{_isa} = %{version}-%{release}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 06 2021 Christine Caulfield <ccaulfie@redhat.com> - 1.22-3
|
||||||
|
- Add back the test suite that got lost in the pull from Fedora
|
||||||
|
Resolves: rhbz#1999980
|
||||||
|
|
||||||
|
* Wed Oct 06 2021 Christine Caulfield <ccaulfie@redhat.com> - 1.22-1
|
||||||
|
- Rebase to v1.22
|
||||||
|
Resolves: rhbz#1999980
|
||||||
|
|
||||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.21-4
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.21-4
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
|
Loading…
Reference in New Issue
Block a user