908aeb56b2
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/krb5#501e2980728bcbd0c757fd9bb2b6274342420d2a
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
From c6e103db0eb02c31a13b8cbcbae296c473074991 Mon Sep 17 00:00:00 2001
|
|
From: Robbie Harwood <rharwood@redhat.com>
|
|
Date: Tue, 23 Aug 2016 16:49:25 -0400
|
|
Subject: [PATCH] [downstream] fix debuginfo with y.tab.c
|
|
|
|
We want to keep these y.tab.c files around because the debuginfo points to
|
|
them. It would be more elegant at the end to use symbolic links, but that
|
|
could mess up people working in the tree on other things.
|
|
|
|
Last-updated: krb5-1.9
|
|
---
|
|
src/kadmin/cli/Makefile.in | 5 +++++
|
|
src/plugins/kdb/ldap/ldap_util/Makefile.in | 2 +-
|
|
2 files changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/kadmin/cli/Makefile.in b/src/kadmin/cli/Makefile.in
|
|
index adfea6e2b..d1327e400 100644
|
|
--- a/src/kadmin/cli/Makefile.in
|
|
+++ b/src/kadmin/cli/Makefile.in
|
|
@@ -37,3 +37,8 @@ clean-unix::
|
|
# CC_LINK is not meant for compilation and this use may break in the future.
|
|
datetest: getdate.c
|
|
$(CC_LINK) $(ALL_CFLAGS) -DTEST -o datetest getdate.c
|
|
+
|
|
+%.c: %.y
|
|
+ $(RM) y.tab.c $@
|
|
+ $(YACC.y) $<
|
|
+ $(CP) y.tab.c $@
|
|
diff --git a/src/plugins/kdb/ldap/ldap_util/Makefile.in b/src/plugins/kdb/ldap/ldap_util/Makefile.in
|
|
index 8669c2436..a22f23c02 100644
|
|
--- a/src/plugins/kdb/ldap/ldap_util/Makefile.in
|
|
+++ b/src/plugins/kdb/ldap/ldap_util/Makefile.in
|
|
@@ -20,7 +20,7 @@ $(PROG): $(OBJS) $(KADMSRV_DEPLIBS) $(KRB5_BASE_DEPLIB) $(GETDATE)
|
|
getdate.c: $(GETDATE)
|
|
$(RM) getdate.c y.tab.c
|
|
$(YACC) $(GETDATE)
|
|
- $(MV) y.tab.c getdate.c
|
|
+ $(CP) y.tab.c getdate.c
|
|
|
|
install:
|
|
$(INSTALL_PROGRAM) $(PROG) ${DESTDIR}$(ADMIN_BINDIR)/$(PROG)
|