9d642021d7
Stop building and packaging PDFs
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From c58dbf05938b57a729d1b3811424866296f11998 Mon Sep 17 00:00:00 2001
|
|
From: Greg Hudson <ghudson@mit.edu>
|
|
Date: Sat, 3 Aug 2019 13:30:28 -0400
|
|
Subject: [PATCH] Skip URI tests when using asan
|
|
|
|
resolve_wrapper uses RTLD_DEEPBIND to load libresolv, triggering a
|
|
failure in the asan runtime.
|
|
|
|
(cherry picked from commit dbcec74b277952adf6e49d087932d2d0ea5393d1)
|
|
---
|
|
src/lib/krb5/os/Makefile.in | 10 +++++++---
|
|
1 file changed, 7 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/lib/krb5/os/Makefile.in b/src/lib/krb5/os/Makefile.in
|
|
index 91b0486b8..f523a5ac8 100644
|
|
--- a/src/lib/krb5/os/Makefile.in
|
|
+++ b/src/lib/krb5/os/Makefile.in
|
|
@@ -232,12 +232,16 @@ check-unix-locate: t_locate_kdc
|
|
echo 'Skipped t_locate_kdc test: OFFLINE' >> $(SKIPTESTS); \
|
|
fi
|
|
|
|
+ASAN = @ASAN@
|
|
check-unix-uri: t_locate_kdc
|
|
- if [ $(HAVE_RESOLV_WRAPPER) = 1 ]; then \
|
|
- $(RUNPYTEST) $(srcdir)/t_discover_uri.py $(PYTESTFLAGS); \
|
|
- else \
|
|
+ if [ $(HAVE_RESOLV_WRAPPER) = 0 ]; then \
|
|
echo '*** WARNING: skipped t_discover_uri.py due to not using resolv_wrapper'; \
|
|
echo 'Skipped URI discovery tests: resolv_wrapper 1.1.5 not found' >> $(SKIPTESTS); \
|
|
+ elif [ $(ASAN) = yes ]; then \
|
|
+ echo '*** Skipping URI discovery tests: resolv_wrapper is incompatible with asan'; \
|
|
+ echo 'Skipped URI discovery tests: incompatible with asan' >> $(SKIPTESTS); \
|
|
+ else \
|
|
+ $(RUNPYTEST) $(srcdir)/t_discover_uri.py $(PYTESTFLAGS); \
|
|
fi
|
|
|
|
check-unix-trace: t_trace
|