krb5/Use-GSSAPI-fallback-skiptest.patch
2017-06-07 15:18:05 +00:00

36 lines
1.1 KiB
Diff

From 659b4dd127cdd001e34ea4faf30885f7b1bc4945 Mon Sep 17 00:00:00 2001
From: Robbie Harwood <rharwood@redhat.com>
Date: Wed, 1 Mar 2017 17:46:22 -0500
Subject: [PATCH] Use GSSAPI fallback skiptest
Also-authored-by: Matt Rogers <mrogers@redhat.com>
[rharwood@redhat.com: Adjusted patch to apply]
---
src/appl/gss-sample/Makefile.in | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/src/appl/gss-sample/Makefile.in b/src/appl/gss-sample/Makefile.in
index 28e59f90f..9806fd327 100644
--- a/src/appl/gss-sample/Makefile.in
+++ b/src/appl/gss-sample/Makefile.in
@@ -6,6 +6,8 @@ SRCS= $(srcdir)/gss-client.c $(srcdir)/gss-misc.c $(srcdir)/gss-server.c
OBJS= gss-client.o gss-misc.o gss-server.o
+LBITS = $(shell /usr/bin/getconf LONG_BIT)
+
all-unix: gss-server gss-client
##WIN32##VERSIONRC = $(BUILDTOP)\windows\version.rc
@@ -43,7 +45,9 @@ clean-unix::
$(RM) gss-server gss-client
check-pytests:
- $(RUNPYTEST) $(srcdir)/t_gss_sample.py $(PYTESTFLAGS)
+ if ! [ $(LBITS) -eq 32 ]; then \
+ $(RUNPYTEST) $(srcdir)/t_gss_sample.py $(PYTESTFLAGS); \
+ fi
install-unix:
$(INSTALL_PROGRAM) gss-client $(DESTDIR)$(CLIENT_BINDIR)/gss-client