- don't include <term.h> into the telnet client when we're not using curses

This commit is contained in:
Nalin Dahyabhai 2005-03-16 22:59:54 +00:00
parent d46e1d65be
commit fe186e59d9
2 changed files with 21 additions and 40 deletions

View File

@ -1,37 +1,19 @@
If HAVE_SETUPTERM isn't defined (because we didn't find setupterm, because we
linked with libtermcap instead of libcurses), then we define our own version,
but we still include <term.h>, so the prototypes conflict. So just use curses.
--- krb5-1.4/src/appl/telnet/configure.in 2005-03-15 16:42:35.882145050 -0500
+++ krb5-1.4/src/appl/telnet/configure.in 2005-03-15 16:42:30.802808371 -0500
@@ -50,11 +50,12 @@
Prevent an incompatible declaration for setupterm(), declared for curses
in <term.h>, from being used when we're building with termcap.
--- krb5/src/appl/telnet/telnet/telnet.c 2005-03-15 19:26:12.676150256 -0500
+++ krb5/src/appl/telnet/telnet/telnet.c 2005-03-15 19:26:07.382841519 -0500
@@ -52,9 +52,13 @@
#include <curses.h>
#endif
])
dnl
-AC_CHECK_LIB(termcap,main,AC_DEFINE(TERMCAP)
-LIBS="$LIBS -ltermcap",
+dnl AC_CHECK_LIB(termcap,main,AC_DEFINE(TERMCAP)
+dnl LIBS="$LIBS -ltermcap",
AC_CHECK_LIB(curses,setupterm,LIBS="$LIBS -lcurses",
AC_CHECK_LIB(ncurses,setupterm,LIBS="$LIBS -lncurses")
-))
+)
+dnl ))
KRB5_AC_INET6
AC_CHECK_FUNCS(setupterm)
AC_CHECK_HEADER(termios.h,AC_DEFINE(USE_TERMIO) ac_termio=1)
@@ -96,11 +97,12 @@
dnl from old telnetd/configure.in
dnl
dnl AC_PROG_INSTALL
-AC_CHECK_LIB(termcap,main,AC_DEFINE(TERMCAP)
-LIBS="$LIBS -ltermcap",
+dnl AC_CHECK_LIB(termcap,main,AC_DEFINE(TERMCAP)
+dnl LIBS="$LIBS -ltermcap",
AC_CHECK_LIB(curses,setupterm,LIBS="$LIBS -lcurses",
AC_CHECK_LIB(ncurses,setupterm,LIBS="$LIBS -lncurses")
-))
+)
+dnl ))
dnl ... whole termios.h/termio.h/NO_CC_T thing again ...
AC_HEADER_TIME
dnl KRB5_AC_INET6
+#ifndef TERMCAP
#ifdef HAVE_TERM_H
#include <term.h>
#endif
+#else
+#include <termcap.h>
+#endif
#include <arpa/telnet.h>

View File

@ -7,7 +7,7 @@
Summary: The Kerberos network authentication system.
Name: krb5
Version: 1.4
Release: 1
Release: 2
# Maybe we should explode from the now-available-to-everybody tarball instead?
# http://web.mit.edu/kerberos/dist/krb5/1.4/krb5-1.4-signed.tar
Source0: krb5-%{version}.tar.gz
@ -126,9 +126,8 @@ workstation.
%changelog
# - XXX krb5_init_ets is gone now, what to do?
* Tue Mar 15 2005 Nalin Dahyabhai <nalin@redhat.com>
- use libncurses instead of libtermcap for the telnet client, because it
provides setupterm(), which we can use instead of the internal version
* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 1.4-2
- don't include <term.h> into the telnet client when we're not using curses
* Thu Feb 24 2005 Nalin Dahyabhai <nalin@redhat.com> 1.4-1
- update to 1.4