auto-import changelog data from krb5-1.3.3-3.src.rpm
Wed May 12 2004 Thomas Woerner <twoerner@redhat.com> 1.3.3-3 - removed rpath Thu Apr 15 2004 Nalin Dahyabhai <nalin@redhat.com> 1.3.3-2 - re-enable large file support, fell out in 1.3-1 - patch rcp to use long long and %lld format specifiers when reporting file sizes on large files
This commit is contained in:
parent
7ebd8dc643
commit
d4f2fb9dc3
47
krb5-1.3.3-rcp-sendlarge.patch
Normal file
47
krb5-1.3.3-rcp-sendlarge.patch
Normal file
@ -0,0 +1,47 @@
|
||||
Fix sending of large files. This isn't *quite* right, because we still have to
|
||||
open the file right to avoid EFBIG errors, and this patch doesn't fix that.
|
||||
Either we build with -D_FILE_OFFSET_BITS=64, change open() to open64(), or
|
||||
pass O_LARGEFILE to open(), none of which are easy to automate.
|
||||
|
||||
--- krb5-1.3.3/src/appl/bsd/krcp.c 2004-04-15 00:40:00.000000000 -0400
|
||||
+++ krb5-1.3.3/src/appl/bsd/krcp.c 2004-04-15 00:55:38.000000000 -0400
|
||||
@@ -819,8 +819,13 @@
|
||||
continue;
|
||||
}
|
||||
}
|
||||
+#ifdef HAVE_LONG_LONG
|
||||
+ (void) sprintf(buf, "C%04o %lld %s\n",
|
||||
+ (int) stb.st_mode&07777, (long long) stb.st_size, last);
|
||||
+#else
|
||||
(void) sprintf(buf, "C%04o %ld %s\n",
|
||||
(int) stb.st_mode&07777, (long ) stb.st_size, last);
|
||||
+#endif
|
||||
(void) rcmd_stream_write(rem, buf, strlen(buf), 0);
|
||||
if (response() < 0) {
|
||||
(void) close(f);
|
||||
--- krb5-1.3.3/src/appl/bsd/v4rcp.c 2004-04-15 00:40:28.000000000 -0400
|
||||
+++ krb5-1.3.3/src/appl/bsd/v4rcp.c 2004-04-15 00:46:57.000000000 -0400
|
||||
@@ -538,8 +538,13 @@
|
||||
continue;
|
||||
}
|
||||
}
|
||||
+#ifdef HAVE_LONG_LONG
|
||||
+ (void) sprintf(buf, "C%04o %lld %s\n",
|
||||
+ (unsigned int) stb.st_mode&07777, (long long) stb.st_size, last);
|
||||
+#else
|
||||
(void) sprintf(buf, "C%04o %ld %s\n",
|
||||
(unsigned int) stb.st_mode&07777, (long) stb.st_size, last);
|
||||
+#endif
|
||||
kstream_write (krem, buf, strlen (buf));
|
||||
if (response() < 0) {
|
||||
(void) close(f);
|
||||
--- krb5-1.3.3/src/appl/bsd/configure.in 2004-04-15 00:52:22.000000000 -0400
|
||||
+++ krb5-1.3.3/src/appl/bsd/configure.in 2004-04-15 00:52:16.000000000 -0400
|
||||
@@ -77,6 +77,7 @@
|
||||
AC_TYPE_MODE_T
|
||||
AC_CHECK_FUNCS(isatty inet_aton getenv gettosbyname killpg initgroups setpriority setreuid setresuid waitpid setsid ptsname setlogin tcgetpgrp tcsetpgrp setpgid strsave utimes rmufile rresvport_af)
|
||||
AC_CHECK_HEADERS(unistd.h stdlib.h string.h sys/filio.h sys/sockio.h sys/label.h sys/tty.h ttyent.h lastlog.h sys/select.h sys/ptyvar.h utmp.h sys/time.h krb4-proto.h sys/ioctl_compat.h paths.h arpa/nameser.h)
|
||||
+AC_CHECK_TYPES([long long])
|
||||
AC_HEADER_STDARG
|
||||
AC_REPLACE_FUNCS(getdtablesize)
|
||||
dnl
|
18
krb5.spec
18
krb5.spec
@ -7,7 +7,7 @@
|
||||
Summary: The Kerberos network authentication system.
|
||||
Name: krb5
|
||||
Version: 1.3.3
|
||||
Release: 1
|
||||
Release: 3
|
||||
# Maybe we should explode from the now-available-to-everybody tarball instead?
|
||||
# http://web.mit.edu/kerberos/www/dist/krb5/1.3/krb5-1.3.2.tar
|
||||
Source0: krb5-%{version}.tar.gz
|
||||
@ -43,7 +43,7 @@ Patch12: krb5-1.3-ktany.patch
|
||||
Patch13: krb5-1.3-large-file.patch
|
||||
Patch14: krb5-1.3-ftp-glob.patch
|
||||
Patch15: krb5-1.3-check.patch
|
||||
Patch16: krb5-1.3-no-rpath.patch
|
||||
Patch16: krb5-1.3.3-no-rpath.patch
|
||||
Patch17: krb5-1.3-pass-by-address.patch
|
||||
Patch18: krb5-1.2.7-reject-bad-transited.patch
|
||||
Patch19: krb5-1.2.7-krb524d-double-free.patch
|
||||
@ -54,6 +54,7 @@ Patch23: krb5-1.3.1-dns.patch
|
||||
Patch24: krb5-1.3.1-server-sort.patch
|
||||
Patch25: krb5-1.3.1-null.patch
|
||||
Patch26: krb5-1.3.2-efence.patch
|
||||
Patch27: krb5-1.3.3-rcp-sendlarge.patch
|
||||
|
||||
License: MIT, freely distributable.
|
||||
URL: http://web.mit.edu/kerberos/www/
|
||||
@ -117,6 +118,14 @@ network uses Kerberos, this package should be installed on every
|
||||
workstation.
|
||||
|
||||
%changelog
|
||||
* Wed May 12 2004 Thomas Woerner <twoerner@redhat.com> 1.3.3-3
|
||||
- removed rpath
|
||||
|
||||
* Thu Apr 15 2004 Nalin Dahyabhai <nalin@redhat.com> 1.3.3-2
|
||||
- re-enable large file support, fell out in 1.3-1
|
||||
- patch rcp to use long long and %%lld format specifiers when reporting file
|
||||
sizes on large files
|
||||
|
||||
* Tue Apr 13 2004 Nalin Dahyabhai <nalin@redhat.com> 1.3.3-1
|
||||
- update to 1.3.3
|
||||
|
||||
@ -679,6 +688,7 @@ workstation.
|
||||
%patch25 -p1 -b .null
|
||||
# Removes a malloc(0) case, nothing more.
|
||||
# %patch26 -p1 -b .efence
|
||||
%patch27 -p1 -b .rcp-sendlarge
|
||||
cp src/krb524/README README.krb524
|
||||
find . -type f -name "*.info-dir" -exec rm -fv "{}" ";"
|
||||
gzip doc/*.ps
|
||||
@ -693,6 +703,10 @@ done
|
||||
%build
|
||||
cd src
|
||||
INCLUDES=-I%{_includedir}/et
|
||||
# Get LFS support on systems that need it which aren't already 64-bit.
|
||||
%ifarch %{ix86} s390 ppc sparc
|
||||
DEFINES="-D_FILE_OFFSET_BITS=64" ; export DEFINES
|
||||
%endif
|
||||
CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS $DEFINES $INCLUDES -fPIC`"
|
||||
%configure \
|
||||
CC=%{__cc} \
|
||||
|
Loading…
Reference in New Issue
Block a user