update to 1.10.2

- when building the new label for a file we're about to create, also mix
  in the current range, in addition to the current user
- also package the PDF format admin, user, and install guides
- drop some PDFs that no longer get built right
This commit is contained in:
Nalin Dahyabhai 2012-06-01 14:05:55 -04:00
parent cd92a2cbb4
commit b8b71859bb
6 changed files with 41 additions and 30 deletions

3
.gitignore vendored
View File

@ -69,3 +69,6 @@ krb5-1.8.3-pdf.tar.gz
/krb5-1.10.1.tar.gz /krb5-1.10.1.tar.gz
/krb5-1.10.1.tar.gz.asc /krb5-1.10.1.tar.gz.asc
/krb5-1.10.1-pdf.tar.xz /krb5-1.10.1-pdf.tar.xz
/krb5-1.10.2.tar.gz
/krb5-1.10.2.tar.gz.asc
/krb5-1.10.2-pdf.tar.xz

View File

@ -33,7 +33,7 @@ configure scripts should be rebuilt. Originally RT#6525
--- krb5/src/configure.in --- krb5/src/configure.in
+++ krb5/src/configure.in +++ krb5/src/configure.in
@@ -1054,6 +1054,17 @@ fi @@ -1054,6 +1054,17 @@ fi
KRB5_WITH_PAM AC_SUBST(localedir)
AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config]) AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config])
+ +

View File

@ -747,6 +747,6 @@ diff -up krb5-1.8/src/configure.in.pam krb5-1.8/src/configure.in
+KRB5_WITH_PAM +KRB5_WITH_PAM
+ +
AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config]) # Make localedir work in autoconf 2.5x.
V5_AC_OUTPUT_MAKEFILE(. if test "${localedir+set}" != set; then
localedir='$(datadir)/locale'

View File

@ -120,9 +120,9 @@ which we used earlier, is some improvement.
+KRB5_WITH_SELINUX +KRB5_WITH_SELINUX
+ +
AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config]) # Make localedir work in autoconf 2.5x.
if test "${localedir+set}" != set; then
V5_AC_OUTPUT_MANPAGE([ localedir='$(datadir)/locale'
--- krb5/src/include/k5-int.h --- krb5/src/include/k5-int.h
+++ krb5/src/include/k5-int.h +++ krb5/src/include/k5-int.h
@@ -133,6 +133,7 @@ typedef unsigned char u_char; @@ -133,6 +133,7 @@ typedef unsigned char u_char;
@ -465,7 +465,7 @@ which we used earlier, is some improvement.
--- krb5/src/util/support/selinux.c --- krb5/src/util/support/selinux.c
+++ krb5/src/util/support/selinux.c +++ krb5/src/util/support/selinux.c
@@ -0,0 +1,373 @@ @@ -0,0 +1,379 @@
+/* +/*
+ * Copyright 2007,2008,2009,2011,2012 Red Hat, Inc. All Rights Reserved. + * Copyright 2007,2008,2009,2011,2012 Red Hat, Inc. All Rights Reserved.
+ * + *
@ -540,7 +540,7 @@ which we used earlier, is some improvement.
+{ +{
+ security_context_t previous, configuredsc, currentsc, derivedsc; + security_context_t previous, configuredsc, currentsc, derivedsc;
+ context_t current, derived; + context_t current, derived;
+ const char *fullpath, *currentuser; + const char *fullpath, *currentuser, *currentrange;
+#ifdef HAVE_SELINUX_LABEL_H +#ifdef HAVE_SELINUX_LABEL_H
+ struct selabel_handle *ctx; + struct selabel_handle *ctx;
+#endif +#endif
@ -624,10 +624,16 @@ which we used earlier, is some improvement.
+ if (currentuser != NULL) { + if (currentuser != NULL) {
+ if (context_user_set(derived, + if (context_user_set(derived,
+ currentuser) == 0) { + currentuser) == 0) {
+ derivedsc = context_str(derived); + currentrange = context_range_get(current);
+ if (derivedsc != NULL) { + if (currentrange != NULL) {
+ freecon(configuredsc); + if (context_range_set(derived,
+ configuredsc = strdup(derivedsc); + currentrange) == 0) {
+ derivedsc = context_str(derived);
+ if (derivedsc != NULL) {
+ freecon(configuredsc);
+ configuredsc = strdup(derivedsc);
+ }
+ }
+ } + }
+ } + }
+ } + }

View File

@ -14,10 +14,10 @@
Summary: The Kerberos network authentication system Summary: The Kerberos network authentication system
Name: krb5 Name: krb5
Version: 1.10.1 Version: 1.10.2
Release: 3%{?dist} Release: 1%{?dist}
# Maybe we should explode from the now-available-to-everybody tarball instead? # Maybe we should explode from the now-available-to-everybody tarball instead?
# http://web.mit.edu/kerberos/dist/krb5/1.10/krb5-1.10.1-signed.tar # http://web.mit.edu/kerberos/dist/krb5/1.10/krb5-1.10.2-signed.tar
Source0: krb5-%{version}.tar.gz Source0: krb5-%{version}.tar.gz
Source1: krb5-%{version}.tar.gz.asc Source1: krb5-%{version}.tar.gz.asc
Source2: kprop.service Source2: kprop.service
@ -51,9 +51,9 @@ Patch30: krb5-1.3.4-send-pr-tempfile.patch
Patch39: krb5-1.8-api.patch Patch39: krb5-1.8-api.patch
Patch56: krb5-1.10-doublelog.patch Patch56: krb5-1.10-doublelog.patch
Patch59: krb5-1.10-kpasswd_tcp.patch Patch59: krb5-1.10-kpasswd_tcp.patch
Patch60: krb5-1.10-pam.patch Patch60: krb5-1.10.2-pam.patch
Patch61: krb5-1.10-manpaths.patch Patch61: krb5-1.10.2-manpaths.patch
Patch63: krb5-1.10-selinux-label.patch Patch63: krb5-1.10.2-selinux-label.patch
Patch71: krb5-1.9-dirsrv-accountlock.patch Patch71: krb5-1.9-dirsrv-accountlock.patch
Patch75: krb5-pkinit-debug.patch Patch75: krb5-pkinit-debug.patch
Patch86: krb5-1.9-debuginfo.patch Patch86: krb5-1.9-debuginfo.patch
@ -262,10 +262,6 @@ popd
sh %{SOURCE24} check << EOF sh %{SOURCE24} check << EOF
doc/api library krb5 doc/api library krb5
doc/implement implement doc/implement implement
doc/kadm5 adb-unit-test
doc/kadm5 api-unit-test
doc/kadm5 api-funcspec
doc/kadm5 api-server-design
EOF EOF
# Generate an FDS-compatible LDIF file. # Generate an FDS-compatible LDIF file.
@ -535,7 +531,7 @@ exit 0
%files workstation %files workstation
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc doc/user*.ps.gz src/config-files/services.append %doc doc/user*.ps.gz doc/user*.pdf src/config-files/services.append
%doc doc/{kdestroy,kinit,klist,kpasswd,ksu}.html %doc doc/{kdestroy,kinit,klist,kpasswd,ksu}.html
%doc doc/krb5-user.html %doc doc/krb5-user.html
%attr(0755,root,root) %doc src/config-files/convert-config-files %attr(0755,root,root) %doc src/config-files/convert-config-files
@ -589,6 +585,8 @@ exit 0
%config(noreplace) /etc/logrotate.d/krb5kdc %config(noreplace) /etc/logrotate.d/krb5kdc
%config(noreplace) /etc/logrotate.d/kadmind %config(noreplace) /etc/logrotate.d/kadmind
%doc doc/admin*.pdf
%doc doc/install*.pdf
%doc doc/admin*.ps.gz %doc doc/admin*.ps.gz
%doc doc/install*.ps.gz %doc doc/install*.ps.gz
%doc doc/krb5-admin.html %doc doc/krb5-admin.html
@ -705,10 +703,7 @@ exit 0
%files devel %files devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%docdir %{_mandir} %docdir %{_mandir}
%doc doc/api/*.pdf
%doc doc/ccapi %doc doc/ccapi
%doc doc/implement/*.pdf
%doc doc/kadm5/*.pdf
%doc doc/kadmin %doc doc/kadmin
%doc doc/kim %doc doc/kim
%doc doc/krb5-protocol %doc doc/krb5-protocol
@ -745,6 +740,13 @@ exit 0
%{_sbindir}/uuserver %{_sbindir}/uuserver
%changelog %changelog
* Fri Jun 1 2012 Nalin Dahyabhai <nalin@redhat.com> 1.10.2-1
- update to 1.10.2
- when building the new label for a file we're about to create, also mix
in the current range, in addition to the current user
- also package the PDF format admin, user, and install guides
- drop some PDFs that no longer get built right
* Mon May 7 2012 Nalin Dahyabhai <nalin@redhat.com> * Mon May 7 2012 Nalin Dahyabhai <nalin@redhat.com>
- skip the setfscreatecon() if fopen() is passed "rb" as the open mode (part - skip the setfscreatecon() if fopen() is passed "rb" as the open mode (part
of #819115) of #819115)

View File

@ -1,3 +1,3 @@
95b770bdae70789f72553ea428af97aa krb5-1.10.1.tar.gz 73c89ed430f92df7d10c49167eec889b krb5-1.10.2.tar.gz
e6c2754e7d532db46856c2e0ce6f8c74 krb5-1.10.1.tar.gz.asc 53994fb4ccbeaf6d017d657942093502 krb5-1.10.2.tar.gz.asc
4ea803a4273191bee410e4ea40f1adb9 krb5-1.10.1-pdf.tar.xz ddebe423b4d60fe957ab7c22dbc8a7ea krb5-1.10.2-pdf.tar.xz