Fix gitignore problem with previous patchset
This commit is contained in:
parent
2c340efca2
commit
99cea2e511
@ -1,4 +1,4 @@
|
||||
From 09304f3859f2dd637b7cc27ba1cb3fb3603a3576 Mon Sep 17 00:00:00 2001
|
||||
From a675384ef4cc4b6d28cce20cbcef0d033206139a Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Sat, 13 Jun 2015 16:04:53 -0400
|
||||
Subject: [PATCH] Add ASN.1 encoders and decoders for SPAKE types
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 0284b6503c003af90b9c317620d38b488dadcf86 Mon Sep 17 00:00:00 2001
|
||||
From bcc764eca6c92210716d1d6db59bfe112522a95d Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Fri, 25 Sep 2015 17:47:35 -0400
|
||||
Subject: [PATCH] Add SPAKE preauth support
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c4c9ca6edde2157cd42839d227e5f3defd4011a1 Mon Sep 17 00:00:00 2001
|
||||
From 6410daacd3b14ca1b96889f3db5ea9c94bf58734 Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Tue, 27 Mar 2018 00:49:43 -0400
|
||||
Subject: [PATCH] Add doc index entries for SPAKE constants
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 4705fc3c9df924b0c1de015e63f95f98eb563dd3 Mon Sep 17 00:00:00 2001
|
||||
From 87e99d886fe8ea74521e73f8f0a8445353162526 Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Thu, 4 Jan 2018 14:35:12 -0500
|
||||
Subject: [PATCH] Add k5_buf_add_vfmt to k5buf interface
|
||||
|
@ -1,34 +1,22 @@
|
||||
From 9fa4d4095164c09b70061fce5c31ccbd97bc7553 Mon Sep 17 00:00:00 2001
|
||||
From 443151a0690d3f11b38db54f650b320cb733535f Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Mon, 19 Feb 2018 00:51:44 -0500
|
||||
Subject: [PATCH] Add libkrb5support hex functions and tests
|
||||
|
||||
(cherry picked from commit 720dea558da0062d3cea4385327161e62cf09a5e)
|
||||
[rharwood@redhat.com Remove .gitignore]
|
||||
---
|
||||
.gitignore | 1 +
|
||||
src/include/k5-hex.h | 53 ++++++++
|
||||
src/util/support/Makefile.in | 15 ++-
|
||||
src/util/support/deps | 6 +
|
||||
src/util/support/hex.c | 116 ++++++++++++++++++
|
||||
src/util/support/libkrb5support-fixed.exports | 2 +
|
||||
src/util/support/t_hex.c | 169 ++++++++++++++++++++++++++
|
||||
7 files changed, 359 insertions(+), 3 deletions(-)
|
||||
6 files changed, 358 insertions(+), 3 deletions(-)
|
||||
create mode 100644 src/include/k5-hex.h
|
||||
create mode 100644 src/util/support/hex.c
|
||||
create mode 100644 src/util/support/t_hex.c
|
||||
|
||||
diff --git a/.gitignore b/.gitignore
|
||||
index c13b5e356..91c8b942e 100644
|
||||
--- a/.gitignore
|
||||
+++ b/.gitignore
|
||||
@@ -517,6 +517,7 @@ local.properties
|
||||
|
||||
/src/util/support/libkrb5support.exports
|
||||
/src/util/support/t_base64
|
||||
+/src/util/support/t_hex
|
||||
/src/util/support/t_json
|
||||
/src/util/support/t_k5buf
|
||||
/src/util/support/t_path
|
||||
diff --git a/src/include/k5-hex.h b/src/include/k5-hex.h
|
||||
new file mode 100644
|
||||
index 000000000..75bd2cb19
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 73fe8ea67105a4e056c82a0593dad8e6820f05d4 Mon Sep 17 00:00:00 2001
|
||||
From 181d3a9e2d274b49a2830895a59ce1b22be4000a Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Sat, 3 Feb 2018 20:53:42 -0500
|
||||
Subject: [PATCH] Add vector support to k5_sha256()
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 7a578d56d42d12973ec17be4cffd983c57aa38c9 Mon Sep 17 00:00:00 2001
|
||||
From 4656f809f0f50c3a0a82192f9436e3292a5fe82a Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Mon, 26 Mar 2018 11:12:39 -0400
|
||||
Subject: [PATCH] Implement k5_buf_init_dynamic_zap
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 5824de8b471d132ed58eece98c614c56c7b0d48d Mon Sep 17 00:00:00 2001
|
||||
From b0fb55f284f543e1e3752512df1f581e77d486ca Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Mon, 26 Mar 2018 10:54:29 -0400
|
||||
Subject: [PATCH] Move zap() definition to k5-platform.h
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 9168f0c02a066543a8d03c60e4f05d5f4073f373 Mon Sep 17 00:00:00 2001
|
||||
From 678c67ef21578fb269f2efc56ff46bbd0e6b482b Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Mon, 26 Mar 2018 11:24:49 -0400
|
||||
Subject: [PATCH] Use k5_buf_init_dynamic_zap where appropriate
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a77bccb3fd953ae5800768efc0fb4a13753cb785 Mon Sep 17 00:00:00 2001
|
||||
From 4a33689d89144f9e473e8192241dcd2473c78bd7 Mon Sep 17 00:00:00 2001
|
||||
From: Greg Hudson <ghudson@mit.edu>
|
||||
Date: Mon, 19 Feb 2018 00:52:35 -0500
|
||||
Subject: [PATCH] Use libkrb5support hex functions where appropriate
|
||||
|
@ -18,7 +18,7 @@ Summary: The Kerberos network authentication system
|
||||
Name: krb5
|
||||
Version: 1.16
|
||||
# for prerelease, should be e.g., 0.% {prerelease}.1% { ?dist } (without spaces)
|
||||
Release: 15%{?dist}
|
||||
Release: 16%{?dist}
|
||||
|
||||
# lookaside-cached sources; two downloads and a build artifact
|
||||
Source0: https://web.mit.edu/kerberos/dist/krb5/1.16/krb5-%{version}%{prerelease}.tar.gz
|
||||
@ -734,6 +734,9 @@ exit 0
|
||||
%{_libdir}/libkadm5srv_mit.so.*
|
||||
|
||||
%changelog
|
||||
* Tue Mar 27 2018 Robbie Harwood <rharwood@redhat.com> - 1.16-16
|
||||
- Fix gitignore problem with previous patchset
|
||||
|
||||
* Tue Mar 27 2018 Robbie Harwood <rharwood@redhat.com> - 1.16-15
|
||||
- Add SPAKE support
|
||||
- Improve protections on internal sensitive buffers
|
||||
|
Loading…
Reference in New Issue
Block a user