- no longer referenced in .spec

This commit is contained in:
Nalin Dahyabhai 2009-08-24 15:51:29 +00:00
parent c297ec78d9
commit 764c9749f5
2 changed files with 0 additions and 44 deletions

View File

@ -1,19 +0,0 @@
Prevent an incompatible declaration for setupterm(), declared for curses
in <term.h>, from being used when we're building with termcap.
--- krb5/src/appl/telnet/telnet/telnet.c 2005-03-15 19:26:12.676150256 -0500
+++ krb5/src/appl/telnet/telnet/telnet.c 2005-03-15 19:26:07.382841519 -0500
@@ -52,9 +52,13 @@
#include <curses.h>
#endif
+#ifndef TERMCAP
#ifdef HAVE_TERM_H
#include <term.h>
#endif
+#else
+#include <termcap.h>
+#endif
#include <arpa/telnet.h>

View File

@ -1,25 +0,0 @@
We lock "krb5int_cc_file_mutex" before attempting to open the file in the
we-don't-have-mkstemp() case. And we shouldn't be trying to unlock it twice.
The function's rewritten in 1.6.4, but fix it here in the meantime.
--- krb5-1.6.3/src/lib/krb5/ccache/cc_file.c 2008-10-28 17:20:13.000000000 -0400
+++ krb5-1.6.3/src/lib/krb5/ccache/cc_file.c 2008-10-28 17:20:07.000000000 -0400
@@ -1976,8 +1976,9 @@ krb5_fcc_generate_new (krb5_context cont
mktemp(scratch);
/* Make sure the file name is reserved */
ret = THREEPARAMOPEN(scratch, O_CREAT | O_EXCL | O_WRONLY | O_BINARY, 0);
if (ret == -1) {
+ k5_mutex_unlock(&krb5int_cc_file_mutex);
return krb5_fcc_interpret(context, errno);
}
#endif
@@ -1995,9 +1996,8 @@ krb5_fcc_generate_new (krb5_context cont
k5_mutex_unlock(&krb5int_cc_file_mutex);
free(data);
close(ret);
unlink(scratch);
- k5_mutex_unlock(&krb5int_cc_file_mutex);
return KRB5_CC_NOMEM;
}
kret = k5_mutex_init(&data->lock);