Drop obsolete patch
This commit is contained in:
parent
aef7c262b1
commit
6265fcabf5
@ -1,39 +0,0 @@
|
|||||||
commit 13fd26e1863c79f616653f6a10a58c01f65fceff
|
|
||||||
Author: Greg Hudson <ghudson@mit.edu>
|
|
||||||
Date: Fri Dec 6 18:56:56 2013 -0500
|
|
||||||
|
|
||||||
Avoid malloc(0) in SPNEGO get_input_token
|
|
||||||
|
|
||||||
If we read a zero-length token in spnego_mech.c's get_input_token(),
|
|
||||||
set the value pointer to NULL instead of calling malloc(0).
|
|
||||||
|
|
||||||
ticket: 7794 (new)
|
|
||||||
|
|
||||||
diff --git a/src/lib/gssapi/spnego/spnego_mech.c b/src/lib/gssapi/spnego/spnego_mech.c
|
|
||||||
index 24c3440..3937662 100644
|
|
||||||
--- a/src/lib/gssapi/spnego/spnego_mech.c
|
|
||||||
+++ b/src/lib/gssapi/spnego/spnego_mech.c
|
|
||||||
@@ -3140,14 +3140,17 @@ get_input_token(unsigned char **buff_in, unsigned int buff_length)
|
|
||||||
return (NULL);
|
|
||||||
|
|
||||||
input_token->length = len;
|
|
||||||
- input_token->value = gssalloc_malloc(input_token->length);
|
|
||||||
+ if (input_token->length > 0) {
|
|
||||||
+ input_token->value = gssalloc_malloc(input_token->length);
|
|
||||||
+ if (input_token->value == NULL) {
|
|
||||||
+ free(input_token);
|
|
||||||
+ return (NULL);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
- if (input_token->value == NULL) {
|
|
||||||
- free(input_token);
|
|
||||||
- return (NULL);
|
|
||||||
+ memcpy(input_token->value, *buff_in, input_token->length);
|
|
||||||
+ } else {
|
|
||||||
+ input_token->value = NULL;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
- (void) memcpy(input_token->value, *buff_in, input_token->length);
|
|
||||||
*buff_in += input_token->length;
|
|
||||||
return (input_token);
|
|
||||||
}
|
|
12
krb5.spec
12
krb5.spec
@ -40,10 +40,10 @@
|
|||||||
|
|
||||||
Summary: The Kerberos network authentication system
|
Summary: The Kerberos network authentication system
|
||||||
Name: krb5
|
Name: krb5
|
||||||
Version: 1.12
|
Version: 1.12.1
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
# Maybe we should explode from the now-available-to-everybody tarball instead?
|
# Maybe we should explode from the now-available-to-everybody tarball instead?
|
||||||
# http://web.mit.edu/kerberos/dist/krb5/1.12/krb5-1.12-signed.tar
|
# http://web.mit.edu/kerberos/dist/krb5/1.12/krb5-1.12.1-signed.tar
|
||||||
Source0: krb5-%{version}.tar.gz
|
Source0: krb5-%{version}.tar.gz
|
||||||
Source1: krb5-%{version}.tar.gz.asc
|
Source1: krb5-%{version}.tar.gz.asc
|
||||||
# Use a dummy krb5-%{version}-pdf.tar.xz the first time through, then
|
# Use a dummy krb5-%{version}-pdf.tar.xz the first time through, then
|
||||||
@ -90,7 +90,6 @@ Patch86: krb5-1.9-debuginfo.patch
|
|||||||
Patch105: krb5-kvno-230379.patch
|
Patch105: krb5-kvno-230379.patch
|
||||||
Patch129: krb5-1.11-run_user_0.patch
|
Patch129: krb5-1.11-run_user_0.patch
|
||||||
Patch134: krb5-1.11-kpasswdtest.patch
|
Patch134: krb5-1.11-kpasswdtest.patch
|
||||||
Patch135: krb5-master-no-malloc0.patch
|
|
||||||
Patch136: krb5-master-ignore-empty-unnecessary-final-token.patch
|
Patch136: krb5-master-ignore-empty-unnecessary-final-token.patch
|
||||||
Patch137: krb5-master-gss_oid_leak.patch
|
Patch137: krb5-master-gss_oid_leak.patch
|
||||||
Patch138: krb5-master-keytab_close.patch
|
Patch138: krb5-master-keytab_close.patch
|
||||||
@ -316,7 +315,6 @@ ln -s NOTICE LICENSE
|
|||||||
%patch71 -p1 -b .dirsrv-accountlock %{?_rawbuild}
|
%patch71 -p1 -b .dirsrv-accountlock %{?_rawbuild}
|
||||||
%patch86 -p0 -b .debuginfo
|
%patch86 -p0 -b .debuginfo
|
||||||
%patch105 -p1 -b .kvno
|
%patch105 -p1 -b .kvno
|
||||||
%patch135 -p1 -b .no-malloc0
|
|
||||||
%patch136 -p1 -b .ignore-empty-unnecessary-final-token
|
%patch136 -p1 -b .ignore-empty-unnecessary-final-token
|
||||||
%patch137 -p1 -b .gss_oid_leak
|
%patch137 -p1 -b .gss_oid_leak
|
||||||
%patch138 -p1 -b .keytab_close
|
%patch138 -p1 -b .keytab_close
|
||||||
@ -978,6 +976,10 @@ exit 0
|
|||||||
%{_sbindir}/uuserver
|
%{_sbindir}/uuserver
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 17 2014 Nalin Dahyabhai <nalin@redhat.com> - 1.12.1-1
|
||||||
|
- update to 1.12.1
|
||||||
|
- drop patch for RT#7794, included now
|
||||||
|
|
||||||
* Mon Jan 13 2014 Nalin Dahyabhai <nalin@redhat.com> - 1.12-11
|
* Mon Jan 13 2014 Nalin Dahyabhai <nalin@redhat.com> - 1.12-11
|
||||||
- update the PIC patch for iaesx86.s to not use ELF relocations to the version
|
- update the PIC patch for iaesx86.s to not use ELF relocations to the version
|
||||||
that landed upstream (RT#7815, #1045699)
|
that landed upstream (RT#7815, #1045699)
|
||||||
|
Loading…
Reference in New Issue
Block a user