Bring back krb5.conf.d and allow building with bad krb5.conf

This commit is contained in:
Robbie Harwood 2015-09-29 14:47:00 -04:00
parent 1138991893
commit 5ccfdd171d
2 changed files with 87 additions and 2 deletions

View File

@ -0,0 +1,75 @@
diff --git a/src/lib/krad/Makefile.in b/src/lib/krad/Makefile.in
index 75431a0..6764d90 100644
--- a/src/lib/krad/Makefile.in
+++ b/src/lib/krad/Makefile.in
@@ -33,12 +33,18 @@ install-unix:: install-libs
clean-unix:: clean-liblinks clean-libs clean-libobjs
check-unix:: t_attr t_attrset t_code t_packet t_remote t_client
- $(RUN_SETUP) $(VALGRIND) ./t_attr
- $(RUN_SETUP) $(VALGRIND) ./t_attrset
- $(RUN_SETUP) $(VALGRIND) ./t_code
- $(RUN_SETUP) $(VALGRIND) ./t_packet $(PYTHON) $(srcdir)/t_daemon.py
- $(RUN_SETUP) $(VALGRIND) ./t_remote $(PYTHON) $(srcdir)/t_daemon.py
- $(RUN_SETUP) $(VALGRIND) ./t_client $(PYTHON) $(srcdir)/t_daemon.py
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_attr
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_attrset
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_code
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_packet $(PYTHON) $(srcdir)/t_daemon.py
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_remote $(PYTHON) $(srcdir)/t_daemon.py
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_client $(PYTHON) $(srcdir)/t_daemon.py
TESTDEPS=t_test.o $(KRB5_BASE_DEPLIBS)
TESTLIBS=t_test.o $(KRB5_BASE_LIBS)
diff --git a/src/lib/krb5/krb/Makefile.in b/src/lib/krb5/krb/Makefile.in
index 62f0b90..ba5f761 100644
--- a/src/lib/krb5/krb/Makefile.in
+++ b/src/lib/krb5/krb/Makefile.in
@@ -464,16 +464,22 @@ check-unix:: $(TEST_PROGS)
$(RM) test.out
KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
$(RUN_SETUP) $(VALGRIND) ./t_ser
- $(RUN_SETUP) $(VALGRIND) ./t_deltat
- $(RUN_SETUP) $(VALGRIND) sh $(srcdir)/transit-tests
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_deltat
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) sh $(srcdir)/transit-tests
KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
$(RUN_SETUP) $(VALGRIND) sh $(srcdir)/walktree-tests
KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
- $(RUN_SETUP) $(VALGRIND) ./t_authdata
- $(RUN_SETUP) $(VALGRIND) ./t_pac
- $(RUN_SETUP) $(VALGRIND) ./t_princ
- $(RUN_SETUP) $(VALGRIND) ./t_etypes
- $(RUN_SETUP) $(VALGRIND) ./t_response_items
+ $(RUN_SETUP) $(VALGRIND) ./t_authdata
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_pac
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_princ
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_etypes
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
+ $(RUN_SETUP) $(VALGRIND) ./t_response_items
KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
$(RUN_SETUP) $(VALGRIND) ./t_copy_context
diff --git a/src/lib/krb5/os/Makefile.in b/src/lib/krb5/os/Makefile.in
index 1bd8573..b87e7f9 100644
--- a/src/lib/krb5/os/Makefile.in
+++ b/src/lib/krb5/os/Makefile.in
@@ -233,6 +233,7 @@ check-unix-locate:: t_locate_kdc
check-unix-trace:: t_trace
rm -f t_trace.out
KRB5_TRACE=t_trace.out ; export KRB5_TRACE ; \
+ KRB5_CONFIG=$(srcdir)/t_krb5.conf ; export KRB5_CONFIG ;\
$(RUN_SETUP) $(VALGRIND) ./t_trace
sed -e 's/^[^:]*: //' t_trace.out | cmp - $(srcdir)/t_trace.ref
rm -f t_trace.out

View File

@ -43,7 +43,7 @@
Summary: The Kerberos network authentication system
Name: krb5
Version: 1.14
Release: 1%{?dist}
Release: 2%{?dist}
# - Maybe we should explode from the now-available-to-everybody tarball instead?
# http://web.mit.edu/kerberos/dist/krb5/1.13/krb5-1.13.2-signed.tar
# - The sources below are stored in a lookaside cache. Upload with
@ -81,6 +81,7 @@ Patch60: krb5-1.12.1-pam.patch
Patch134: krb5-1.11-kpasswdtest.patch
Patch143: krb5-tests_use_libs_from_build.patch
Patch145: krb5-1.14-ss_execute_command-missing.patch
Patch146: krb5-1.14-no_system_krb5_conf.patch
License: MIT
URL: http://web.mit.edu/kerberos/www/
@ -251,7 +252,8 @@ ln NOTICE LICENSE
%patch134 -p1 -b .kpasswdtest
%patch143 -p1 -b .krb5-tests_use_libs_from_build
%patch145 -p1 -b .ss_execute_command
%patch146 -p1 -b .no_system_krb5_conf
# Take the execute bit off of documentation.
chmod -x doc/krb5-protocol/*.txt doc/ccapi/*.html
@ -425,6 +427,9 @@ mkdir -p $RPM_BUILD_ROOT%{_var}/kerberos/krb5/user
mkdir -p $RPM_BUILD_ROOT/etc
install -pm 644 %{SOURCE6} $RPM_BUILD_ROOT/etc/krb5.conf
# Default include on this directory
mkdir -p $RPM_BUILD_ROOT/etc/krb5.conf.d
# Parent of configuration file for list of loadable GSS mechs ("mechs"). This
# location is not relative to sysconfdir, but is hard-coded in g_initialize.c.
mkdir -m 755 -p $RPM_BUILD_ROOT/etc/gss
@ -768,6 +773,7 @@ exit 0
# These are hard-coded, not-dependent-on-the-configure-script paths.
%dir /etc/gss
%dir /etc/gss/mech.d
%dir /etc/krb5.conf.d
%verify(not md5 size mtime) %config(noreplace) /etc/krb5.conf
/%{_mandir}/man5/.k5identity.5*
/%{_mandir}/man5/.k5login.5*
@ -860,6 +866,10 @@ exit 0
%changelog
* Tue Sep 29 2015 Robbie Harwood <rharwood@redhat.com> - 1.14-2
- Patch around bad system krb5.conf in test suite
- Reinstate /etc/krb5.conf.d
* Wed Sep 23 2015 Robbie Harwood <rharwood@redhat.com> - 1.14-1
- New upstream version; krb5-1.14-alpha1
- Drop patches that have since been applied