Fix typo in 3des commit
This commit is contained in:
parent
7bee5f19e1
commit
490a817464
@ -1,4 +1,4 @@
|
||||
From cac8b2d0da82fd625da0a351bb80b51a0bb811a2 Mon Sep 17 00:00:00 2001
|
||||
From c524c375aef17009e3dcca4a2001e102e022c24b Mon Sep 17 00:00:00 2001
|
||||
From: Robbie Harwood <rharwood@redhat.com>
|
||||
Date: Tue, 26 Mar 2019 18:51:10 -0400
|
||||
Subject: [PATCH] Remove 3des support
|
||||
@ -8,7 +8,7 @@ des3-hmac-sha1, des3-cbc-sha1-kd). Update all tests and documentation
|
||||
to user other enctypes. Mark the 3DES enctypes UNSUPPORTED and retain
|
||||
their constants.
|
||||
|
||||
(cherry picked from commit 49b086ddbf861ad0e2e84c402f3d65e9ea8a2392)
|
||||
(cherry picked from commit 57a8a84e035000b515ca9efd56e5cbe1568b95e7)
|
||||
---
|
||||
doc/admin/advanced/retiring-des.rst | 11 +
|
||||
doc/admin/conf_files/kdc_conf.rst | 7 +-
|
||||
@ -18,7 +18,7 @@ their constants.
|
||||
doc/mitK5features.rst | 2 +-
|
||||
src/Makefile.in | 4 +-
|
||||
src/configure.in | 1 -
|
||||
src/include/krb5/krb5.hin | 12 +-
|
||||
src/include/krb5/krb5.hin | 10 +-
|
||||
src/kadmin/testing/proto/kdc.conf.proto | 4 +-
|
||||
src/kdc/kdc_util.c | 4 -
|
||||
src/lib/crypto/Makefile.in | 8 +-
|
||||
@ -105,7 +105,7 @@ their constants.
|
||||
src/tests/t_salt.py | 5 +-
|
||||
src/util/k5test.py | 10 -
|
||||
.../leash/htmlhelp/html/Encryption_Types.htm | 13 -
|
||||
95 files changed, 163 insertions(+), 4837 deletions(-)
|
||||
95 files changed, 162 insertions(+), 4836 deletions(-)
|
||||
delete mode 100644 src/lib/crypto/builtin/des/ISSUES
|
||||
delete mode 100644 src/lib/crypto/builtin/des/Makefile.in
|
||||
delete mode 100644 src/lib/crypto/builtin/des/d3_aead.c
|
||||
@ -302,15 +302,9 @@ index 8d781a7c8..a19a0ea97 100644
|
||||
lib/crypto/$CRYPTO_IMPL/sha1 lib/crypto/$CRYPTO_IMPL/sha2
|
||||
lib/crypto/$CRYPTO_IMPL/aes lib/crypto/$CRYPTO_IMPL/camellia
|
||||
diff --git a/src/include/krb5/krb5.hin b/src/include/krb5/krb5.hin
|
||||
index 5f596d1fc..ca7eb6a80 100644
|
||||
index 5f596d1fc..9a05ce32d 100644
|
||||
--- a/src/include/krb5/krb5.hin
|
||||
+++ b/src/include/krb5/krb5.hin
|
||||
@@ -1,4 +1,4 @@
|
||||
-/* -*- mode: c; c-basic-offset: 4; indent-tabs-mode: nil -*- */
|
||||
+./* -*- mode: c; c-basic-offset: 4; indent-tabs-mode: nil -*- */
|
||||
/* General definitions for Kerberos version 5. */
|
||||
/*
|
||||
* Copyright 1989, 1990, 1995, 2001, 2003, 2007, 2011 by the Massachusetts
|
||||
@@ -426,8 +426,8 @@ typedef struct _krb5_crypto_iov {
|
||||
#define ENCTYPE_DES_CBC_MD4 0x0002 /**< @deprecated no longer supported */
|
||||
#define ENCTYPE_DES_CBC_MD5 0x0003 /**< @deprecated no longer supported */
|
||||
|
@ -18,7 +18,7 @@ Summary: The Kerberos network authentication system
|
||||
Name: krb5
|
||||
Version: 1.17
|
||||
# for prerelease, should be e.g., 0.% {prerelease}.1% { ?dist } (without spaces)
|
||||
Release: 32%{?dist}
|
||||
Release: 33%{?dist}
|
||||
|
||||
# lookaside-cached sources; two downloads and a build artifact
|
||||
Source0: https://web.mit.edu/kerberos/dist/krb5/1.17/krb5-%{version}%{prerelease}.tar.gz
|
||||
@ -719,6 +719,9 @@ exit 0
|
||||
%{_libdir}/libkadm5srv_mit.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 26 2019 Robbie Harwood <rharwood@redhat.com> - 1.17-33
|
||||
- Fix typo in 3des commit
|
||||
|
||||
* Wed Jun 26 2019 Robbie Harwood <rharwood@redhat.com> - 1.17-32
|
||||
- Remove PKINIT draft9 support (compat with EOL, pre-2008 Windows)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user