- override the default build rules to not delete temporary y.tab.c files,

so that they can be packaged, allowing debuginfo files which point to them
  do so usefully (#729044)
This commit is contained in:
Nalin Dahyabhai 2011-08-08 18:39:55 -04:00
parent ad0dcf5042
commit 0ad36e9c38
2 changed files with 34 additions and 1 deletions

26
krb5-1.9-debuginfo.patch Normal file
View File

@ -0,0 +1,26 @@
We want to keep these y.tab.c files around because the debuginfo points to
them. It would be more elegant at the end to use symbolic links, but that
could mess up people working in the tree on other things.
--- src/kadmin/cli/Makefile.in
+++ src/kadmin/cli/Makefile.in
@@ -43,3 +43,8 @@ clean-unix::
# CC_LINK is not meant for compilation and this use may break in the future.
datetest: getdate.c
$(CC_LINK) $(ALL_CFLAGS) -DTEST -o datetest getdate.c
+
+%.c: %.y
+ $(RM) y.tab.c $@
+ $(YACC.y) $<
+ $(CP) y.tab.c $@
--- src/plugins/kdb/ldap/ldap_util/Makefile.in
+++ src/plugins/kdb/ldap/ldap_util/Makefile.in
@@ -22,7 +22,7 @@ $(PROG): $(OBJS) $(KADMSRV_DEPLIBS) $(KR
getdate.c: $(GETDATE)
$(RM) getdate.c y.tab.c
$(YACC) $(GETDATE)
- $(MV) y.tab.c getdate.c
+ $(CP) y.tab.c getdate.c
install::
$(INSTALL_PROGRAM) $(PROG) ${DESTDIR}$(ADMIN_BINDIR)/$(PROG)

View File

@ -6,7 +6,7 @@
Summary: The Kerberos network authentication system
Name: krb5
Version: 1.9.1
Release: 8%{?dist}
Release: 9%{?dist}
# Maybe we should explode from the now-available-to-everybody tarball instead?
# http://web.mit.edu/kerberos/dist/krb5/1.9/krb5-1.9.1-signed.tar
Source0: krb5-%{version}.tar.gz
@ -59,6 +59,7 @@ Patch82: krb5-1.9.1-ai_addrconfig.patch
Patch83: krb5-1.9.1-ai_addrconfig2.patch
Patch84: krb5-1.9.1-sendto_poll.patch
Patch85: krb5-trunk-gss_delete_sec.patch
Patch86: krb5-1.9-debuginfo.patch
License: MIT
URL: http://web.mit.edu/kerberos/www/
@ -209,6 +210,7 @@ ln -s NOTICE LICENSE
%patch83 -p0 -b .ai_addrconfig2
%patch84 -p0 -b .sendto_poll
%patch85 -p1 -b .gss_delete_sec
%patch86 -p0 -b .debuginfo
gzip doc/*.ps
sed -i -e '1s!\[twoside\]!!;s!%\(\\usepackage{hyperref}\)!\1!' doc/api/library.tex
@ -668,6 +670,11 @@ exit 0
%{_sbindir}/uuserver
%changelog
* Mon Aug 8 2011 Nalin Dahyabhai <nalin@redhat.com> 1.9.1-9
- override the default build rules to not delete temporary y.tab.c files,
so that they can be packaged, allowing debuginfo files which point to them
do so usefully (#729044)
* Fri Jul 22 2011 Nalin Dahyabhai <nalin@redhat.com> 1.9.1-8
- build shared libraries with partial RELRO support (#723995)
- filter out potentially multiple instances of -Wl,-z,relro from krb5-config