parent
2f3f20f718
commit
0429334fa0
@ -1,52 +1,41 @@
|
||||
From 117f6e415238b507a42cbc3ccdb45ad8408bfdfd Mon Sep 17 00:00:00 2001
|
||||
From e60e5e0a8e8e98edae8c678e5c300b30368006fb Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Mon, 7 Mar 2016 17:59:07 +0100
|
||||
Subject: [PATCH] Add tests for send and receive sendto_kdc hooks
|
||||
Subject: [PATCH 2/2] Add tests for send and receive sendto_kdc hooks
|
||||
|
||||
[ghudson@mit.edu: style changes]
|
||||
|
||||
ticket: 8386
|
||||
|
||||
Conflicts:
|
||||
src/tests/Makefile.in
|
||||
[rharwood@redhat.com: fix cherry-pick merge conflicts]
|
||||
[rharwood@redhat.com: remove references to .gitignore]
|
||||
---
|
||||
.gitignore | 1 +
|
||||
src/tests/Makefile.in | 18 ++--
|
||||
src/tests/Makefile.in | 12 ++-
|
||||
src/tests/deps | 10 ++
|
||||
src/tests/hooks.c | 253 ++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
src/tests/t_hooks.py | 9 ++
|
||||
5 files changed, 284 insertions(+), 7 deletions(-)
|
||||
5 files changed, 281 insertions(+), 4 deletions(-)
|
||||
create mode 100644 src/tests/hooks.c
|
||||
create mode 100755 src/tests/t_hooks.py
|
||||
|
||||
diff --git a/.gitignore b/.gitignore
|
||||
index d424019..fdc62f9 100644
|
||||
--- a/.gitignore
|
||||
+++ b/.gitignore
|
||||
@@ -361,6 +361,7 @@ local.properties
|
||||
/src/tests/etinfo
|
||||
/src/tests/gcred
|
||||
/src/tests/hist
|
||||
+/src/tests/hooks
|
||||
/src/tests/hrealm
|
||||
/src/tests/icred
|
||||
/src/tests/kdbtest
|
||||
diff --git a/src/tests/Makefile.in b/src/tests/Makefile.in
|
||||
index 4ab8e6e..d060513 100644
|
||||
index b24e197..0fc0ea9 100644
|
||||
--- a/src/tests/Makefile.in
|
||||
+++ b/src/tests/Makefile.in
|
||||
@@ -6,10 +6,10 @@ SUBDIRS = resolve asn.1 create hammer verify gssapi dejagnu shlib \
|
||||
@@ -6,9 +6,9 @@ SUBDIRS = resolve asn.1 create hammer verify gssapi dejagnu shlib \
|
||||
RUN_DB_TEST = $(RUN_SETUP) KRB5_KDC_PROFILE=kdc.conf KRB5_CONFIG=krb5.conf \
|
||||
LC_ALL=C $(VALGRIND)
|
||||
|
||||
-OBJS= adata.o etinfo.o gcred.o hist.o hrealm.o icred.o kdbtest.o localauth.o \
|
||||
- plugorder.o rdreq.o responder.o s2p.o s4u2proxy.o
|
||||
-EXTRADEPSRCS= adata.c etinfo.c gcred.c hist.c hrealm.c icred.c kdbtest.c \
|
||||
- localauth.c plugorder.c rdreq.o responder.c s2p.c s4u2proxy.c
|
||||
+OBJS= adata.o etinfo.o gcred.o hist.o hooks.o hrealm.o icred.o kdbtest.o \
|
||||
+ localauth.o plugorder.o rdreq.o responder.o s2p.o s4u2proxy.o
|
||||
+EXTRADEPSRCS= adata.c etinfo.c gcred.c hist.c hooks.c hrealm.c icred.c \
|
||||
+ kdbtest.c localauth.c plugorder.c rdreq.o responder.c s2p.c s4u2proxy.c
|
||||
-OBJS= adata.o etinfo.o gcred.o hist.o hrealm.o kdbtest.o plugorder.o \
|
||||
+OBJS= adata.o etinfo.o gcred.o hist.o hooks.o hrealm.o kdbtest.o plugorder.o \
|
||||
t_init_creds.o t_localauth.o rdreq.o responder.o s2p.o s4u2proxy.o
|
||||
-EXTRADEPSRCS= adata.c etinfo.c gcred.c hist.c hrealm.c kdbtest.c plugorder.c \
|
||||
+EXTRADEPSRCS= adata.c etinfo.c gcred.c hist.c hooks.c hrealm.c kdbtest.c plugorder.c \
|
||||
t_init_creds.c t_localauth.c rdreq.o responder.c s2p.c s4u2proxy.c
|
||||
|
||||
TEST_DB = ./testdb
|
||||
TEST_REALM = FOO.TEST.REALM
|
||||
@@ -33,6 +33,9 @@ gcred: gcred.o $(KRB5_BASE_DEPLIBS)
|
||||
hist: hist.o $(KDB5_DEPLIBS) $(KADMSRV_DEPLIBS) $(KRB5_BASE_DEPLIBS)
|
||||
$(CC_LINK) -o $@ hist.o $(KDB5_LIBS) $(KADMSRV_LIBS) $(KRB5_BASE_LIBS)
|
||||
@ -61,26 +50,25 @@ index 4ab8e6e..d060513 100644
|
||||
$(RUN_DB_TEST) ../kadmin/dbutil/kdb5_util $(KADMIN_OPTS) destroy -f
|
||||
$(RM) $(TEST_DB)* stash_file
|
||||
|
||||
-check-pytests:: adata etinfo gcred hist hrealm icred kdbtest localauth
|
||||
+check-pytests:: adata etinfo gcred hist hooks hrealm icred kdbtest localauth
|
||||
check-pytests:: plugorder rdreq responder s2p s4u2proxy unlockiter
|
||||
-check-pytests:: adata etinfo gcred hist hrealm kdbtest plugorder rdreq
|
||||
+check-pytests:: adata etinfo gcred hist hooks hrealm kdbtest plugorder rdreq
|
||||
check-pytests:: responder s2p s4u2proxy t_init_creds t_localauth unlockiter
|
||||
$(RUNPYTEST) $(srcdir)/t_general.py $(PYTESTFLAGS)
|
||||
+ $(RUNPYTEST) $(srcdir)/t_hooks.py $(PYTESTFLAGS)
|
||||
$(RUNPYTEST) $(srcdir)/t_dump.py $(PYTESTFLAGS)
|
||||
$(RUNPYTEST) $(srcdir)/t_iprop.py $(PYTESTFLAGS)
|
||||
$(RUNPYTEST) $(srcdir)/t_kprop.py $(PYTESTFLAGS)
|
||||
@@ -159,7 +163,7 @@ check-pytests:: plugorder rdreq responder s2p s4u2proxy unlockiter
|
||||
@@ -159,7 +163,7 @@ check-pytests:: responder s2p s4u2proxy t_init_creds t_localauth unlockiter
|
||||
$(RUNPYTEST) $(srcdir)/t_tabdump.py $(PYTESTFLAGS)
|
||||
|
||||
clean::
|
||||
- $(RM) adata etinfo gcred hist hrealm icred kdbtest localauth plugorder
|
||||
- $(RM) rdreq responder s2p s4u2proxy krb5.conf kdc.conf
|
||||
+ $(RM) adata etinfo gcred hist hooks hrealm icred kdbtest localauth
|
||||
+ $(RM) plugorder rdreq responder s2p s4u2proxy krb5.conf kdc.conf
|
||||
- $(RM) gcred hist hrealm kdbtest plugorder rdreq responder s2p
|
||||
+ $(RM) gcred hist hooks hrealm kdbtest plugorder rdreq responder s2p
|
||||
$(RM) adata etinfo gcred hist hrealm kdbtest plugorder rdreq responder
|
||||
$(RM) s2p s4u2proxy t_init_creds t_localauth krb5.conf kdc.conf
|
||||
$(RM) -rf kdc_realm/sandbox ldap
|
||||
$(RM) au.log
|
||||
diff --git a/src/tests/deps b/src/tests/deps
|
||||
index d280026..55df1a7 100644
|
||||
index de33c55..3634dc4 100644
|
||||
--- a/src/tests/deps
|
||||
+++ b/src/tests/deps
|
||||
@@ -50,6 +50,16 @@ $(OUTPRE)hist.$(OBJEXT): $(BUILDTOP)/include/autoconf.h \
|
||||
|
@ -1,7 +1,7 @@
|
||||
From fb4d426ddeb9d4802a53dfbd74189ef8eacbe65e Mon Sep 17 00:00:00 2001
|
||||
From 700f0921e891c5986e31e8394a9e7287a7c16524 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Thu, 3 Mar 2016 18:53:31 +0100
|
||||
Subject: [PATCH] Add KDC pre-send and post-receive KDC hooks
|
||||
Subject: [PATCH 1/2] Add KDC pre-send and post-receive KDC hooks
|
||||
|
||||
Add two new APIs, krb5_set_kdc_send_hook() and
|
||||
krb5_set_kdc_recv_hook(), which can be used to inspect and override
|
||||
@ -47,10 +47,10 @@ index 51c4093..dc414cf 100644
|
||||
krb5_principal.rst
|
||||
krb5_principal_data.rst
|
||||
diff --git a/src/include/k5-int.h b/src/include/k5-int.h
|
||||
index 6b36e9d..d0216d6 100644
|
||||
index 41c3d1b..a4266d9 100644
|
||||
--- a/src/include/k5-int.h
|
||||
+++ b/src/include/k5-int.h
|
||||
@@ -1242,6 +1242,12 @@ struct _krb5_context {
|
||||
@@ -1237,6 +1237,12 @@ struct _krb5_context {
|
||||
krb5_trace_callback trace_callback;
|
||||
void *trace_callback_data;
|
||||
|
||||
@ -64,10 +64,10 @@ index 6b36e9d..d0216d6 100644
|
||||
char *plugin_base_dir;
|
||||
};
|
||||
diff --git a/src/include/krb5/krb5.hin b/src/include/krb5/krb5.hin
|
||||
index 0a0d272..9e91a60 100644
|
||||
index 851cea3..59baf70 100644
|
||||
--- a/src/include/krb5/krb5.hin
|
||||
+++ b/src/include/krb5/krb5.hin
|
||||
@@ -8292,6 +8292,110 @@ krb5_set_trace_callback(krb5_context context, krb5_trace_callback fn,
|
||||
@@ -8288,6 +8288,110 @@ krb5_set_trace_callback(krb5_context context, krb5_trace_callback fn,
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
krb5_set_trace_filename(krb5_context context, const char *filename);
|
||||
|
||||
|
@ -13,7 +13,7 @@
|
||||
Summary: The Kerberos network authentication system
|
||||
Name: krb5
|
||||
Version: 1.14.1
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
# - Maybe we should explode from the now-available-to-everybody tarball instead?
|
||||
# http://web.mit.edu/kerberos/dist/krb5/1.13/krb5-1.13.2-signed.tar
|
||||
# - The sources below are stored in a lookaside cache. Upload with
|
||||
@ -778,6 +778,10 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 05 2016 Robbie Harwood <rharwood@redhat.com> - 1.14.1-5
|
||||
- Use the correct patches this time.
|
||||
- Resolves: #1321135
|
||||
|
||||
* Mon Apr 04 2016 Robbie Harwood <rharwood@redhat.com> - 1.14.1-4
|
||||
- Add send/receive sendto_kdc hooks and corresponding tests
|
||||
- Resolves: #1321135
|
||||
|
Loading…
Reference in New Issue
Block a user