import kpatch-0.6.1-1.el8
This commit is contained in:
commit
7d68549940
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/v0.6.1.tar.gz
|
1
.kpatch.metadata
Normal file
1
.kpatch.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
7a0395e649f58026a3dd66dd13e3bcecdb9e97a4 SOURCES/v0.6.1.tar.gz
|
@ -0,0 +1,46 @@
|
|||||||
|
From f056d60fb309896a52882fd3fc10fb5305f5a47e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Joe Lawrence <joe.lawrence@redhat.com>
|
||||||
|
Date: Thu, 21 Jun 2018 15:40:20 -0400
|
||||||
|
Subject: [PATCH] contrib: disable upstart kpatch.conf install
|
||||||
|
|
||||||
|
Do not install the upstart configuration file to avoid this rhpkg
|
||||||
|
build complaint:
|
||||||
|
|
||||||
|
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/kpatch-0.6.1-1.el7.noarch
|
||||||
|
error: Installed (but unpackaged) file(s) found:
|
||||||
|
/etc/init/kpatch.conf
|
||||||
|
Installed (but unpackaged) file(s) found:
|
||||||
|
/etc/init/kpatch.conf
|
||||||
|
|
||||||
|
We'll need to think of a better way to do this upstream, but for now,
|
||||||
|
just skip the unneeded file on RHEL.
|
||||||
|
|
||||||
|
Signed-off-by: Joe Lawrence <joe.lawrence@redhat.com>
|
||||||
|
---
|
||||||
|
contrib/Makefile | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/contrib/Makefile b/contrib/Makefile
|
||||||
|
index 0b0eeeb23a56..e873f27d6eae 100644
|
||||||
|
--- a/contrib/Makefile
|
||||||
|
+++ b/contrib/Makefile
|
||||||
|
@@ -6,12 +6,12 @@ install: all
|
||||||
|
$(INSTALL) -d $(SYSTEMDDIR)
|
||||||
|
$(INSTALL) -m 0644 kpatch.service $(SYSTEMDDIR)
|
||||||
|
sed -i 's~PREFIX~$(PREFIX)~' $(SYSTEMDDIR)/kpatch.service
|
||||||
|
- $(INSTALL) -d $(UPSTARTDIR)
|
||||||
|
- $(INSTALL) -m 0644 kpatch.conf $(UPSTARTDIR)
|
||||||
|
- sed -i 's~PREFIX~$(PREFIX)~' $(UPSTARTDIR)/kpatch.conf
|
||||||
|
+# $(INSTALL) -d $(UPSTARTDIR)
|
||||||
|
+# $(INSTALL) -m 0644 kpatch.conf $(UPSTARTDIR)
|
||||||
|
+# sed -i 's~PREFIX~$(PREFIX)~' $(UPSTARTDIR)/kpatch.conf
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
$(RM) $(SYSTEMDDIR)/kpatch.service
|
||||||
|
- $(RM) $(UPSTARTDIR)/kpatch.conf
|
||||||
|
+# $(RM) $(UPSTARTDIR)/kpatch.conf
|
||||||
|
|
||||||
|
clean:
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
101
SPECS/kpatch.spec
Normal file
101
SPECS/kpatch.spec
Normal file
@ -0,0 +1,101 @@
|
|||||||
|
Name: kpatch
|
||||||
|
Version: 0.6.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Dynamic kernel patch manager
|
||||||
|
|
||||||
|
Group: System Environment/Kernel
|
||||||
|
License: GPLv2
|
||||||
|
URL: https://github.com/dynup/kpatch
|
||||||
|
Source0: https://github.com/dynup/kpatch/archive/v%{version}.tar.gz
|
||||||
|
Patch0: 0001-contrib-disable-upstart-kpatch.conf-install.patch
|
||||||
|
|
||||||
|
Requires: bash kmod binutils
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
kpatch is a dynamic kernel patch module manager. It allows the user to manage
|
||||||
|
a collection of binary kernel patch modules which can be used to dynamically
|
||||||
|
patch the kernel without rebooting.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
make -C man
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install PREFIX=/usr DESTDIR=%{buildroot} -C kpatch
|
||||||
|
make install PREFIX=/usr DESTDIR=%{buildroot} -C man
|
||||||
|
make install PREFIX=/usr DESTDIR=%{buildroot} -C contrib
|
||||||
|
rm -f %{buildroot}/usr/share/man/man1/kpatch-build.1.gz
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_sbindir}/kpatch
|
||||||
|
%{_usr}/lib/systemd/system/kpatch.service
|
||||||
|
%doc %{_mandir}/man1/kpatch.1.gz
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 14 2018 Joe Lawrence <joe.lawrence@redhat.com> 0.6.1-1
|
||||||
|
- update to 0.6.1 (rhbz#1615880)
|
||||||
|
|
||||||
|
* Mon Aug 13 2018 Troy Dawson <tdawson@redhat.com> - 0.4.0-4
|
||||||
|
- Release Bumped for el8 Mass Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 16 2017 Joe Lawrence <joe.lawrence@redhat.com> 0.4.0-3
|
||||||
|
- kpatch: better livepatch module support (rhbz#1504066)
|
||||||
|
|
||||||
|
* Wed Oct 18 2017 Josh Poimboeuf <jpoimboe@redhat.com> 0.4.0-2
|
||||||
|
- fix backwards compatibility with RHEL 7.3 patches (rhbz#1497735)
|
||||||
|
|
||||||
|
* Mon Mar 13 2017 Josh Poimboeuf <jpoimboe@redhat.com> 0.4.0-1
|
||||||
|
- update to 0.4.0 (rhbz#1427642)
|
||||||
|
|
||||||
|
* Wed Jun 15 2016 Josh Poimboeuf <jpoimboe@redhat.com> 0.3.2-1
|
||||||
|
- update to 0.3.2 (rhbz#1282508)
|
||||||
|
|
||||||
|
* Wed Nov 18 2015 Josh Poimboeuf <jpoimboe@redhat.com> 0.3.1-1
|
||||||
|
- update to 0.3.1 (rhbz#1282508)
|
||||||
|
|
||||||
|
* Tue Sep 16 2014 Seth Jennings <sjenning@redhat.com> 0.1.10-4
|
||||||
|
- fix dracut dependencies (rhbz#1170369)
|
||||||
|
|
||||||
|
* Tue Sep 16 2014 Seth Jennings <sjenning@redhat.com> 0.1.10-3
|
||||||
|
- support re-enabling forced modules (rhbz#1140268)
|
||||||
|
|
||||||
|
* Thu Sep 11 2014 Seth Jennings <sjenning@redhat.com> 0.1.10-2
|
||||||
|
- support modprobe format names (rhbz#1133045)
|
||||||
|
|
||||||
|
* Thu Jul 31 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.10-1
|
||||||
|
- update to kpatch 0.1.10
|
||||||
|
|
||||||
|
* Wed Jul 23 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.9-1
|
||||||
|
- update to kpatch 0.1.9
|
||||||
|
|
||||||
|
* Tue Jul 15 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.8-1
|
||||||
|
- update to kpatch 0.1.8
|
||||||
|
|
||||||
|
* Wed May 21 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.2-1
|
||||||
|
- update to kpatch 0.1.2
|
||||||
|
|
||||||
|
* Mon May 19 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.1-2
|
||||||
|
- fix initramfs core module path
|
||||||
|
|
||||||
|
* Mon May 19 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.1-1
|
||||||
|
- rebase to kpatch 0.1.1
|
||||||
|
|
||||||
|
* Fri May 9 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.0-2
|
||||||
|
- modprobe core module
|
||||||
|
|
||||||
|
* Tue May 6 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.1.0-1
|
||||||
|
- Initial kpatch release 0.1.0
|
||||||
|
|
||||||
|
* Thu Jan 30 2014 Josh Poimboeuf <jpoimboe@redhat.com> 0.0-1
|
||||||
|
- Initial build
|
Loading…
Reference in New Issue
Block a user